Streaming Help

Roku's free SDK allows developers to build channels and applications and publish them to the Roku Channel Store. Register for the Developer Program at http://www.roku.com/developer

Moderators: RokuDouglas, RokuRyan, RokuJamesL, RokuKen, RokuChris, RokuJoel

Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 9:59 am

So,

I am looking for help for streaming to the Roku. I've got streaming to iPhone through Wowza going fine, both live and on-demand, but when I go to pull the exact same URL through the XML on the Roku, buffer bars come up for a split-second then go back to the previous page. When I look at the Wowza server as the stream is starting to get pulled it is showing that it is starting to create the stream only, then nothing like when I connect via iphone, where Wowza will create the stream and then return the server comment mediareaderh264cupertino.handlepacket whilst streaming the media to the iphone. While connected to telnet I get " an unexpected problem (but not server timeout or http error) has been detected. | index = -3" and also "video request failure: -3 0 ". I'm not sure what I am doing wrong here but below is what I do know:

inet connection 30mbps (tx) 10mbps (rx)
port 1935 is open
Roku firmware is update 2.7 built 857
media server = Wowza 2.1.2
Can stream live from quicktime broadcaster to iphone through wowza
can stream vod through wowza to iphone
no streaming to roku live or on demand through wowza
i've reset the roku multiple times
Can direct link to video files on server for roku to play
Video files are both mp4 and mov
no clue what smil is or how to use it :/

Anyone have any clue? I can reciprocate $$ to anyone that can help bring this to fruition. :D
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby retrotom » Mon Oct 18, 2010 10:55 am

In my experiences with the Roku, that is always related to some kind of minimum bandwidth required for video playback. I would suggest you turn on bandwidth debugging, lower the minimum bandwidth as already described on these forums, and while testing you should try to playback your stream multiple times in quick succession.
retrotom
 
Posts: 135
Joined: Mon Jul 05, 2010 7:21 pm

Re: Streaming Help

Postby TheEndless » Mon Oct 18, 2010 11:15 am

You'll also want to make sure that your stream is being encoded with the settings described by RokuMarkn here: viewtopic.php?f=34&t=31056&p=190110#p190110
RokuMarkn wrote:Yes, the audio must be AAC, not MP3. It must also be LC profile, not Main, and the ADTS headers must correctly indicate LC profile.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), MainSqueeze (MAINSQUEEZE), iTunes Podcasts (ITPC), Justin.tv (JUSTINTV), My Channels (MYCHANNELS)
User avatar
TheEndless
** Valued Community Member **
 
Posts: 7927
Joined: Mon Oct 04, 2004 10:15 am
Location: US

Re: Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 11:38 am

@retrotom - Sounds interesting, I'm going to look at that right now
@TheEndless - I checked that and it looks to be correct, from QuickTime Broadcaster it's encoding mpeg-4 and using aac-lc 80-bits/s | 48khz | 16 bit | mono
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby astudios » Mon Oct 18, 2010 1:09 pm

perhaps this will be of some help?

viewtopic.php?p=190154
astudios
 
Posts: 27
Joined: Wed Jul 14, 2010 8:22 pm

Re: Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 1:55 pm

@astudios - thanks, I keep on reading that thread over and over trying to see if something else will jump out at me. No avail. I don't understand smil files
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby cgerrish » Mon Oct 18, 2010 4:29 pm

You have to add this to get it to work
Code: Select all
videoclip.minBandwidth = 20

Chris
Northland Church
cgerrish
 
Posts: 24
Joined: Mon May 17, 2010 4:59 pm

Re: Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 5:14 pm

@chris - what file does that get added to?
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby cgerrish » Mon Oct 18, 2010 5:32 pm

Actually it will be in the showFeed.brs, and it will be
Code: Select all
item.minBandwidth = 20
cgerrish
 
Posts: 24
Joined: Mon May 17, 2010 4:59 pm

Re: Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 5:49 pm

Thanks, Chris! I'll give that a try! BTW I love your stuff!
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby ckehayias » Mon Oct 18, 2010 8:07 pm

Thanks Chris for the help today!
ckehayias
 
Posts: 3
Joined: Mon Oct 18, 2010 8:05 pm

Re: Streaming Help

Postby faithoutreachchurch » Mon Oct 18, 2010 8:58 pm

still no dice :/
faithoutreachchurch
 
Posts: 6
Joined: Mon Oct 11, 2010 3:06 pm

Re: Streaming Help

Postby ChrisDotson » Thu Nov 04, 2010 11:50 am

Any update on this? I'm having the same symptoms. The stream I'm trying to play is 900kbps, so I don't think it's a minbandwidth issue, but I'm new at this so I'm open to being TOTALLY wrong. :lol:
ChrisDotson
 
Posts: 13
Joined: Thu Nov 04, 2010 11:17 am

Re: Streaming Help

Postby RokuKevin » Tue Nov 16, 2010 3:56 pm

If you'd like to share the link to your stream, I'll take a look.

--Kevin
User avatar
RokuKevin
Roku Engineering
 
Posts: 789
Joined: Tue Sep 22, 2009 2:29 pm


Return to Roku Developer Program

Who is online

Users browsing this forum: No registered users and 2 guests