Roku 2 XD Connection problem [Error code 009]

Moderators: RokuDouglas, RokuShawnS, RokuRyan, RokuJamesL, RokuKen

Roku 2 XD Connection problem [Error code 009]

Postby pop » Fri Dec 23, 2011 1:10 am

I just bought Roku 2 XD and trying to connect to the internet.
It says "Connecting to wireless network" and
"Connecting to your local network" are Ok (indicated by green light).
However, it reports error code 009 trying to finally connect to the internet.

I have WRT54G router and have no issues with wireless connection with other laptops.
My WRT54G firmware version is v3.03.6. Also, firewall is disabled and its security
mode is "WPA Pre-Shared Key" and WPA algorithm is AES (the same error results if
this is changed to TKIP). Also, "Wireless MAC Filter" is disabled.
"Wireless SSID Broadcast" is enabled and "Wireless channel is "6-2.437GHz".

What else can I try?

TIA,

pop
pop
 
Posts: 1
Joined: Fri Dec 23, 2011 12:56 am

Re: Roku 2 XD Connection problem [Error code 009]

Postby RickRansom » Fri Dec 23, 2011 1:02 pm

Have you already tried doing a network power cycle by powering down the modem and router then booting them back up?

If so, try to pop the following numbers as your static DNS:
You'll find that under Setup > Network Address Server Settings (DHCP) > DNS
Static DNS 1: 208.67.220.220
Static DNS 2: 208.67.222.222

I did that to my Cisco E3000 and my network runs faster than it did with the default DNS I got from my ISP. :wink:
Retired
User avatar
RickRansom
 
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: Roku 2 XD Connection problem [Error code 009]

Postby RokuShawnS » Fri Dec 23, 2011 1:50 pm

pop wrote:I just bought Roku 2 XD and trying to connect to the internet.
It says "Connecting to wireless network" and
"Connecting to your local network" are Ok (indicated by green light).
However, it reports error code 009 trying to finally connect to the internet.

I have WRT54G router and have no issues with wireless connection with other laptops.
My WRT54G firmware version is v3.03.6. Also, firewall is disabled and its security
mode is "WPA Pre-Shared Key" and WPA algorithm is AES (the same error results if
this is changed to TKIP). Also, "Wireless MAC Filter" is disabled.
"Wireless SSID Broadcast" is enabled and "Wireless channel is "6-2.437GHz".

What else can I try?

TIA,

pop


I just received word that the Error Code 009 is a DNS Lookup failure. You'll want to either try a GoogleDNS or your ISP's default DNS servers (if you've already changed them to a public DNS).

C. Shawn Smith
Forum Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
User avatar
RokuShawnS
Roku Engineering
 
Posts: 4423
Joined: Thu Mar 10, 2011 2:21 pm


Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: No registered users and 17 guests