New SDK Example not working with my Feed

Roku's free SDK allows developers to build channels and applications and publish them to the Roku Channel Store. Register for the Developer Program at http://www.roku.com/developer

Moderators: RokuDouglas, RokuKen, RokuRyan, RokuJamesL, RokuChris, RokuJoel

New SDK Example not working with my Feed

Postby tgriffin19 » Fri Mar 30, 2012 1:19 pm

Hello, I have a private channel that was developed with an old sdk example application and it works fine with my feed. I downloaded new sdk and it will load my categories and subcategories but will not play my videos... any ideas? Here is a sample video category.

<feed>
<resultLength>3</resultLength><endIndex>3</endIndex>

<item sdImg="http://bvmconsole.com/roku_thumbnails/12366.png" hdImg="http://bvmconsole.com/roku_thumbnails/12366.png"><title>State Policy Network Founding Principles of Freedom </title><contentId>12366</contentId><contentType>episode</contentType><contentQuality>SD</contentQuality><media><streamFormat>hls</streamFormat><streamQuality>SD</streamQuality><streamBitrate>800</streamBitrate><streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/We-the-People_-Founding-Principles-of-Freedom_0800.mp4/playlist.m3u8</streamUrl></media><synopsis>We the People: Founding Principles of Freedom </synopsis><genres/><runtime>12000</runtime></item>

<item sdImg="http://bvmconsole.com/roku_thumbnails/12211.jpg" hdImg="http://bvmconsole.com/roku_thumbnails/12211.jpg"><title>The Poll Project</title><contentId>12211</contentId><contentType>episode</contentType><contentQuality>SD</contentQuality><media><streamFormat>hls</streamFormat><streamQuality>SD</streamQuality><streamBitrate>800</streamBitrate><streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/VotingPollsInterview_0800.mp4/playlist.m3u8</streamUrl></media><synopsis>Meet Us At The Poll, Project. Listen to the First Coast Tea Party Poll Project Team discuss their plans for getting out the vote in 2012!</synopsis><genres/><runtime>12000</runtime></item>

<item sdImg="http://bvmconsole.com/roku_thumbnails/11324.png" hdImg="http://bvmconsole.com/roku_thumbnails/11324.png"><title>Barbara Knick CPAC</title><contentId>11324</contentId><contentType>episode</contentType><contentQuality>SD</contentQuality><media><streamFormat>hls</streamFormat><streamQuality>SD</streamQuality><streamBitrate>800</streamBitrate><streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/CPAC_BarbaraKnick_0800.mp4/playlist.m3u8</streamUrl></media><synopsis>B!G with Barbara Knick Orlando FL</synopsis><genres/><runtime>12000</runtime></item>

</feed>
tgriffin19
 
Posts: 4
Joined: Sun Oct 30, 2011 1:05 am

Re: New SDK Example not working with my Feed

Postby bandal » Fri Mar 30, 2012 1:37 pm

Could be the start <> like there is no <genres> but you have <genres/> only, plus a few others without opening brackets. Tried VLC and I could not play either.
Last edited by bandal on Fri Mar 30, 2012 2:48 pm, edited 1 time in total.
bandal
 
Posts: 264
Joined: Sat Oct 15, 2011 2:17 pm

Re: New SDK Example not working with my Feed

Postby TheEndless » Fri Mar 30, 2012 2:31 pm

bandal wrote:Could be the start <> like there is no <genres> but you have <genres/> only, plus a few others without opening brackets.

<genres /> is perfectly valid XML, and is parsed properly by the Roku XML parser, so I doubt that's the issue.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), MainSqueeze (MAINSQUEEZE), iTunes Podcasts (ITPC), Justin.tv (JUSTINTV), My Channels (MYCHANNELS)
TheEndless
** Valued Community Member **
 
Posts: 7816
Joined: Mon Oct 04, 2004 10:15 am
Location: US

Re: New SDK Example not working with my Feed

Postby RokuJoel » Fri Mar 30, 2012 3:48 pm

Which example?
RokuJoel
 
Posts: 1095
Joined: Mon Nov 14, 2011 5:22 pm

Re: New SDK Example not working with my Feed

Postby tgriffin19 » Fri Mar 30, 2012 3:57 pm

The video player example.
tgriffin19
 
Posts: 4
Joined: Sun Oct 30, 2011 1:05 am

Re: New SDK Example not working with my Feed

Postby RokuChris » Fri Mar 30, 2012 5:52 pm

I think the problem may be that your <streamFormat> element is subordinate to your <media> element. If you look at showFeed.brs, the paring logic expects the streamFormat element to be subordinate to the <item> element.
RokuChris
 
Posts: 1036
Joined: Mon Aug 30, 2010 1:45 pm

Re: New SDK Example not working with my Feed

Postby destruk » Fri Mar 30, 2012 6:01 pm

XML is easier to read if you format it like this

Code: Select all
<feed>
   <resultLength>3</resultLength>
   <endIndex>3</endIndex>
   
   <item sdImg="http://bvmconsole.com/roku_thumbnails/12366.png" hdImg="http://bvmconsole.com/roku_thumbnails/12366.png">
      <title>State Policy Network Founding Principles of Freedom </title>
      <contentId>12366</contentId>
      <contentType>episode</contentType>
      <contentQuality>SD</contentQuality>
      <media>
         <streamFormat>hls</streamFormat>
         <streamQuality>SD</streamQuality>
         <streamBitrate>800</streamBitrate>
         <streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/We-the-People_-Founding-Principles-of-Freedom_0800.mp4/playlist.m3u8</streamUrl>
      </media>
      <synopsis>We the People: Founding Principles of Freedom </synopsis>
      <genres/>
      <runtime>12000</runtime>
   </item>
   
   <item sdImg="http://bvmconsole.com/roku_thumbnails/12211.jpg" hdImg="http://bvmconsole.com/roku_thumbnails/12211.jpg">
      <title>The Poll Project</title>
      <contentId>12211</contentId>
      <contentType>episode</contentType>
      <contentQuality>SD</contentQuality>
      <media>
         <streamFormat>hls</streamFormat>
         <streamQuality>SD</streamQuality>
         <streamBitrate>800</streamBitrate>
         <streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/VotingPollsInterview_0800.mp4/playlist.m3u8</streamUrl>
      </media>
      <synopsis>Meet Us At The Poll, Project. Listen to the First Coast Tea Party Poll Project Team discuss their plans for getting out the vote in 2012!</synopsis>
      <genres/>
      <runtime>12000</runtime>
   </item>
   
   <item sdImg="http://bvmconsole.com/roku_thumbnails/11324.png" hdImg="http://bvmconsole.com/roku_thumbnails/11324.png">
      <title>Barbara Knick CPAC</title>
      <contentId>11324</contentId>
      <contentType>episode</contentType>
      <contentQuality>SD</contentQuality>
      <media>
         <streamFormat>hls</streamFormat>
         <streamQuality>SD</streamQuality>
         <streamBitrate>800</streamBitrate>
         <streamUrl>http://wfs.mp.advection.net/vod/mp/bigvoicesmedia/BVMedia101/_dld/CPAC_BarbaraKnick_0800.mp4/playlist.m3u8</streamUrl>
      </media>
      <synopsis>B!G with Barbara Knick Orlando FL</synopsis>
      <genres/>
      <runtime>12000</runtime>
   </item>
</feed>


That being said, I don't see any problems with your xml - like you said it is parsing and displaying your feed just fine, but it won't play the videos, so I'd guess it could be something different elsewhere. Or what RokuChris said, lol... :)
destruk
 
Posts: 1787
Joined: Sat Dec 18, 2010 4:58 pm

Re: New SDK Example not working with my Feed

Postby mkenya » Mon Jun 11, 2012 6:52 am

Did you get it to work. I can't gt mine to play either.
mkenya
 
Posts: 15
Joined: Mon May 28, 2012 4:17 pm


Return to Roku Developer Program

Who is online

Users browsing this forum: No registered users and 1 guest