5.1 on Marantz Receiver - HELP!

Moderators: RokuDouglas, RokuShawnS, RokuRyan, RokuJamesL, RokuKen

5.1 on Marantz Receiver - HELP!

Postby Smeg » Fri Apr 20, 2012 5:40 pm

I have a Roku 2 XS connected to my AV receiver via HDMI, and I have my audio settings set to 5.1.

My receiver is a Marantz SR7002, which is capable of decoding DD+. I have my receiver set to auto mode, which is supposed to automatically detect the appropriate audio mode to go to when the signal is passed to it. This works perfectly on my blu ray player, but it doesn't seem to be working with Roku. I tried manually cycling through all of the audio modes when I started a 5.1 program, but the 5.1 mode never kicked in on my receiver.

I tried using the Source Direct mode as was recommended for Denon receivers in one of the other threads, but that did not fix the issue either.

Any help is appreciated!
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby philsoft » Fri Apr 20, 2012 5:59 pm

Smeg wrote:I have a Roku 2 XS connected to my AV receiver via HDMI, and I have my audio settings set to 5.1.

My receiver is a Marantz SR7002, which is capable of decoding DD+. I have my receiver set to auto mode, which is supposed to automatically detect the appropriate audio mode to go to when the signal is passed to it. This works perfectly on my blu ray player, but it doesn't seem to be working with Roku. I tried manually cycling through all of the audio modes when I started a 5.1 program, but the 5.1 mode never kicked in on my receiver.

I tried using the Source Direct mode as was recommended for Denon receivers in one of the other threads, but that did not fix the issue either.

Any help is appreciated!


I can't say for your brand of receiver, but on mine there are settings for certain inputs (Video 1 for example) that can be set individually as either an Analog source (Say Component) or a digital source (Maybe HDMI or Toslink), I would check to see if such a setting is (toggleable ??) one that can be set manually, on any of the inputs.
philsoft
** Valued Community Member **
 
Posts: 4304
Joined: Wed May 06, 2009 6:26 pm
Location: Midland, Michigan

Re: 5.1 on Marantz Receiver - HELP!

Postby dboff01 » Fri Apr 20, 2012 6:55 pm

Smeg wrote:I have a Roku 2 XS connected to my AV receiver via HDMI, and I have my audio settings set to 5.1.

My receiver is a Marantz SR7002, which is capable of decoding DD+. I have my receiver set to auto mode, which is supposed to automatically detect the appropriate audio mode to go to when the signal is passed to it. This works perfectly on my blu ray player, but it doesn't seem to be working with Roku. I tried manually cycling through all of the audio modes when I started a 5.1 program, but the 5.1 mode never kicked in on my receiver.

I tried using the Source Direct mode as was recommended for Denon receivers in one of the other threads, but that did not fix the issue either.

Any help is appreciated!


I have the exact same receiver being fed by a Roku 2 XS via HDMI. I am able to receive DD+ on Netflix 5.1 content with the receiver set to Auto mode. Occasionally I get no sound, as if the receiver couldn't lock onto the stream, but it mostly works.

Are you sure you are using 5.1 content? Selecting 5.1 in the Roku audio setup menu will not automatically result in 5.1 audio being played. For Netflix, one must choose the 5.1 track specifically in the movie's audio and subtitles menu. With the latest Roku firmware, the 5.1 choice will be persistent on successive movies that have 5.1. I can't speak to other sources (Amazon, etc.) as I don't use them.
dboff01
 
Posts: 200
Joined: Thu Feb 23, 2012 2:37 pm
Location: Long Island, NY

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Fri Apr 20, 2012 7:07 pm

dboff01 wrote:
Smeg wrote:I have the exact same receiver being fed by a Roku 2 XS via HDMI. I am able to receive DD+ on Netflix 5.1 content with the receiver set to Auto mode. Occasionally I get no sound, as if the receiver couldn't recognize the stream, but it mostly works.

Are you sure you are using 5.1 content? Selecting 5.1 in the Roku audio setup menu will not automatically result in 5.1 audio being played. For Netflix, one must choose the 5.1 track specifically in the movie's audio and subtitles menu. With the latest Roku firmware, the 5.1 choice will be persistent on successive movies that have 5.1. I can't speak to other sources (Amazon, etc.) as I don't use them.


Oh, good, that gives me some hope!

Yes, I have been trying this on Netflix 5.1 content - specifically, Avengers - Earth's Mightiest Heroes and From Dusk Til Dawn. Both of them come in via stereo.

Would you mind checking your input setup so I can see where my settings might be different? I looked through them, but I didn't find any of the settings set in a state that would cause this to happen, as philsoft pointed out might be a possibility. The Roku is connected to my TV HDMI input, and the audio source for that input is set to Auto.
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby dboff01 » Fri Apr 20, 2012 7:43 pm

My Roku is feeding HDMI3 (VCR1 input) via a 6' HDMI cable. I have all my inputs using Auto mode.

I just played Dusk til Dawn in Netflix using the Dolby Digital Plus track and it worked fine.

You're sure you have selected Roku's Settings -> Audio Mode -> 5.1 surround and chosen the Dolby Digital Plus track in the movie selection?

There shouldn't really be any special settings necessary in the Receiver for the DD+ to be played.
dboff01
 
Posts: 200
Joined: Thu Feb 23, 2012 2:37 pm
Location: Long Island, NY

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Fri Apr 20, 2012 8:55 pm

OK, maybe if I list all my settings and all of the indicators on my screen, we can figure something out.

Roku 2 XS is set to 5.1 audio mode in the settings. I triple checked this.

Roku feeds HDMI 1 on my receiver.

Receiver settings:

Input > Function Input Setup > TV : AUTO, mapped to HDMI 1
Video Setup > Video convert : off, OSD info: disable, I/P convert: disable, HDMI out: OUTPUT1
Preference > HDMI Audio: Enable, HDMI LIP: Enable
Acoustic EQ > EQ Mode: Audyssey

I have the following on my receiver's display while watching From Dusk Til Dawn:

AUTO SURR SPKR A EQ DIGITAL L R
STEREO PCM

So, auto mode is selecting stereo for some reason, but I don't know why. I hope someone sees something that I'm just overlooking or not setting up right.

Thanks!
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby RickRansom » Fri Apr 20, 2012 9:06 pm

Smeg wrote:The Roku is connected to my TV HDMI input.....

I believe you should connect the Roku to your receiver and the receiver should passe the video to the TV.

Roku<HDMI>Receiver<HDMI/COMPONENT/COMPOSITE>TV

Can you try to double-check first? The Roku is a pass-through device, so unless your TV can downmix the DD+ into regular DD or pass the audio directly to the receiver, you may not get the right audio you're looking for.

----------------------
EDIT
Took to long to post. Your reply already mentioned you have the roku connected via HDMI 1 on your receiver. :mrgreen:
----------------------

BTW, it was mentioned in your receiver's manual (page 2) that the HDMI cable has to be 1.3a. Were you able to double-check this too?
Retired
User avatar
RickRansom
 
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: 5.1 on Marantz Receiver - HELP!

Postby dboff01 » Sat Apr 21, 2012 5:23 am

RickRansom wrote:
Smeg wrote:The Roku is connected to my TV HDMI input.....

----------------------
EDIT
Took to long to post. Your reply already mentioned you have the roku connected via HDMI 1 on your receiver. :mrgreen:
----------------------


The Marantz SR7002 calls the HDMI1 input the "TV" input which is what the OP was referring to.
dboff01
 
Posts: 200
Joined: Thu Feb 23, 2012 2:37 pm
Location: Long Island, NY

Re: 5.1 on Marantz Receiver - HELP!

Postby dboff01 » Sat Apr 21, 2012 5:58 am

Smeg wrote:OK, maybe if I list all my settings and all of the indicators on my screen, we can figure something out.

Roku 2 XS is set to 5.1 audio mode in the settings. I triple checked this.

Roku feeds HDMI 1 on my receiver.

Receiver settings:

Input > Function Input Setup > TV : AUTO, mapped to HDMI 1
Video Setup > Video convert : off, OSD info: disable, I/P convert: disable, HDMI out: OUTPUT1
Preference > HDMI Audio: Enable, HDMI LIP: Enable
Acoustic EQ > EQ Mode: Audyssey

I have the following on my receiver's display while watching From Dusk Til Dawn:

AUTO SURR SPKR A EQ DIGITAL L R
STEREO PCM

So, auto mode is selecting stereo for some reason, but I don't know why. I hope someone sees something that I'm just overlooking or not setting up right.

Thanks!


My Marantz settings:

FUNC INPUT SETUP
TV: AUTO 1 1 1 1
DVD AUTO 2 2 2 2
VCR1: AUTO 3 3 3 3
DSS: AUTO 4 4 4 4
AUX1: AUTO F - - *

Video Setup
Video Convert = ANA&HDMI for all inputs
TV-AUTO = DISABLE
OSD INFO = ENABLE
I/P CONVERT = ENBLE
HDMI OUT = OUTPUT1

Preferences
HDMI AUDIO = ENABLE
HDMI LIP = ENABLE

Acoustic EQ
EQ MODE = OFF

Display icons during Dusk til Dawn
Auto Surr Spkr A Digital DDDigital Icon (orange)
All 5.1 speakers shown enabled in the array
Also flashes DOLBY DIGITAL PLUS on initial start-up

I just enable/disabled Audyssey EQ and still played 5.1 either way.

I only see the PCM icon when choosing a 2.0 track from the Roku 2 XS. When I select a 5.1 source, the PCM icon disappears, I assume indicating the Roku is bitstreaming the DD+.

I also don't ever see the Stereo icon, even when playing back 2.0 from the Roku. Perhaps that is indicative of something.

EDIT: FWIW my Marantz FW version is H33 (HDMI)
dboff01
 
Posts: 200
Joined: Thu Feb 23, 2012 2:37 pm
Location: Long Island, NY

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Sat Apr 21, 2012 7:12 am

I think you might be on to something with the firmware. I never considered that. It *looks* like all of my settings should be right, especially considering yours goes to 5.1 regardless of whether the Audyssey EQ is enabled.

Thank you very much for your help. I'll go check my firmware version and update as needed. I might have to make a phone call to Marantz for help before all is said and done.
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Sat Apr 21, 2012 7:13 am

RickRansom wrote:BTW, it was mentioned in your receiver's manual (page 2) that the HDMI cable has to be 1.3a. Were you able to double-check this too?


The cable is HDMI 1.3. Should there be much of a difference between 1.3 and 1.3a cables?

Thanks for catching this. I'll see if I have a 1.3a or later cable to try out.
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Sat Apr 21, 2012 7:45 am

Well, I checked the firmware version, and it is H38, which I believe is the latest. I'll try messing with the cable.
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby RickRansom » Sat Apr 21, 2012 12:15 pm

Smeg wrote:
RickRansom wrote:BTW, it was mentioned in your receiver's manual (page 2) that the HDMI cable has to be 1.3a. Were you able to double-check this too?


The cable is HDMI 1.3. Should there be much of a difference between 1.3 and 1.3a cables?

Thanks for catching this. I'll see if I have a 1.3a or later cable to try out.

Can't say I know the answer to that, but I did a quick search and there doesn't seem to be much behind it. I can't guarantee the cable would fix it, but it's wort a try. I'm just interested in what's going to be the fix for this. I'm waiting for my Pioneer receiver to reach my doorstep sometime early next week. My receiver probably costs a third compared to that of yours, but since it also does DD+ and all that shenanigans, I wanna know(and know the fixes) of whatever bug I may come across. Hope you get yours sorted out soon. :wink:
Retired
User avatar
RickRansom
 
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: 5.1 on Marantz Receiver - HELP!

Postby Smeg » Sat Apr 21, 2012 1:07 pm

So, I ordered a couple of new cables from Amazon as I didn't have any laying around that indicated to me they were more recent than 1.3. I'll post back if I find a solution, but for now, I might be stumped.

I'm going to try to make my settings identical to dboff01's tonight to see if that works, and I'll call Marantz on Monday.
Smeg
 
Posts: 9
Joined: Fri Apr 20, 2012 5:31 pm

Re: 5.1 on Marantz Receiver - HELP!

Postby __5 » Sat Apr 21, 2012 4:26 pm

Smeg wrote:I have a Roku 2 XS connected to my AV receiver via HDMI, and I have my audio settings set to 5.1.

My receiver is a Marantz SR7002, which is capable of decoding DD+. I have my receiver set to auto mode, which is supposed to automatically detect the appropriate audio mode to go to when the signal is passed to it. This works perfectly on my blu ray player, but it doesn't seem to be working with Roku. I tried manually cycling through all of the audio modes when I started a 5.1 program, but the 5.1 mode never kicked in on my receiver.

I tried using the Source Direct mode as was recommended for Denon receivers in one of the other threads, but that did not fix the issue either.

Any help is appreciated!

Try this,

  1. Turn “OFF” all connected devices (Roku/TV/AVR/BDP/STB/…) and unplug Power cords then HDMI cables (& any cable connected to the AVR) -
    – wait 10 min – (if the TV status-light still “On” wait until it goes “OFF”) - first; re-plug HDMI cables then Power cords to ONLY Roku, TV and AVR .

  2. On Roku’s side set the follow,
    1. Select a [5.1] Netflix title –> within the Netflix title you find “Audio & subtitle” (a pull-down-menu) –> select “5.1 Dolby Digital Plus” (note; this audio-setting-option applies to only Netflix channel).
    2. From Roku’s Home screen >Settings > Audio mode > select ‘Stereo’ or ‘5.1 Sound’ ( note; this audio-setting-option doesn’t apply to Netflix channel, but applies to Amazon channel & others).
  3. On AVR’s side set the follow,
    1. Press “PURE DIRECT” toggle button on the Front-Panel and select “SOURCE DIRECT”.
    2. INPUT SETUP > “5.1CH” (not “7.1CH”) - disable SL & SR speakers from settings (if they active).
    3. INPUT SETUP > TV: HDMI, mapped to HDMI 1
    4. PREFERENCE > HDMI AUDIO: “ENABLE”
    5. ACOUSTIC EQ > EQ MODE: OFF
    6. VIDEO SETUP > HDMI OUT: OUTPUT1
    7. VIDEO SETUP > TV-AUTO: DISABLE
    8. VIDEO SETUP > OSD INFO: ENABLE
    9. VIDEO SETUP > I/P CONVERT: DISABLE
    10. VIDEO CONVERT > TV: OFF
    11. Reboot the AVR (turn it off/on).
    12. Stream a [5.1] Netflix title.
  4. If the above didn’t help, change the above step “a” from “SOURCE DIRECT” to “Auto” Surround Mode, by Pressing “Auto” button on the Front-Panel & reboot the AVR before streaming.

  5. As for “High-Speed” HDMI cable vs “Standard” HDMI cable – click here.

Good luck
__5
** Valued Community Member **
 
Posts: 1088
Joined: Tue Dec 23, 2008 7:51 pm

Next

Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: bvd1022 and 19 guests