pink screen? handshake issue?

Moderators: RokuDouglas, RokuShawnS, RokuRyan, RokuJamesL, RokuKen

Re: pink screen? handshake issue?

Postby d6500k » Thu Nov 22, 2012 12:47 pm

It's simple boys.....

The roku outputs 0-255 when also outputting DD+ or 5.1DD. Period

It does not matter what mode the Onkyo or I'm pretty sure any other DVR is in the stream.

Fact of the matter is that ONLY THOSE TV's THAT HAVE BEEN CALIBRATED TO DISPLAY A CORRECT BLACK LEVEL, will display the issue to any degree. In addition, only someone that has calibrated their TV AND has a discerning eye, would ever notice or care.

The Pink Screen Effect (where this all started) has been repeated, repeatedly. That fix needs to be assessed and corrected by ROKU in conjunction with all manufacturers they can connect their product to.

So, on this Thanksgiving, I bid you all adieu, adios and So Long.

Sincerely,

Doug k
d6500k
 
Posts: 96
Joined: Fri May 18, 2012 4:02 pm

Re: pink screen? handshake issue?

Postby __5 » Thu Nov 22, 2012 12:57 pm

david0406 wrote:How is the black level holding up so fare? (w/“Normal” & “Direct”)

Fine. Why is the Roku2 input the only input on the TV that I can adjust the HDMI Black level on. Every other device grays out the HDMI black level.



- No more “black crush”? after switching between inputs or audio 5.1/srereo?
This seems fine also


Is the “pink screen” your only issue left? (w/”Custom & “Direct)
Yes.This is still an issue whether or not I have the picture mode on the AVR set in "direct " or " custom" . Mostly I am toggling back and forth between the STB and the Roku2. It failed to make the handshake just about everytime I did it. I spent 2 hours playing with settings till 2AM. I'm just about ready to give up on this issue. It's only a handshake issue and powering off the TV or the AVR establishes the handshake again but going back to when I started this thread the Roku2 is the only device that has this handshake issue in my setup.

Btw, did you see the “pink screen” during test #2, #3, #4?(w/”Custom or “Direct)
No. Not while I was toggling back and forth during testing but I only had the Roku2 HDMI connected to the AVR when I was doing this testing.

Could you check something for me? From your “STB cable/Sat box” “settings menu” toggle between “YCbCr” and “RGB” - See if a “pink screen” flashes in between toggles (for less than a second, a lot more than that or non?).
After you done. set it back to YCbCr”.

For Verizon Fios my STB is a Motorola QIP-7232-2 multi room DVR. I checked the settings menu and do not see where I can change this setting you speak of. If the verbage is different for changing this on this box let me know.



Fine. Why is the Roku2 input the only input on the TV that I can adjust the HDMI Black level on. Every other device grays out the HDMI black level.

That’s good, it’s the way it should now be (I’ll explain more later...)


For Verizon Fios my STB is a Motorola QIP-7232-2 multi room DVR. I checked the settings menu and do not see where I can change this setting you speak of. If the verbage is different for changing this on this box let me know.

To open the (secret) user system menu,
- From the STB remote Control (Verizon-supplied remote) turn ON the STB -Press [Power/Off] Power button then Press [OK] button then press [menu] button (in quick succession)– a white system menu will display on the TV – Scroll down to: “Additional HDMI Settings” > Press [Ok] > Scroll down to “YCbCr” / “RGB”.
- To exit menu, press [Power/On]
- To turn STB On, press [Power/On]again.

Also, change the STB resolution to 720P. (from that menu)


Btw, do you have all AVR HDMI inputs set to “Direct”?

#7 is important. :idea: - also, add to #7 this > set all devices (BDP, STB, WD, etc…) to 720p (not Auto) then turn Off/On all before testing.

Don’t give up yet, help is on the way :D



-----------------------------------------------------------------------------------------------------------------------------------------
:idea: FYI, did you know HDMI 1.4 specification have now five HDMI cable types to choose from. read here.
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: pink screen? handshake issue?

Postby david0406 » Thu Nov 22, 2012 7:38 pm

To open the (secret) user system menu,
- From the STB remote Control (Verizon-supplied remote) turn ON the STB -Press [Power/Off] Power button then Press [OK] button then press [menu] button (in quick succession)– a white system menu will display on the TV – Scroll down to: “Additional HDMI Settings” > Press [Ok] > Scroll down to “YCbCr” / “RGB”.
- To exit menu, press [Power/On]
- To turn STB On, press [Power/On]again.

Also, change the STB resolution to 720P. (from that menu)

Menu states HDMI/YPbPr output 720p. Only other color space setting is YCC 4:4:4
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue?

Postby __5 » Fri Nov 23, 2012 3:50 am

david0406 wrote:To open the (secret) user system menu,
- From the STB remote Control (Verizon-supplied remote) turn ON the STB -Press [Power/Off] Power button then Press [OK] button then press [menu] button (in quick succession)– a white system menu will display on the TV – Scroll down to: “Additional HDMI Settings” > Press [Ok] > Scroll down to “YCbCr” / “RGB”.
- To exit menu, press [Power/On]
- To turn STB On, press [Power/On]again.

Also, change the STB resolution to 720P. (from that menu)

Menu states HDMI/YPbPr output 720p. Only other color space setting is YCC 4:4:4



Looking now at your (second) “Pink screen” (HDCP error) issue. i got few Qs. :)


9. From your “STB” “user system menu” toggle between “YCC 4:4:4” and “RGB” - see if a “Pink screen” flashes in between toggles for, a) less than a second. b) a lot more than that. c) none?

    - Then set it to “RGB”.
    - Exit menu, (press [Power/On]), turn STB back On, (press [Power/On] again).
    - Switch back and forth between inputs.
    - Do you see a “Pink screen” ?

To toggle between “YCC 4:4:4” and “RGB”, scroll to “Color space:” then Press [Ok] and wait…

Also, (from that menu) set “Audio output:” to “Pass through” (not Auto or L-PCM)
Try not to change any thing else (only “720p”, “color space” & Audio output:”).


---------------------


10. When,
    - The AVR Picture mode is set to “Direct” on all HDMI inputs (1,2,3,4,5 & AUX)
    - The TV “HDMI black level is set to “Normal”.
    - The video resolution is set to 720p (not ‘Auto”) on all devices (BDP, STB, WD).
    - The RGB range is set to “YCbCr” (not “Auto”) on all devices (set BDP > “YCbCr” - STB > “YCC 4:4:4” - WD > “YCbCr”).
      or if, the RGB range is set to “RGB” (not “Auto”) on all devices (set BDP > RGB - STB > RGB - WD > “RGB Low”) .
Qs,
    The “Pink screen” issue happens,
      - when you switch back and forth between Roku and the STB inputs only?
      - or, When you switch back and forth between any inputs (including BDP & WD)?
      - No more “Pink screen” issue?

    As you switch between inputs and if the “Pink screen” shows up
      - Doest it display at first on the STB input or at first on Roku input?
      - By turning Off/On (only) the TV or (only) the AVR, does the “Pink screen” (HDCP error) clears?
      - If the STB is turned Off, (or its hdmi cable is unplugged from the AVR), does “Pink screen” shows up?



-----------------------------------------------------------------------------------------------------------------------------------------
:idea: FYI, did you know HDMI 1.4 specification have now five HDMI cable types to choose from. read here.
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: pink screen? handshake issue?

Postby david0406 » Fri Nov 23, 2012 5:43 am

Qs,
The “Pink screen” issue happens,
- when you switch back and forth between Roku and the STB inputs only?
- or, When you switch back and forth between any inputs (including BDP & WD)?
- No more “Pink screen” issue?

Before I attempt to decipher MORE tests :( . With multiple attempts this morning this " Pink Screen" issue appears to only be occuring when switching between the STB inputs and the Roku2 input after streaming DD+ 5.1. I made attempts to switch between the BDP, WDTV live and the Roku2 after streaming DD+ and no " Pink screen" occurred. So i think it would be reasonable to say that only my STB is creating this issue. :D

By turning Off/On (only) the TV or (only) the AVR, does the “Pink screen” (HDCP error) clears?

Yes. Either one.

9. From your “STB” “user system menu” toggle between “YCC 4:4:4” and “RGB”

Is YPbPr currently on my STB what you call "RGB" ?
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue?

Postby __5 » Fri Nov 23, 2012 6:02 am

david0406 wrote:.... So i think it would be reasonable to say that only my STB is creating this issue. :D


Ok. :D


9. From your “STB” “user system menu” toggle between “YCC 4:4:4” and “RGB”

Is YPbPr currently on my STB what you call "RGB" ?


"YCbCr" (“YCC 4:4:4”) is the default setting - this box has only two options “YCC 4:4:4” and “RGB”.
To toggle between “YCC 4:4:4” and “RGB”, scroll to “Color space:” then Press [Ok] and wait…



==================================

From the STB user system menu,

FYI, To toggle between settings in that menu, scroll to “that setting” then Press [Ok] and wait… (every time you Press [Ok] ...it will switch..).

1- Change video resolution on the STB,
    If you see “Native mode settings” grayed out,
    Scroll to “HDMI/YPbpr Output”,
    Press [Ok] several times & set it to “NATIVE”,
    Then “Native mode settings” should become active,
    Scroll to “Native mode settings”
    Press [Ok],
    You should see “MY TV Supports the following formats:”
    Mark only the following formats
    [ ] 1080p 30
    [ ]1080p 24
    [x]1080i
    [x]720p
    [x]480p
    [ ]480i
Return to the main menu >>


2- Set “Audio output:” to “Pass through” (not Auto or L-PCM)
Return to the main menu >>


3- Check this,
    From your “STB” “user system menu” toggle between “YCC 4:4:4” and “RGB” - see if a “Pink screen” flashes in between toggles for,
    a) less than a second.
    b) a lot more than that.
    c) none?
Return to the main menu >>


4- Try this,
    - Make sure the AVR Picture mode is set to “Direct” on all HDMI inputs (1,2,3,4,5 & AUX)
    - Set the STB "color space setting" to “RGB”.
    - Return to the main menu >>
    - Exit menu, (press [Power/On]),
    - Turn STB back On, (press [Power/On] again).
    - Switch back and forth between Roku&STB inputs.
    - Do you see a “Pink screen” (HDCP error) ?

=================

• You also need to set the following (to minimize handshake-delay).
    - Set the AVR Picture mode to “Direct” on all HDMI inputs (1,2,3,4,5 & AUX)
    - Set the TV “HDMI black level to “Normal”.
    - Set the video resolution to 720p (not ‘Auto”) on all devices (Roku > 720p, BDP > 720p, WD > 720p) (STB > NATIVE see more above).
    - Set the RGB range to “YCbCr” (not “Auto”) on all devices (BDP > “YCbCr” - STB > “YCC 4:4:4” - WD > “YCbCr”).

=====================


• You could also try to turn “Off” the cable box, switch input, and then turn it “On”.
Add these IR codes to your remote control.
“Off” before the switch and “On” after the switch.
Each set, should work regardless (if the box is on or off - like on/off IR discrete codes – since these boxes have only one Power/toggle)

    (cable box 'OFF')
      MENU
      1 sec delay
      POWER
      POWER
      POWER

    (cable box 'ON')
      MENU
      1 sec delay
      POWER
      1 sec delay
      POWER

Try the process manually first, before you add it to the remote control.
In any event you can always make some use out of it, that if you haven’t already. :D



Roku2 - Onkyo (TX-NR609) issues & Facts …… click here



-----------------------------------------------------------------------------------------------------------------------------------------
:idea: FYI, did you know HDMI 1.4 specification have now five HDMI cable types to choose from. read here.
-----------------------------------------------------------------------------------------------------------------------------------------
Last edited by __5 on Wed Dec 05, 2012 11:38 pm, edited 2 times in total.
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: pink screen? handshake issue?

Postby david0406 » Fri Nov 23, 2012 11:19 am

From the STB user system menu,

FYI, To toggle between settings in that menu, scroll to “that setting” then Press [Ok] and wait… (every time you Press [Ok] ...it will switch..).

1- Change video resolution on the STB,
If you see “Native mode settings” grayed out,
Scroll to “HDMI/YPbpr Output”,
Press [Ok] several times & set it to “NATIVE”,
Then “Native mode settings” should become active,
Scroll to “Native mode settings”
Press [Ok],
You should see “MY TV Supports the following formats:”
Mark only the following formats
[ ] 1080p 30
[ ]1080p 24
[x]1080i
[x]720p
[x]480p
[ ]480i
Return to the main menu >>

Ok to all of this.


2- Set “Audio output:” to “Pass through” (not Auto or L-PCM)
Return to the main menu >>

Ok to this.


3- Check this,
From your “STB” “user system menu” toggle between “YCC 4:4:4” and “RGB” - see if a “Pink screen” flashes in between toggles for,
a) less than a second.
b) a lot more than that.
c) none?
Return to the main menu >>

As I recall none


4- Try this,
- Make sure the AVR Picture mode is set to “Direct” on all HDMI inputs (1,2,3,4,5 & AUX)
- Set the STB "color space setting" to “RGB”.
- Return to the main menu >>
- Exit menu, (press [Power/On]),
- Turn STB back On, (press [Power/On] again).
- Switch back and forth between Roku&STB inputs.
- Do you see a “Pink screen” (HDCP error) ?

Ok to this and no error.

=================

• You also need to set the following (to minimize handshake-delay).
- Set the AVR Picture mode to “Direct” on all HDMI inputs (1,2,3,4,5 & AUX)
- Set the TV “HDMI black level to “Normal”.
- Set the video resolution to 720p (not ‘Auto”) on all devices (Roku > 720p, BDP > 720p, WD > 720p) (STB > NATIVE see more above).
- Set the RGB range to “YCbCr” (not “Auto”) on all devices (BDP > “YCbCr” - STB > “YCC 4:4:4” - WD > “YCbCr”).

Ok to all of this with one exception. I tried the STB > YCC 4:4:4 and got the " pink screen issue". I put the color space of the STB> RGB and multiple times switching of Roku2 >STB after streaming a 5.1DD+ or 5.1 DD title resulted in no "pink Screen issue" I tried this with the AVR pic mode in direct and got the pink screen with color space on YCC 4 4 4. Changed STB back to RGB and put my AVR pic mode in "custom" ( which is really what I want my AVR in) and as of now NO PINK SCREEN ISSUE IS OCCURRING!!!!!!!!! YAY!!!!!!!

5,
This has been an epic journey and very frustrating at times. I just want to say an enormous thank you for your persistence in attempting to get these issues resolved in my setup. I don't know what your backround is with this stuff but it appears you have a level of expertise not too many people have. :D If you see any potential issues with what I have done or how I have left things set up wise. Please let me know but it appears we might be able to call this issue RESOLVED!! :D :D :D :D :D :D


I'm going to go out on a limb here and put a little addition in the title of this thread :D
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby RickRansom » Fri Nov 23, 2012 5:50 pm

I've always thought that 5 knew things that most people don't, but after following this thread for sometime I am really impressed. Response time. Providing instructions. Checking device manuals. 5 seems to have a really extensive background when it comes to things like this. Either that or 5 is an automated computer program set to resolve roku issues. :mrgreen:

Glad to know your pink screen issue got resolved, david0406. Happy streaming. :wink:
Retired
User avatar
RickRansom
 
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby david0406 » Sun Nov 25, 2012 5:45 pm

Did 5 go into hiding or something? :D . Just wanted to quick report after a full weekend of streaming that the fix is in and it appears stable. It apears it was never a Roku2 issue after all.So at this point I will re-elevate Roku2 to KING of the content streamers in david0406's household. Thanks only to roku5. Roku should put him to work for them. :D
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby vandergraff » Sun Nov 25, 2012 11:48 pm

david0406 wrote:Did 5 go into hiding or something? :D . Just wanted to quick report after a full weekend of streaming that the fix is in and it appears stable. It apears it was never a Roku2 issue after all.So at this point I will re-elevate Roku2 to KING of the content streamers in david0406's household. Thanks only to roku5. Roku should put him to work for them. :D


Sorry I don't mean to be funny but what was the fix (it is hard to read the tremendous amount detail of suggestions and replies in the previous posts to see what the actual fix was).

Can you also confirm that playing 5.1 Netflix and 2.0 Netflix titles through the ROKU 2 /Onkyo has no affect on the black levels now?

Thanks
vandergraff
 
Posts: 186
Joined: Fri Aug 19, 2011 11:50 am

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby david0406 » Mon Nov 26, 2012 3:09 am

vandergraff wrote:
david0406 wrote:Did 5 go into hiding or something? :D . Just wanted to quick report after a full weekend of streaming that the fix is in and it appears stable. It apears it was never a Roku2 issue after all.So at this point I will re-elevate Roku2 to KING of the content streamers in david0406's household. Thanks only to roku5. Roku should put him to work for them. :D


Sorry I don't mean to be funny but what was the fix (it is hard to read the tremendous amount detail of suggestions and replies in the previous posts to see what the actual fix was).

Can you also confirm that playing 5.1 Netflix and 2.0 Netflix titles through the ROKU 2 /Onkyo has no affect on the black levels now?

Thanks


I don't have equipment to measure black levels, only my eyes. My bigger issue was the handshake problem. I changed the colorspace output of my STB to output RGB instead of YCC 4:4:4. My STB was causing the " pink screen issue" when switching inputs between the STB ond the Roku2. As for the black crush I don't know exactly. It could have been my multiple hard resets of all the devices or getting my hdmi black level active again on the TV. I did have "severe" black crush on the Roku2 and it is not nearly as bad as it was before I did all those resets of all the devices. I can not specifically point to one test ( I did so many of them :shock: ) that improved the issue as I do not have the equipment to measure that. It still could be producing the issue you are stating. I always thought that issue was causing the HDCP error issue between my AVR and the Roku2 when in reality it was my STB. Sorry I don't have an exact answer for you. Maybe 5 will respond.
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby vandergraff » Tue Nov 27, 2012 11:26 pm

Black levels are still off on Netflix 5.1 titles when using a ROKU 2 with an Onkyo receiver.

Roku mods - Onkyo mods are saying here on November 23rd http://onkyoproductsupport.forumotion.c ... ith-my-809

'Thank you very much for your updated response; as we have repeatedly tried contacting Roku and still haven't spoken to anyone in their Engineering department.'

I though you were in contact with them.

Unfortunately most of the threads here discussing the subject have been closed by the Roku mods........
vandergraff
 
Posts: 186
Joined: Fri Aug 19, 2011 11:50 am

Re: pink screen? handshake issue? RESOLVED!! <The entropy of a perfect crystal, at absolute zero kelvin, is exactly equal to zero. - Third Law of Thermodynamics> YES!!!!!

Postby david0406 » Wed Nov 28, 2012 3:31 am

vandergraff wrote:Black levels are still off on Netflix 5.1 titles when using a ROKU 2 with an Onkyo receiver.

Roku mods - Onkyo mods are saying here on November 23rd http://onkyoproductsupport.forumotion.c ... ith-my-809

'Thank you very much for your updated response; as we have repeatedly tried contacting Roku and still haven't spoken to anyone in their Engineering department.'

I though you were in contact with them.

Unfortunately most of the threads here discussing the subject have been closed by the Roku mods........


Well if I use my eyes yes that issue still occurs although somewhat alleviated with my HDMI black level set to normal on my TV as for the handshake issue....


Thought I had my handshake issue fixed with the Roku2 and switching inputs between my STB and Roku2 after DD+ 5.1 or DD 5.1 on the Roku2 by changing the colorspace output to RGB on the STB. While that does indeed fix the handshake issue when switching between the STB and Roku2 after a dd+ or 5.1 stream it makes the picture on the TV picture look like crap. So I changed the STB back to ouput YCC 4:4:4 to get the better picture on my TV and of course the handshake issue occurs again when switching inputs after said streams. I'm not losing sleep over this issue anymore. No more testing or wasting my time for an issue that can't be fixed. Sadly.
Last edited by david0406 on Sat Dec 15, 2012 4:36 am, edited 1 time in total.
Roku N-1000
Roku HD 2000C
Roku LT
Roku 2 XD
Roku 3
Roku 3
david0406
 
Posts: 673
Joined: Sun Apr 22, 2012 8:06 pm
Location: Florida

Re: pink screen? handshake issue?

Postby onkyoPS » Mon Dec 03, 2012 9:21 am

We are following up on our request to speak with Roku's Engineering department regarding this issue again. Please contact our Onkyo Product Support department during normal business hours, Mon- Fri 9am - 5pm EST, and request to speak to the FORUM MODERATOR or Onkyo On-Site Engineer and reference the " ROKU PINK SCREEN ISSUE". A Product Support representative will transfer the call to the Technical Engineering department. As this department has constantly ask if Roku has responded and I can't locate any email, forum responses, or phone calls to suggest so. The Engineer has also provided his direct contact information and hasn't received any calls to date. We would like to work to resolve this issue as well and would appreciate your assistance as well.

Best Regards;

Onkyo Product Support department
Onkyo USA
(800) 229-1687, option #3 Product Technical Support
onkyoPS
 
Posts: 8
Joined: Tue Nov 13, 2012 10:16 am

Re: pink screen? handshake issue?

Postby mikebdoss » Mon Dec 03, 2012 9:23 am

onkyoPS wrote:We are following up on our request to speak with Roku's Engineering department regarding this issue again. Please contact our Onkyo Product Support department during normal business hours, Mon- Fri 9am - 5pm EST, and request to speak to the FORUM MODERATOR or Onkyo On-Site Engineer and reference the " ROKU PINK SCREEN ISSUE". A Product Support representative will transfer the call to the Technical Engineering department. As this department has constantly ask if Roku has responded and I can't locate any email, forum responses, or phone calls to suggest so. The Engineer has also provided his direct contact information and hasn't received any calls to date. We would like to work to resolve this issue as well and would appreciate your assistance as well.

Best Regards;

Onkyo Product Support department
Onkyo USA
(800) 229-1687, option #3 Product Technical Support


Why hasn't this guy been banned yet?
mikebdoss
** Valued Community Member **
 
Posts: 3350
Joined: Mon Oct 25, 2010 12:52 am

PreviousNext

Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: dboff01, mikebdoss and 30 guests