Non-native language/Forced Captions not showing?

Moderators: RokuDouglas, RokuShawnS, RokuKen, RokuRyan, RokuJamesL

Non-native language/Forced Captions not showing?

Postby griffindodd » Mon Dec 16, 2013 2:33 pm

I don't remember this being an issue in the past but I've noticed lately that content with forced captions for non-native language are not showing.

For example, Netflix Lilyhammer Season 2, whenever anyone speaks Norwegian there are no captions, the only way you can see them is to turn on ALL captions for the language you are watching in which is very distracting.

Also noticed the same watching the new Wolverine Movie on the Plex app, no subtitles for the parts spoken in Japanese. I watched whole first season of Lilyhammer when it came out on my Roku with the Netflix app and had none of these issues before.

Anyone got a solution to this??
griffindodd
 
Posts: 6
Joined: Tue Jun 12, 2012 12:17 pm

Re: Non-native language/Forced Captions not showing?

Postby RokuShawnS » Mon Dec 16, 2013 3:23 pm

RE: Plex app captions - You must have the subtitle file in the same folder (and with the same name) as the video you're watching. I believe there's a website that contains a lot of subtitles, including just the non-English parts.

RE: Netflix - I don't recall off-hand how Netflix handles subtitles. I'm assuming you're using the new Netflix UI (Roku 3)? You'll need to contact Netflix about that, but I'll also note it in my report.

C. Shawn Smith
Forum Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
User avatar
RokuShawnS
Roku Engineering
 
Posts: 4626
Joined: Thu Mar 10, 2011 2:21 pm

Re: Non-native language/Forced Captions not showing?

Postby Pearl » Mon Dec 16, 2013 5:08 pm

griffindodd wrote:For example, Netflix Lilyhammer Season 2, whenever anyone speaks Norwegian there are no captions, the only way you can see them is to turn on ALL captions for the language you are watching in which is very distracting.


I noticed the same thing with Lilyhammer Season 2 on Netflix yesterday. I could not solve the issue, so ended up using a different steaming media player and it worked fine. Something to do with the app for Roku. The default with no subtitles on, should still be subtitles for the Norwegian parts. I had assumed that they were embedded since it is an American TV show, but obviously that is not the case.

-P
Pearl
 
Posts: 56
Joined: Sat Jun 02, 2012 10:15 am

Re: Non-native language/Forced Captions not showing?

Postby digitalhome » Fri Dec 20, 2013 5:10 pm

This does not work in Lilyhammer in Netflix on Roku. Works fine on PC. Very frustrating as I now can't watch Lilyhammer on the TV
digitalhome
 
Posts: 1
Joined: Fri Dec 20, 2013 5:08 pm

Re: Non-native language/Forced Captions not showing?

Postby Pearl » Fri Dec 20, 2013 7:09 pm

digitalhome wrote:This does not work in Lilyhammer in Netflix on Roku. Works fine on PC. Very frustrating as I now can't watch Lilyhammer on the TV


Well, you could just hook an HDMI cord from your PC to your TV, but that's not really the point. It's definitely specific to the Roku app. Besides it working on the PC, the app for the WD devices works correctly as well with the series.

-P
Pearl
 
Posts: 56
Joined: Sat Jun 02, 2012 10:15 am

Re: Non-native language/Forced Captions not showing?

Postby Legaleagle2 » Fri Dec 20, 2013 8:52 pm

I am having the same issue with forced subtitles, in my case Lilyhammer on Netflix as viewed on a Roku XD and an HDTV. When the actors speak Norwegian no subtitles appear. The work-around of turning on CC is not effective as all voices then become English subtitles, which is a pain. The problem is confined to the Roku-Netflix interface because when I watch the same program on my HDTV using a wifi Blu-Ray player with a Netflix app, the forced subtitles work fine.
Legaleagle2
 
Posts: 1
Joined: Fri Dec 20, 2013 8:43 pm

Re: Non-native language/Forced Captions not showing?

Postby Netchuc » Mon Dec 23, 2013 12:57 am

Hi, this is my first time to join a discussion here, but I was having the same problem with "Lilihammer". Some folks here said there's no fix, and that might be true for their Roku setups, but I've been able to get the subtitles back without too much trouble. I'm using a Roku 3, BTW.
When I start "Lilihammer" there are no subtitles for the Norwegian. I then click the OK button, which pauses the show and gives me options for audio. Here comes the tricky part. I go into the subtitle options and choose an option (any option) and return to the show. The yellow subtitles (for Norwegian) return and then I uncheck the previously selected option from before. The yellow subtitles then remain for the rest of the show.
Here's the weird thing. Sometimes I don't even have to check an option. Just going into the audio menu and returning to the main show might do the trick. And there seems to be no rhyme or reason for selection of one option working better than others.
All I know is, it always works and it takes less than 30 seconds to fix. Hope this one helps you too, fellow Lilihammer fans.
Netchuc
 
Posts: 1
Joined: Mon Dec 23, 2013 12:34 am

Re: Non-native language/Forced Captions not showing?

Postby krisbee » Wed Jan 01, 2014 4:58 pm

This is still an issue. For lillyhammer, have to run subtitles all the time, which for this show is distracting since they slip in and out of English constantly.
krisbee
 
Posts: 1025
Joined: Wed Nov 24, 2010 12:09 pm

Re: Non-native language/Forced Captions not showing?

Postby mattnad » Wed Jan 01, 2014 7:30 pm

It's definitely the Netflix client on Roku devices except for the 3. Netflix should be ashamed of their client programming, particularly since Lilihammer is their own series. How stupid is that?
mattnad
 
Posts: 2
Joined: Wed Jan 01, 2014 7:26 pm

Re: Non-native language/Forced Captions not showing?

Postby krisbee » Thu Jan 02, 2014 10:25 am

mattnad wrote:It's definitely the Netflix client on Roku devices except for the 3. Netflix should be ashamed of their client programming, particularly since Lilihammer is their own series. How stupid is that?


Well, it did work for season 1 when it aired, so it USED to work - I think somewhere with the upgrades it failed. I'm too lazy to get NETFLIX on my HDTV or Blu Ray player going, so I will just live with the annoyance. :(
krisbee
 
Posts: 1025
Joined: Wed Nov 24, 2010 12:09 pm

Re: Non-native language/Forced Captions not showing?

Postby jusernamer » Sun Feb 09, 2014 2:49 pm

Yeah, I got this problem too, ROKU LT. Annoying. Reading three lines deep in yellow stacked over every scene:

(IN ENGLISH:) Yeah, that's what I said.
(IN NORWEGIAN): Really? Hey are you hungry?
(In ENGLISH): Fuggedaboutit.

This is lame.

Reason I jusdt bought a ROKU is my WII and Philips BluRay always hang up on Netflix. Almost always, can't get through a half hour without a streaming problem. Amazon, no problem.

Please fix this ROKU.
jusernamer
 
Posts: 1
Joined: Sun Feb 09, 2014 2:43 pm

Re: Non-native language/Forced Captions not showing?

Postby krisbee » Sun Feb 09, 2014 2:54 pm

jusernamer wrote:Yeah, I got this problem too, ROKU LT. Annoying. Reading three lines deep in yellow stacked over every scene:

(IN ENGLISH:) Yeah, that's what I said.
(IN NORWEGIAN): Really? Hey are you hungry?
(In ENGLISH): Fuggedaboutit.

This is lame.

Reason I jusdt bought a ROKU is my WII and Philips BluRay always hang up on Netflix. Almost always, can't get through a half hour without a streaming problem. Amazon, no problem.

Please fix this ROKU.


Apparently there is some switch in the normal roku menu (not netflix) to turn on captioning that will fix the issue. I did that because my .srt files weren't playing. I can't remember if I went back and tried to play Lillyhammer. Give it a try and see if it works. My Roku2 I recently bought died (it was a remanufactured unit, died in two months) - so I had to put the Roku 1 back into service which doesn't have the problem...
krisbee
 
Posts: 1025
Joined: Wed Nov 24, 2010 12:09 pm


Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: mrjlturner and 28 guests