can't connect to your local network

Moderators: RokuDouglas, RokuShawnS, RokuKen, RokuRyan, RokuJamesL

can't connect to your local network

Postby lovekeiiy » Sat May 31, 2008 2:03 am

I just got the player today. I haven't been able to get it to connect to my network.

I have Comcast for my ISP with their upper tier service (8mb down, 1.5mb up), I use Smoothwall for my DHCP and firewall, have a Belkin Pre N router that I use as an access point.

I was able to connect the box to netflix when I plugged it directly into the cable modem. I preformed whatever update available, and got an access code.

I'm using player on the same network and wireless network as this computer, which also connects wireless. So by the player's error screen, I know the router is accessible wirelessly, and the box tells me it's connecting wirelessly to my access point. I double check and the SSID and passcode are correct. When it scans for networks, it can them, in theory, since I don't broadcast them (I have two networks); I can see two blank boxes. I did enter the one that uses DHCP manaully; the other network is pure static IPs and has no IP or DNS forwarding.

I tried connecting using the ethernet cable with the same result. I also tried connecting the box directly to the Smoothwall machine with the same result. Connect the ethernet cable, but not the local network.

I tried pinging moviecontrol.netflix.com, a suggestion from another thread and got:

Pinging moviecontrol.netflix.com [208.75.76.19] with 32 bytes of data:

Reply from 208.75.76.19: bytes=32 time=17ms TTL=238
Reply from 208.75.76.19: bytes=32 time=16ms TTL=238
Reply from 208.75.76.19: bytes=32 time=16ms TTL=238
Reply from 208.75.76.19: bytes=32 time=16ms TTL=238

Ping statistics for 208.75.76.19:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 17ms, Average = 16ms

From Smoothwall's DHCP log, I'm getting the following the player (it's the only name I didn't recongize):

01:16:50 dhcpd DHCPDISCOVER from 00:0d:4b:35:26:fa (NP-20F84E004665) via eth0
01:16:50 dhcpd Abandoning IP address 192.168.101.193: pinged before offer
01:16:55 dhcpd DHCPDISCOVER from 00:0d:4b:35:26:fa via eth0
01:16:56 dhcpd DHCPOFFER on 192.168.101.189 to 00:0d:4b:35:26:fa (NP-20F84E004665) via eth0
01:16:58 dhcpd if NP-20F84E004665. IN A rrset doesn't exist add NP-20F84E004665. 1800 IN A 192.168.101.189: timed out.
01:16:58 dhcpd DHCPREQUEST for 192.168.101.189 (192.168.101.1) from 00:0d:4b:35:26:fa (NP-20F84E004665) via eth0
01:16:58 dhcpd DHCPACK on 192.168.101.189 to 00:0d:4b:35:26:fa (NP-20F84E004665) via eth0
01:30:55 dhcpd DHCPDISCOVER from 00:0d:4b:35:26:fb (NP-20F84E004665) via eth0
01:30:55 dhcpd Abandoning IP address 192.168.101.190: pinged before offer
01:30:55 dhcpd Wrote 11 leases to leases file.
01:31:00 dhcpd DHCPDISCOVER from 00:0d:4b:35:26:fb via eth0
01:31:01 dhcpd DHCPOFFER on 192.168.101.188 to 00:0d:4b:35:26:fb (NP-20F84E004665) via eth0
01:31:02 dhcpd if NP-20F84E004665. IN A rrset doesn't exist add NP-20F84E004665. 1800 IN A 192.168.101.188: timed out.
01:31:02 dhcpd DHCPREQUEST for 192.168.101.188 (192.168.101.1) from 00:0d:4b:35:26:fb (NP-20F84E004665) via eth0
01:31:02 dhcpd DHCPACK on 192.168.101.188 to 00:0d:4b:35:26:fb (NP-20F84E004665) via eth0

unfortunately, I don't know quite what it's saying.

I'm thinking it's not getting IP and DNS forwarded somehow. Some devices on my system I've had to entered the DNS information for them to work. I tried to see if there was user interface using a web browser, a common interface for my network devices, but it wouldn't connect.

I'm a bit stumped. Any suggestions?
lovekeiiy
 
Posts: 25
Joined: Sat May 31, 2008 1:08 am
Location: san francisco bay area

Postby lovekeiiy » Sat May 31, 2008 2:45 am

Got it to work. It was a setting in the Smoothwall machine. It should be noted I use SW 3.0 express with last two updates from 10/9/07 and 3/19/08

I found that in the networking, advance tab, the enabling the Block ICMP Ping prevented the box from connecting to the local network. After I was to connect to Netflix, I could enabled again with no problems. I having UPnP, Block and Ignore IGMP packets, and Block and/or ignore multicast traffic enable did not the effect the ablity to connect Netflix. I can't explain why the setting caused the issue to setup, but someone may encounter it, and figured I'd give a heads up.
lovekeiiy
 
Posts: 25
Joined: Sat May 31, 2008 1:08 am
Location: san francisco bay area

Postby devrdander » Sat May 31, 2008 10:22 am

Blocking ICMP will disabled any sort of PING the device might do to check its online status. Perhaps its doing a ping to an internet host now? Havent heard the Roku guys comment on that but it may be be useful information.
devrdander
 
Posts: 90
Joined: Wed May 28, 2008 11:46 am

Postby lovekeiiy » Sat May 31, 2008 3:13 pm

I'm not sure what the box does when setting up, but apparently it must ping the local network, which my firewall blocked or ignored.

Unfortunately, I have a firewall that has more feature than I understand, but is a lot better than the standard one in the routers. I figured I'd let people know what I found, in case there are other smoothwall users encountering problems as well. Plus, maybe Roku may need to address it. They're can't do anything, if they choose, if they don't know about it.
lovekeiiy
 
Posts: 25
Joined: Sat May 31, 2008 1:08 am
Location: san francisco bay area

Postby coxhaus » Thu Oct 08, 2009 3:51 pm

Here is what I posted on the Smoothwall forum.
Notice I have it working through Smoothwall using Microsoft's DHCP and not changing the ICMP setting, so I am not sure why that change fixes it. I think it is a problem with DHCP in Smoothwall but I do not know really know. I guess it could be a timing problem but someone else will need to figure it out.

My wife bought the new Roku digital player to play Netflix moves. I tried it wireless first and it said it was having a problem connecting to the network. There is a pass through AP wirless device using Smoothwalls DHCP for purple. So I next connected a cat5 wire from the Smoothwall's switch on the green side. No go. I have a green light on the switch for connectivity so I am thinking DHCP. I next try moving the cat5 wire to my sub network which is governed by Microsoft's DHCP server and running through the Smoothwall to the internet. The Roku device connects fine and is currently running a movie as I write this. I do not currently have the last update installed. Do you think the last update will fix this issue? Is anybody running the Roku device using Smoothwall's DHCP.
coxhaus
 
Posts: 1
Joined: Thu Oct 08, 2009 3:42 pm

Postby udi » Mon Oct 12, 2009 7:08 pm

same here with Astaro 7.5. had to enable "Firewall is Ping visible" to pass initial network setup.
Also added Astaro AV exception for domain llnwd.net
udi
 
Posts: 7
Joined: Sun Sep 13, 2009 2:41 pm

Re: can't connect to your local network

Postby SirBC » Thu Apr 04, 2013 11:06 am

Thanks for the pointer, I was having the same issue with my Untangle UTM. I was able to resolve by going to Networking/Advanced/Packet filter and from there checking the "Allow Ping on all interfaces". Was able to immediately connect to the local network after making that selection.
SirBC
 
Posts: 1
Joined: Thu Apr 04, 2013 11:03 am

Re: can't connect to your local network

Postby RokuShawnS » Thu Apr 04, 2013 11:26 am

viewtopic.php?f=28&t=38665

  • When creating a topic, please perform a search or glance over the first two pages before posting the topic, as it may have been covered already. In general, if a thread is more than six months old, it will be best for our moderators if you generate a new thread, to prevent confusion.
Forum Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
User avatar
RokuShawnS
Roku Engineering
 
Posts: 4652
Joined: Thu Mar 10, 2011 2:21 pm


Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: dboff01, shadoecat and 38 guests