plex audio sync issue

Moderators: RokuDouglas, RokuShawnS, RokuRyan, RokuJamesL, RokuKen

plex audio sync issue

Postby ronfelder » Sun Dec 16, 2012 12:05 pm

Well i've found another new issue with Plex and audio. Now I know in the past I never had this problem so something new has caused it. Perhaps it's do to the latest update to the Plex server software on my pc. Seems if I play a movie from the beinning and all the way through the audio is in perfect syn. Should during the movie I back out and restart the movie from where I left off the audio is very noticeably out of sync. I can even start a movie from the beginning where it was in syc and then fast forward into the movie once I start the movie from the new spot anmd the movie is out of audio sync.

Anyone also have this problem? Any ideas and tips for the cause and the cure?
Roku 2100x, (2) Roku2 3100x , Actiontec M1424-WR Rev I modem/router, Verizon FIOS 25/25, LG HDTV 42LH90, Pioneer VSX-920 Audio/Video Multi Channel Receiver
ronfelder
 
Posts: 445
Joined: Sat May 15, 2010 1:43 pm
Location: new jersey

Re: plex audio sync issue

Postby lion7718 » Sun Dec 16, 2012 3:49 pm

I think this is on your computers side, most likely you need to reboot your system when this happens.
Remember Plex transcodes the video to Roku, this uses CPU...depending of the video depends on how much.

I found out I had problems sometimes when the computers screensaver came on, so I turned it off..I just moved the monitor off time up.
I mostly watch AVI's through Plex, every now & than a MKV if it won't play with the Roku's USB.
lion7718
 
Posts: 475
Joined: Mon Jul 16, 2012 7:01 am

Re: plex audio sync issue

Postby ronfelder » Sun Dec 16, 2012 4:08 pm

lion7718 wrote:I think this is on your computers side, most likely you need to reboot your system when this happens.
Remember Plex transcodes the video to Roku, this uses CPU...depending of the video depends on how much.

I found out I had problems sometimes when the computers screensaver came on, so I turned it off..I just moved the monitor off time up.
I mostly watch AVI's through Plex, every now & than a MKV if it won't play with the Roku's USB.



not pc. Atleast it isn't do to rebooting. Did that multiple times and I never use a screensaver. Thanks for the input.
Also have plenty of computing power. Core I-7 2.66Ghz processor with 6 gigs of DDR3 Ram.

Been to Plex's site. Seems i'm not the only one with this problem. Same with losing audio and locking up. Roku and Plex it seems know of this and are working on it. Just seems to have gotten worse this weekend.
Roku 2100x, (2) Roku2 3100x , Actiontec M1424-WR Rev I modem/router, Verizon FIOS 25/25, LG HDTV 42LH90, Pioneer VSX-920 Audio/Video Multi Channel Receiver
ronfelder
 
Posts: 445
Joined: Sat May 15, 2010 1:43 pm
Location: new jersey

Re: plex audio sync issue

Postby RokuShawnS » Sun Dec 16, 2012 5:03 pm

ronfelder wrote:
lion7718 wrote:I think this is on your computers side, most likely you need to reboot your system when this happens.
Remember Plex transcodes the video to Roku, this uses CPU...depending of the video depends on how much.

I found out I had problems sometimes when the computers screensaver came on, so I turned it off..I just moved the monitor off time up.
I mostly watch AVI's through Plex, every now & than a MKV if it won't play with the Roku's USB.



not pc. Atleast it isn't do to rebooting. Did that multiple times and I never use a screensaver. Thanks for the input.
Also have plenty of computing power. Core I-7 2.66Ghz processor with 6 gigs of DDR3 Ram.

Been to Plex's site. Seems i'm not the only one with this problem. Same with losing audio and locking up. Roku and Plex it seems know of this and are working on it. Just seems to have gotten worse this weekend.


Not necessarily. The PC itself, despite it's robust nature, during any fast-forward or rewind event, can cause a lag in the audio/visual, especially when it's transcoding (I've seen this on something as simple as Windows Media Player, when advancing or re-winding a title). Try the same title in a Roku-friendly format that doesn't require transcoding.

C. Shawn Smith
Forum Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
User avatar
RokuShawnS
Roku Engineering
 
Posts: 4504
Joined: Thu Mar 10, 2011 2:21 pm

Re: plex audio sync issue

Postby ronfelder » Sun Dec 16, 2012 5:45 pm

RokuShawnS wrote:
ronfelder wrote:
lion7718 wrote:I think this is on your computers side, most likely you need to reboot your system when this happens.
Remember Plex transcodes the video to Roku, this uses CPU...depending of the video depends on how much.

I found out I had problems sometimes when the computers screensaver came on, so I turned it off..I just moved the monitor off time up.
I mostly watch AVI's through Plex, every now & than a MKV if it won't play with the Roku's USB.



not pc. Atleast it isn't do to rebooting. Did that multiple times and I never use a screensaver. Thanks for the input.
Also have plenty of computing power. Core I-7 2.66Ghz processor with 6 gigs of DDR3 Ram.

Been to Plex's site. Seems i'm not the only one with this problem. Same with losing audio and locking up. Roku and Plex it seems know of this and are working on it. Just seems to have gotten worse this weekend.


Not necessarily. The PC itself, despite it's robust nature, during any fast-forward or rewind event, can cause a lag in the audio/visual, especially when it's transcoding (I've seen this on something as simple as Windows Media Player, when advancing or re-winding a title). Try the same title in a Roku-friendly format that doesn't require transcoding.

C. Shawn Smith



Shawn the files are in mkv format. Isn't that a roku friendly format? I have the ability to change it using Handbrake if needed.
Roku 2100x, (2) Roku2 3100x , Actiontec M1424-WR Rev I modem/router, Verizon FIOS 25/25, LG HDTV 42LH90, Pioneer VSX-920 Audio/Video Multi Channel Receiver
ronfelder
 
Posts: 445
Joined: Sat May 15, 2010 1:43 pm
Location: new jersey

Re: plex audio sync issue

Postby scyber » Sun Dec 16, 2012 6:41 pm

Roku only supports mkv via usb. Direct Playing MKV's via http streaming can cause issues (audio drops and reboots). Plex will either transcode or remux (depending on the video/audio format) mkv files to HLS format for the Roku to play. The cpu load in this process is dependent on the exact video/audio formats in the file.
scyber
 
Posts: 1287
Joined: Mon Dec 29, 2008 8:51 am

Re: plex audio sync issue

Postby ronfelder » Sun Dec 16, 2012 7:19 pm

scyber wrote:Roku only supports mkv via usb. Direct Playing MKV's via http streaming can cause issues (audio drops and reboots). Plex will either transcode or remux (depending on the video/audio format) mkv files to HLS format for the Roku to play. The cpu load in this process is dependent on the exact video/audio formats in the file.



What is the HLS format? Do you then reccomend I use Handbrake to convert the files to mp4?
When I turn off the 5.1 from within Plex and switch it to stereo all seems to be ok. Kindly explain what's up there?
Roku 2100x, (2) Roku2 3100x , Actiontec M1424-WR Rev I modem/router, Verizon FIOS 25/25, LG HDTV 42LH90, Pioneer VSX-920 Audio/Video Multi Channel Receiver
ronfelder
 
Posts: 445
Joined: Sat May 15, 2010 1:43 pm
Location: new jersey

Re: plex audio sync issue

Postby ronfelder » Mon Dec 17, 2012 3:41 am

RokuShawnS wrote:
ronfelder wrote:
lion7718 wrote:I think this is on your computers side, most likely you need to reboot your system when this happens.
Remember Plex transcodes the video to Roku, this uses CPU...depending of the video depends on how much.

I found out I had problems sometimes when the computers screensaver came on, so I turned it off..I just moved the monitor off time up.
I mostly watch AVI's through Plex, every now & than a MKV if it won't play with the Roku's USB.



not pc. Atleast it isn't do to rebooting. Did that multiple times and I never use a screensaver. Thanks for the input.
Also have plenty of computing power. Core I-7 2.66Ghz processor with 6 gigs of DDR3 Ram.

Been to Plex's site. Seems i'm not the only one with this problem. Same with losing audio and locking up. Roku and Plex it seems know of this and are working on it. Just seems to have gotten worse this weekend.


Not necessarily. The PC itself, despite it's robust nature, during any fast-forward or rewind event, can cause a lag in the audio/visual, especially when it's transcoding (I've seen this on something as simple as Windows Media Player, when advancing or re-winding a title). Try the same title in a Roku-friendly format that doesn't require transcoding.

C. Shawn Smith



Shawn my next question is why did I not have any problems using an MKV file in the past? Quite a few of my videos are mkv format and I didn't lose audio, sync or have it freeze and reboot. I was even able to fast forward or go back 10 seconds with no problem. Has anything changed with your Roku or the Plex sever, or Plex channel on the Roku? also i thought the idea of Plex was that it transcoded on the fly. Now you're telling em to use a format that I need not transcode.

I will slowly convert all my videos to mp4 and any future videos until something is fixed.

Hope to hear your answers thanks.
Roku 2100x, (2) Roku2 3100x , Actiontec M1424-WR Rev I modem/router, Verizon FIOS 25/25, LG HDTV 42LH90, Pioneer VSX-920 Audio/Video Multi Channel Receiver
ronfelder
 
Posts: 445
Joined: Sat May 15, 2010 1:43 pm
Location: new jersey

Re: plex audio sync issue

Postby scyber » Mon Dec 17, 2012 9:19 am

There has been a change recently with degraded 5.1 mkv performance in Plex. Schulyer (from Plex) has stated over on the Plex forum that he is investigating it (he has said he is in contact with Roku about it). It is unclear if it was a PMS update or a Roku Firmware update (or a combo of the two) that introduced the issue, but people are working on resolving it.

The workaround for now is to use stereo audio. But hopefully the issue should be fixed soon.
scyber
 
Posts: 1287
Joined: Mon Dec 29, 2008 8:51 am


Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: trekkeriii and 56 guests