Roku 3 - Audio Stereo setting play slow

Moderators: RokuDouglas, RokuShawnS, RokuRyan, RokuJamesL, RokuKen

Roku 3 - Audio Stereo setting play slow

Postby DavidCole » Tue Jan 07, 2014 5:48 pm

Today I was introduced to an extended family member's new Roku 3. He purchased new in the box from some local big box retailer. The Roku 3 is also hooked up to a fresh out of the box Hitachi 1080p 55" tv.

I was called over to address a couple issues, all were normal given package plans and third party equipment. The last and final issue was an audio problem on the Roku 3, Pandora was pulled up on screen and then a station selected. At first the audio was great which left our Uncle perplexed. He then pulled up Netflix and started streaming a tv show at full HD resolution and Dolby Digital 5.1 audio quality. All this time everything was playing just great, then he showed me he could scroll down and then switch to standard stereo audio quality, this is when audio began in half speed. Video was at full speed but audio was painfully slow. We then started the normal troubleshooting regime, switching HDMI ports on the tv, switching out HDMI cables, adjusting any and every audio input and output available, reboot, checking for updates, and all the rest that came to mind. Still nothing worked, stereo audio plays at half speed no matter the channel on Roku 3 (ie netflix, pandora, ...) Audio only played as it should when the player was output Dobly Digital 5.1 quality.

So my question, who has experienced this and what's the solution. Any and all help would be greatly appreciated.
DavidCole
 
Posts: 4
Joined: Tue Jan 07, 2014 5:32 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby __5 » Tue Jan 07, 2014 7:56 pm

Is the Hitachi TV has Dolby Digital Plus (DD+) decoder? or, is it connected to an AVR?
if so, what make/model (of TV/AVR)? and what connections are used? (hdmi/optical/ analog)

If neither, ( no DD+ decoder & no AVR) try this:
    1. Set roku3 audio settings to Stereo – (from) Home > settings > Audio mode > “Stereo”
    (note: change it from global audio settings and not from “Audio & Subtitles” settings within Netflix [5.1] titels)
    2. reboot all devices (TV & Roku ...)
    3. try it …
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby DavidCole » Wed Jan 08, 2014 7:07 am

I did change that setting and it made the audio as described in both Netflix and Pandora. Which led me to believe that the stereo output from the Roku 3 is the issue or the TV can not interpret the audio signal properly.
I even changed all available audio options on the TV. Every combination was attempted in settings on the equipment to tv ports and cables used.

The Hitachi is a LE55V707, the Roku 3 is attached/connected to the tv via the HDMI and was plugged into the tv through its rear ports in both the HDMI1 and HDMI2 ports. Used the factory Roku 3 cable and it looked cheap so I placed a higher end cable in at one point with same result.

the technical specs on the tv say it has and is capable of handling:

Dolby® Digital/ MTS Stereo/ SAP
15W + 15W Stereo
Audio Only Mode
Perfect Volume
Surround Sound
DavidCole
 
Posts: 4
Joined: Tue Jan 07, 2014 5:32 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby __5 » Wed Jan 08, 2014 11:18 am

(your setup) Roku3 > HDMI > TV
The Hitachi TV (LE55V707) has no Dolby Digital (DD) nor Dolby Digital Plus (DD+) built-in decoder, but is capable of passing DD (no +) signal over optical-out (when “Digital Audio Out” is set to “RAW” (not “PCM”). this TV supports PCM.

Pandora outputs PCM.
Netflix outputs PCM from all titles (when R3 is set to “Stereo”).
Netflix outputs PCM from non-5.1 titles (when R3 is set to “surround”).
Netflix outputs 5.1DD+ from 5.1 titles (when R3 is set to “surround”).
(PCM = Stereo)

So, Hitachi TV can not interpret Netflix 5.1DD+ audio signal (& that’s common & it should ignore it but it didn’t). You could report this to Hitachi or,
Don’t send DD+ signal to this TV:
(you need to go thru all these steps, btw)

From the TV,
1. MENU > Audio > Reset all Audio Settings to the factory default settings.
2. make sure “Digital Audio Out” is set to “PCM” (not “RAW”)

From Roku,
3. Set roku3 audio settings to Stereo –from Home > settings > Audio mode > “Stereo”
(note: change it from global audio settings and not from “Audio & Subtitles” settings within Netflix [5.1] titels)
4. reboot TV & Roku
5. try it …

note: don’t toggle between R3/Netflix stereo & surround again (if you do perform step 1 ~ 5).

Good luck
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby DavidCole » Thu Jan 09, 2014 7:13 am

Apparently you can not read, as your fix seems to be related to Dobly Digital. I have no, again no, zero, zip, zelch, issues with the DD process of the signal from the Roku. The issue is stereo. The setting you pointed out is for audio is and has been set on RAW and PCM, but default was PCM and was only changed to RAW once just to test whether that would have any effect. All your directions are for the reverse of the issue I am describing.

Just to reiterate from my original post:

"Audio only played as it should when the player was output Dobly Digital 5.1 quality. "

Why if my audio only works with DD 5.1 would i change my settings over to stereo, when i wrote my issue only exists on those settings?
DavidCole
 
Posts: 4
Joined: Tue Jan 07, 2014 5:32 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby __5 » Thu Jan 09, 2014 9:18 am

.
(setup)
Hitachi TV (LE55V707)
Roku3 > HDMI > TV ( no AVR)

DavidCole wrote:.. … All your directions are for the reverse of the issue I am describing…...

Actually, from your description, the issue seems in reveres.
As you seem to be under the impression that the TV accepts/decodes/process Netflix 5.1Dolby Digital Plus (5.1DD+) and outputs the sound thru its two speakers (w/ great audio) but when you switch netflix to stereo audio began in half speed.

Q- How you determine if the TV actually decodes 5.1DD+? or does it try to transcode it to 2-ch PCM? or …..?

Keep in mind, Netflix [5.1] titles are encoded in 5.1 Dolby Digital Plus (5.1DD+) and not in 5.1 Dolby Digital (5.1DD legacy).

The idea here is to completely avoid DD+ signal with your TV and reset TV settings (you experimented too much already)

So, try to perform step 1~5 (above), stick with stereo only and avoid feeding DD+(plus) audio signal to your TV (that maybe causing the issue, since your TV doesn’t decode DD+).

& report back to help find out cause/fix.

Good luck
Last edited by __5 on Thu Jan 09, 2014 9:23 am, edited 1 time in total.
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby theuser86 » Thu Jan 09, 2014 9:22 am

DavidCole wrote:Apparently you can not read, as your fix seems to be related to Dobly Digital. I have no, again no, zero, zip, zelch, issues with the DD process of the signal from the Roku. The issue is stereo. The setting you pointed out is for audio is and has been set on RAW and PCM, but default was PCM and was only changed to RAW once just to test whether that would have any effect. All your directions are for the reverse of the issue I am describing.

Just to reiterate from my original post:

"Audio only played as it should when the player was output Dobly Digital 5.1 quality. "

Why if my audio only works with DD 5.1 would i change my settings over to stereo, when i wrote my issue only exists on those settings?


Have you tried setting the Roku Audio setting to "Stereo" instead of "Surround sound" and then playing a video with a Stereo audio track on Netflix?

Selecting a different audio track, have it be Stereo, in Netflix is NOT changing the Audio settings on the Roku. These settings I speak of are in the same Settings menu where you setup the internet connection. So it is outside of the Netflix channel.
theuser86
 
Posts: 864
Joined: Sun Oct 27, 2013 4:56 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby DavidCole » Thu Jan 09, 2014 9:50 am

Yep, tried that, it completely disables your Netflix ability to broadcast or even give you the option to choose Surround Sound as and option. The audio as a result is still played at half speed.

@__5 I have literally made every change on all possible settings and combinations there in. The "process" you have asked me to do, I have done already and still the audio is messed up. And no grabbled or clipping or making a fuzzy sound at high volume. The audio is actually playing at half speed or some slower speed less than real time.
Last edited by DavidCole on Thu Jan 09, 2014 9:59 am, edited 1 time in total.
DavidCole
 
Posts: 4
Joined: Tue Jan 07, 2014 5:32 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby theuser86 » Thu Jan 09, 2014 9:54 am

Very odd experience, I've tried the Netflix on multiple HDTVs of different brands with the Roku 3 set to Stereo and Surround and using DD Plus and Stereo audio tracks. I either wouldn't get audio at all based on what the TV supported but I always got Stereo sound at full speed.

Must be isolated to your HDTV, have you tried your Roku on another HDTV?
theuser86
 
Posts: 864
Joined: Sun Oct 27, 2013 4:56 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby __5 » Thu Jan 09, 2014 12:00 pm

DavidCole wrote:Yep, tried that, it completely disables your Netflix ability to broadcast or even give you the option to choose Surround Sound as and option. The audio as a result is still played at half speed.

@__5 I have literally made every change on all possible settings and combinations there in. The "process" you have asked me to do, I have done already and still the audio is messed up. And no grabbled or clipping or making a fuzzy sound at high volume. The audio is actually playing at half speed or some slower speed less than real time.


Ok.
Good, now you have stereo only (keep stereo setting - from Home > settings > Audio mode > “Stereo”)

Next step is to reset the TV (this way we make sure it forgets any previous DD+ signals and any corrupted audio settings).
reminder: don’t toggle between R3 stereo & surround again

A. From the TV, (reset TV audio to factory default settings)
    MENU > Audio > Reset all Audio Settings to the factory default settings.
    note: make sure “Digital Audio Out” is set to “PCM” (not “RAW”)

B. (Reset A/V)
  1. Turn “OFF” all connected devices (e.g., TV, BDP, DVD & STBs).
  2. Unplug power cord from Roku,TV, BDP, DVD & STBs.
  3. Disconnect any USB device from all devices.
  4. Unplug HDMI cables from all connected Devices (e.g., Roku,TV, BDP, DVD & STBs).
  5. Wait 10 min.
  6. Re-plug the HDMI cables to all devices (e.g., Roku,TV, BDP, DVD & STBs).
  7. (exclude Roku) Re-Plug power cord to all devices (e.g., TV, BDP & STBs).
  8. Turn “On” TV first.
  9. Wait 30 sec...
  10. Turn “On” Roku last (re-plug its power cord)
try it …
__5
** Valued Community Member **
 
Posts: 1097
Joined: Tue Dec 23, 2008 7:51 pm

Re: Roku 3 - Audio Stereo setting play slow

Postby kc8pql » Thu Jan 09, 2014 1:02 pm

DavidCole, __5 is a tenacious problem solver, and he really does know what he's doing.
I'd follow his advice if it were me.
_______________________________________________________________________________________________________
No, I don't work for Roku.
OTA Antenna, "Netflix Player" N1000X, XDS 2100X (premature death by lightning)
Roku2 XD 3050X, Roku2 XS 3100R
User avatar
kc8pql
** Valued Community Member **
 
Posts: 8058
Joined: Fri Jan 23, 2009 3:54 pm
Location: US

Re: Roku 3 - Audio Stereo setting play slow

Postby TheEndless » Thu Jan 09, 2014 1:07 pm

DavidCole wrote:So my question, who has experienced this and what's the solution. Any and all help would be greatly appreciated.

This sounds a lot like the issue described in this thread: viewtopic.php?f=28&t=65576
Not sure if there's anything in that thread that'll help, but thought it'd be worth pointing out, as this doesn't seem like an issue isolated to your system.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), MainSqueeze (MAINSQUEEZE), iTunes Podcasts (ITPC), Justin.tv (JUSTINTV), My Channels (MYCHANNELS)
User avatar
TheEndless
** Valued Community Member **
 
Posts: 7955
Joined: Mon Oct 04, 2004 10:15 am
Location: US


Return to Roku Streaming Player General Discussion

Who is online

Users browsing this forum: ACraigo and 43 guests