Your Digital Media Has Never Looked So Good

Search found 6 matches

by Mainer
Fri Sep 04, 2009 8:02 am
Forum: SoundBridge Radio General Discussion
Topic: Repair and repair gurus
Replies: 10
Views: 18162

Repair and repair gurus

You guys who can dissect Roku units amaze me. I took the easy way: UPS'd my SBR to Matt in Austin. Ten days later, UPS brought it home. No change in appearance, no wires hanging out, no screwdriver scratches around the screws, and I think that Matt even cleaned the case. One big change: the radio wo...
by Mainer
Sun Aug 16, 2009 9:29 am
Forum: SoundBridge General Discussion
Topic: Soundbridge power supply replaced by Matt in Austin
Replies: 1
Views: 2927

Soundbridge power supply replaced by Matt in Austin

My SBR failed in its third year: the notorious power supply got me. I found Matt Burkhard's name on this forum, contacted him at burkhardi@hotmail.com, downloaded his service work order from http://www.tinyURL.com/ServiceMatt, and about ten days later I had my Soundbridge back, fully repaired. All o...
by Mainer
Thu Dec 27, 2007 9:42 am
Forum: SoundBridge Radio General Discussion
Topic: Can't tune an FM station
Replies: 2
Views: 2134

Thanks, SuzieQ.
by Mainer
Thu Dec 27, 2007 7:32 am
Forum: SoundBridge Radio General Discussion
Topic: Can't tune an FM station
Replies: 2
Views: 2134

Can't tune an FM station

An FM station which I receive on other radios will not come in on my SBradio. WhenI tune to the station's frequency, my SB yields static? Help?
by Mainer
Thu Dec 27, 2007 7:29 am
Forum: SoundBridge Radio General Discussion
Topic: Soundbridge radio plays but controls don't respond
Replies: 1
Views: 2020

Soundbridge radio plays, but controls don't respond

Solved the problem by powering down (unplugging power cord), then restarting. I'd still be interested to know cause. Thanks.
by Mainer
Wed Dec 26, 2007 8:03 am
Forum: SoundBridge Radio General Discussion
Topic: Soundbridge radio plays but controls don't respond
Replies: 1
Views: 2020

Soundbridge radio plays but controls don't respond

I'm playing internet radio thru an iTunes playlist. I hit the home and down arrow keys on the remote. The display went blank, and the radio does not respond to either the remote or the controls on the radio. The station plays on. Anyone seen this before? Many thanks.