Your Digital Media Has Never Looked So Good

Search found 30 matches

  • 1
  • 2
by lisakb140
Mon Feb 04, 2019 9:29 am
Forum: Roku Developer Program
Topic: When do things get cleared from Texture Memory?
Replies: 0
Views: 305

When do things get cleared from Texture Memory?

I've been looking through the docs to try to find this out, but haven't had any luck. I'm trying to figure out when images get cleared from the texture memory in a channel-- are images that are no longer visible on the screen (after changing screens, for example) still in texture memory? For example...
by lisakb140
Thu Jan 31, 2019 8:44 am
Forum: Roku Developer Program
Topic: Screen strobing/flashing only on Roku Stick with SceneGraph Update
Replies: 1
Views: 313

Screen strobing/flashing only on Roku Stick with SceneGraph Update

We have a channel that we recently updated to use the new SceneGraph framework. It passed Roku's testing and has been published successfully. However, we've had several users notify us that the screen "strobes" or flashes when they open up the channel. ALL of these complaints come from use...
by lisakb140
Fri Nov 30, 2018 8:02 am
Forum: Roku Developer Program
Topic: Registry not cleared after removing channel
Replies: 17
Views: 3549

Re: Registry not cleared after removing channel

.has anyone else had a similar experience with flush()? If you're not flush()-ing. the data in question won't be saved.  Now, maybe that's what you want, and maybe not. If you are having trouble with things persisting, it means you are not deleting the right things, when you think you are. Thanks, ...
by lisakb140
Thu Nov 29, 2018 2:30 pm
Forum: Roku Developer Program
Topic: Registry not Cleared if App is deleted
Replies: 15
Views: 3879

Re: Registry not Cleared if App is deleted

I even tried doing a factory reset, and it seems this data has still persisted. I am using the new Roku SG framework, and I am trying to programmatically delete data in my app when a user logs out, with the deleteRegistry sub Function in generalUtilities (it uses Delete(key)). Does anyone know why e...
by lisakb140
Thu Nov 29, 2018 2:15 pm
Forum: Roku Developer Program
Topic: Registry not cleared after removing channel
Replies: 17
Views: 3549

Re: Registry not cleared after removing channel

I am having this problem too, clearing the Registry of user information (logging in/logging out). I'm using the new SG framework, and it has a deleteRegistry sub function in generalUtilies that looks like this: sub deleteRegistry(keySection="" As String)     print "Starting Delete Reg...
by lisakb140
Wed Nov 28, 2018 9:03 am
Forum: Roku Developer Program
Topic: Can't Set Up Roku_Analytics:AnalyticsNode
Replies: 3
Views: 267

Re: Can't Set Up Roku_Analytics:AnalyticsNode

Ah, good call!  I copied and pasted  sg_component_libs_required=Roku_Analytics into the "Other Libraries" field in my manifest, but got an error saying "BS lib provider not found." However, when I just put in "Roku_Analytics" into that field, I was able to successfully ...
by lisakb140
Tue Nov 27, 2018 3:30 pm
Forum: Roku Developer Program
Topic: Can't Set Up Roku_Analytics:AnalyticsNode
Replies: 3
Views: 267

Can't Set Up Roku_Analytics:AnalyticsNode

I am trying to integrate the Roku Analytics Component, specifically Google Analytics,with my Roku Channel, per the documentation here  (starting at "Implementation") However, I keep getting an error when I try to create the roSGNode with type Roku_Analytics:AnalyticsNode. I literally copie...
by lisakb140
Thu Oct 11, 2018 12:54 pm
Forum: Roku Developer Program
Topic: Label Node Created in main.brs not rendering
Replies: 9
Views: 502

Re: Label Node Created in main.brs not rendering

I tried reworking this a little, annd now I'm getting a Type mismatch error (appending a Label Node as a child to a VideoNode). Is that prohibited for some reason?
by lisakb140
Thu Oct 11, 2018 11:52 am
Forum: Roku Developer Program
Topic: Label Node Created in main.brs not rendering
Replies: 9
Views: 502

Re: Label Node Created in main.brs not rendering

For some reason that throws a fatal error. I have: row = createObject("RoSGNode","VideoNode") label = CreateObject("roSGNode", "Label") label.text = "EPISODES AVAILABLE" row.appendChild(label) I'm not sure why that crashes things-- it doesn't seem th...
by lisakb140
Thu Oct 11, 2018 11:51 am
Forum: Roku Developer Program
Topic: Label Node Created in main.brs not rendering
Replies: 9
Views: 502

Re: Label Node Created in main.brs not rendering

For some reason that throws a fatal error. I have: row = [i]createObject[/i]("RoSGNode","VideoNode") label = [i]CreateObject[/i]("roSGNode", "Label") label.[b]text[/b] = "EPISODES AVAILABLE" row.appendChild(label) I'm not sure why that crashes things...
by lisakb140
Thu Oct 11, 2018 11:24 am
Forum: Roku Developer Program
Topic: Label Node Created in main.brs not rendering
Replies: 9
Views: 502

Re: Label Node Created in main.brs not rendering

Yeah, I'm not sure why that prints like that. In my brs I specify

label.color="0xFFFFFF"
by lisakb140
Thu Oct 11, 2018 11:02 am
Forum: Roku Developer Program
Topic: Specifying Font on RowLabel crashes channel
Replies: 5
Views: 282

Re: Specifying Font on RowLabel crashes channel

Got it!! I had to create a Font node in my brs and assign it to rowLabelFont there. All good!
by lisakb140
Thu Oct 11, 2018 10:34 am
Forum: Roku Developer Program
Topic: Specifying Font on RowLabel crashes channel
Replies: 5
Views: 282

Re: Specifying Font on RowLabel crashes channel

Haha, that is true! It crashes when I put the following inside my RowList node


<Font role="font" uri = "pkg:/fonts/BarlowCondensed-Medium.ttf" size="24"/>
by lisakb140
Thu Oct 11, 2018 10:25 am
Forum: Roku Developer Program
Topic: Specifying Font on RowLabel crashes channel
Replies: 5
Views: 282

Re: Specifying Font on RowLabel crashes channel

I tried that--what happens then is the text just doesn't render at all.
by lisakb140
Thu Oct 11, 2018 10:20 am
Forum: Roku Developer Program
Topic: Custom font for Rowlist label ?
Replies: 8
Views: 1274

Re: Custom font for Rowlist label ?

I am struggling with this same issue---what did you end up doing to make this work??
  • 1
  • 2