Your Digital Media Has Never Looked So Good

Search found 12 matches

by rrobinson
Sat May 29, 2010 7:26 am
Forum: Roku Developer Program
Topic: Packaging Clarification
Replies: 4
Views: 2372

Re: Packaging Clarification

That's what I was thinking, it would have to have no images and I couldn't
figure out how to make that happen. Thanks.
by rrobinson
Fri May 28, 2010 3:48 pm
Forum: Roku Developer Program
Topic: Packaging Clarification
Replies: 4
Views: 2372

Packaging Clarification

It was stated that even large apps were around 50k. http://forums.roku.com/viewtopic.php?f=34&t=28416 I'm obviously misunderstanding how to package. The manifest requires 4 image files, even with png8 in the sizes required I can't get them under about 28k each. So I packaged and uploaded with no...
by rrobinson
Fri May 28, 2010 2:28 pm
Forum: Roku Developer Program
Topic: Private Channel Upload Problem <solved>
Replies: 7
Views: 4630

Re: Private Channel Upload Problem

Thanks, it was an orignal package with poster images that are now being fetched from our server. I removed them and now the package is 59k Still didn't work...but We are used to tagging our Program titles with their state ex: <development> This seems to be what was making it choke. Removed it and it...
by rrobinson
Fri May 28, 2010 11:53 am
Forum: Roku Developer Program
Topic: Charset Problem
Replies: 1
Views: 1692

Re: Charset Problem

by rrobinson
Fri May 28, 2010 2:41 am
Forum: Roku Developer Program
Topic: getting started with roku
Replies: 1
Views: 2889

Re: getting started with roku

a) Yes, you put the Roku in developer mode and as you write code you zip it up and upload to the Roku. This is how you test and debug it. More specific instructions are in the docs provided with the sdk. b) Your computer would be the workstation, the text editor could be notepad or something similia...
by rrobinson
Fri May 28, 2010 2:17 am
Forum: Roku Developer Program
Topic: Private Channel Upload Problem <solved>
Replies: 7
Views: 4630

Re: Private Channel Upload Problem

Good question, Thanks for replying. I checked just to make sure, did a reboot and shut my virus protection off. I have two networks, one that has a wireless router attached and one not. I disconnected them one at a time and tried each independently after bypassing the firewalls ( they are hardware f...
by rrobinson
Thu May 27, 2010 10:38 am
Forum: Roku Developer Program
Topic: Private Channel Upload Problem <solved>
Replies: 7
Views: 4630

Re: Private Channel Upload Problem

I just tried it again and received the same message.
I had tried it two nights in a row before I posted.

thanks
by rrobinson
Thu May 27, 2010 12:27 am
Forum: Roku Developer Program
Topic: Private Channel Upload Problem <solved>
Replies: 7
Views: 4630

Private Channel Upload Problem <solved>

When I try to upload my package I get this message: The website experienced an unexpected problem in url bar: https://owner.roku.com/Error.htm?code=500&subcode=0&url=https%3a%2f%2fowner.roku.com%2fDeveloper%2fHome%2fdefault.aspx When I run an inspect on the package everything looks good. Any...
by rrobinson
Mon May 24, 2010 9:56 am
Forum: Roku Developer Program
Topic: Adding Translations <solved>
Replies: 7
Views: 4136

Re: Adding Translations <solved>

Thanks for the fast reply!
Saved me a ton of time on testing.
by rrobinson
Sun May 23, 2010 11:59 pm
Forum: Roku Developer Program
Topic: Adding Translations <solved>
Replies: 7
Views: 4136

Re: Adding Translations <solved>

Just in case anyone comes across this. I converted the string to it's ord numbers, ';' seperated, before packaging in the xml for example in php $ord_string = ""; for( $i = 0; $i < strlen( $translation['t_translated'] ); $i++ ) { $ord_string .= ord( $translation['t_translated'][$i] ) . &qu...
by rrobinson
Sun May 23, 2010 8:35 pm
Forum: Roku Developer Program
Topic: Adding Translations <solved>
Replies: 7
Views: 4136

Re: Adding Translations

Just in case anyone wanted a sample of xml that fails parsing for me. This is a google translate so please excuse my spanish ;) <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <translations> <translation> <from><![CDATA[This player is already registered]]></from...
by rrobinson
Sun May 23, 2010 8:24 pm
Forum: Roku Developer Program
Topic: Adding Translations <solved>
Replies: 7
Views: 4136

Adding Translations <solved>

I was wanting to add translations through an http request returning xml. I have the bright script code working and the backend server code written. I'm using a mysql database with utf8_general_ci encoding. On some translations, the simple ones, french, spanish etc. (haven't even tried chinese yet ) ...