Your Digital Media Has Never Looked So Good

Search found 17 matches

  • 1
  • 2
by edunn@lifeminute.tv
Mon Feb 27, 2012 10:33 am
Forum: Roku Developer Program
Topic: How can I get my pub channel on roku website w the others?
Replies: 1
Views: 1097

How can I get my pub channel on roku website w the others?

Hi everyone! My channel was approved a few months ago, and is now a proud part of the content available through Roku. I just have one question. In order to better market my app to potential or current roku users, I would like my channel to appear among the list of channels on Roku's website. (as see...
by edunn@lifeminute.tv
Tue Dec 27, 2011 2:39 pm
Forum: Roku Developer Program
Topic: XML - Categories/Levels Question
Replies: 40
Views: 35282

Re: XML - Categories/Levels Question

Aha! Solved. Thanks so much for all your help!! The problem turned out that I was applying the o.Feed = xml@feed to the wrong case in CategoryFeed.brs. It needs to be under "if xml.GetName() = "category" then" instead of "elseif xml.GetName() = "specialCategory" th...
by edunn@lifeminute.tv
Tue Dec 27, 2011 2:19 pm
Forum: Roku Developer Program
Topic: XML - Categories/Levels Question
Replies: 40
Views: 35282

Re: XML - Categories/Levels Question

Sorry, that was the browser interperation, The ampersand is escaped. I was able to get my app to function 100% correctly when it was using leafs, so it's really not a quality-of-feed issue. I have my root feed at categories.xml which leads to a separate feed for each category. Using the video player...
by edunn@lifeminute.tv
Tue Dec 27, 2011 1:57 pm
Forum: Roku Developer Program
Topic: XML - Categories/Levels Question
Replies: 40
Views: 35282

Re: XML - Categories/Levels Question

The other day I started with a fresh SDK & went through this and confirmed that it is correct / successfully removes the leafs. The ONLY thing I left out is that you need to update your XML to include a 'feed' for the top level 'category' elements. cheers, Joe I made all the changes you listed,...
by edunn@lifeminute.tv
Tue Dec 27, 2011 12:47 pm
Forum: Roku Developer Program
Topic: Telnet Connection refused
Replies: 3
Views: 2640

Re: Telnet Connection refused

Ah, it turns out it was the IT dept here, they changed the router hardware, and I wasn't aware of it. They fiddled with the settings and now it works fine again.

Thanks so much,
Evan
by edunn@lifeminute.tv
Tue Dec 27, 2011 8:37 am
Forum: Roku Developer Program
Topic: Roku V 4.1 build 2667 Broke my app
Replies: 7
Views: 3027

Re: Roku V 4.1 build 2667 Broke my app

My app now works again with V 4.2 build 1006

I made no changes... So... that's cool. Makes me nervous at the inconsistant behavior of the OS, but I'm glad to see the app working again. I just wish v 4.2 build 1006 hadn't landed the day before my boss came in to review the project. :p
by edunn@lifeminute.tv
Tue Dec 27, 2011 8:34 am
Forum: Roku Developer Program
Topic: Telnet Connection refused
Replies: 3
Views: 2640

Telnet Connection refused

Hi all, I'm having a really strange problem. When I try to connect to my Roku device through telnet, I'm getting "connection refused". I confirmed that developer mode is running, I even turned it off and then back on. I type telnet 192.168.0.222 8085 (network settings on the roku box confi...
by edunn@lifeminute.tv
Thu Nov 17, 2011 7:29 am
Forum: Roku Developer Program
Topic: Roku V 4.1 build 2667 Broke my app
Replies: 7
Views: 3027

Re: Roku V 4.1 build 2667 Broke my app

Here is the output. ---- AA ---- starrating: 90 hdbifurl: shortdescriptionline2: shortdescriptionline1: It's National Animal Safety and Protection Month! contentid: sdbifurl: categories: (list of 1)... List(0)= sdposterurl: http://lifeminute.tv/sites/default/files/imagecache/roku_sd_poster/images/vi...
by edunn@lifeminute.tv
Wed Nov 16, 2011 3:34 pm
Forum: Roku Developer Program
Topic: Roku V 4.1 build 2667 Broke my app
Replies: 7
Views: 3027

Re: Roku V 4.1 build 2667 Broke my app

I don't think I made any changes to appVideoScreen.brs Function showVideoScreen(episode As Object) if type(episode) <> "roAssociativeArray" then print "invalid data passed to showVideoScreen" return -1 endif port = CreateObject("roMessagePort") screen = CreateObject(&qu...
by edunn@lifeminute.tv
Wed Nov 16, 2011 1:38 pm
Forum: Roku Developer Program
Topic: Roku V 4.1 build 2667 Broke my app
Replies: 7
Views: 3027

Re: Roku V 4.1 build 2667 Broke my app

Everything looks ok through the console except I'm getting when I play a video: "Unexpected event type: 20" The video fails most of the time, but not all of the time. Sometimes the video does play successfully, but I don't know why. When the video fails I get this is the message: "sho...
by edunn@lifeminute.tv
Wed Nov 16, 2011 12:58 pm
Forum: Roku Developer Program
Topic: Roku V 4.1 build 2667 Broke my app
Replies: 7
Views: 3027

Roku V 4.1 build 2667 Broke my app

Hi all, I was in the process of developing an app, and everything was working when I last checked it. Today, I gave it another test drive without changing anything, and it's broken. The app loads, and attempts to play videos but once the video is loaded it either crashes or it returns me to the sele...
by edunn@lifeminute.tv
Mon Nov 07, 2011 2:28 pm
Forum: Roku Developer Program
Topic: Customized Video Player sample ignoring hd_img
Replies: 1
Views: 1047

Re: Customized Video Player sample ignoring hd_img

Nevermind, the Roku was just set to widescreen and not hd. My fault!
by edunn@lifeminute.tv
Mon Nov 07, 2011 2:16 pm
Forum: Roku Developer Program
Topic: Customized Video Player sample ignoring hd_img
Replies: 1
Views: 1047

Customized Video Player sample ignoring hd_img

Hi all, Weird problem I'm having. I've got a customized version of the video player sample, and I'm finding that the hd_image tag defined in categories.xml is being ignored, and the Roku device only loads the sd_image. Does anyone know why this might be? It's causing the SD icon to warp and stretch ...
by edunn@lifeminute.tv
Mon Nov 07, 2011 2:11 pm
Forum: Roku Developer Program
Topic: XML - Categories/Levels Question
Replies: 40
Views: 35282

Re: XML - Categories/Levels Question

So have these modifications been successful for anyone? I tried applying them to my app, and it came up with a number of syntax errors in appHomeScreen.brs

I'd really like to get those subcategories out of there. I'm wondering if I made a mistake of my own somewhere...

Thanks so much everyone.
by edunn@lifeminute.tv
Mon Nov 07, 2011 2:03 pm
Forum: Roku Developer Program
Topic: Can't parse feed error, driving me crazy
Replies: 8
Views: 5124

Re: Can't parse feed error, driving me crazy

Ah! That did the trick.

Thanks so much!!

-Evan
  • 1
  • 2