Your Digital Media Has Never Looked So Good

Search found 315 matches

by Baradanikto
Sun Jun 18, 2017 8:23 am
Forum: Roku Direct Publisher
Topic: shortFormVideo adBreaks
Replies: 4
Views: 803

Re: shortFormVideo adBreaks

Thanks for the reply.  I can appreciate that, but, why then, does the Content object that's embedded in the shortFormVideo allow adBreaks?  The spec does not specify that mid-roll adBreaks are only for non-shortFormVideo objects.
by Baradanikto
Sun Jun 18, 2017 7:34 am
Forum: Roku Direct Publisher
Topic: shortFormVideo adBreaks
Replies: 4
Views: 803

shortFormVideo adBreaks

I've specified 5 adbreaks for a shortformVideo that's almost an hour.  The ads do not occur.  Are shortformVideos exempt from adbreaks, or, do I need to specify the content differently? Here's the adbreak line in json....             ],                                                 "dateAdded...
by Baradanikto
Sun Jun 18, 2017 7:27 am
Forum: Roku Direct Publisher
Topic: Published Channel missing from 'New and Notable'
Replies: 1
Views: 550

Re: Published Channel missing from 'New and Notable'

Update: My channel finally made it to "New and Notable".  I guess it takes a while before that happens.  It would have been nice to know that up front.
by Baradanikto
Fri Jun 16, 2017 9:20 am
Forum: Roku Direct Publisher
Topic: Sample Direct Publisher Feed
Replies: 39
Views: 12199

Re: Sample Direct Publisher Feed

Mediadisconnect,

Thanks for the reply.  However, I'm still a bit confused since the spec says that the field is an 'integer', but, the sample show it as '1328.0'.
by Baradanikto
Thu Jun 15, 2017 12:16 pm
Forum: Roku Direct Publisher
Topic: Sample Direct Publisher Feed
Replies: 39
Views: 12199

Re: Sample Direct Publisher Feed

I'm writing some software to manage json feeds.  As part of my development, I tried to load the sample feed mentioned at the beginning of this post.  I got an exception in my code, because I defined the 'bitrate' to be an integer (like it says in the json feed specifications).  However, the value gi...
by Baradanikto
Wed Jun 14, 2017 11:48 am
Forum: Roku Direct Publisher
Topic: Error Accessing Developer portal from Chrome
Replies: 3
Views: 880

Re: Error Accessing Developer portal from Chrome

Thanks for your reply.  However, it's not helpful since Chrome used to work for me also.  And, it still works when I access the forum.
by Baradanikto
Wed Jun 14, 2017 11:45 am
Forum: Roku Direct Publisher
Topic: Published Channel missing from 'New and Notable'
Replies: 1
Views: 550

Published Channel missing from 'New and Notable'

I received notification that my channel was published this week (June 12).  I checked to see if it was listed in the "New and Notable".  As of this morning, it does not show under that section.  However, it does display under the category (Sports) I had selected.  Is that normal?  If so, h...
by Baradanikto
Wed Jun 07, 2017 2:34 pm
Forum: Roku Direct Publisher
Topic: Error Accessing Developer portal from Chrome
Replies: 3
Views: 880

Re: Error Accessing Developer portal from Chrome

Ping....Is this a problem for anyone else?
by Baradanikto
Tue Jun 06, 2017 10:35 am
Forum: Roku Direct Publisher
Topic: Having an issue with XML feed
Replies: 57
Views: 3786

Re: Having an issue with XML feed

PJSWeb,

Please see MRSS Feed Update Utility and MRSS to JSON Converter.  This may help you.
by Baradanikto
Sun Jun 04, 2017 11:47 am
Forum: Roku Direct Publisher
Topic: Error Accessing Developer portal from Chrome
Replies: 3
Views: 880

Error Accessing Developer portal from Chrome

Within the last few days, I've begun getting an error when I try to access the developer portal from Chrome.  After entering my credentials, I get:


Access to My.Roku.Com was denied
You don't have authorization to view this page.
Http error 403



I can, however, access the portal if I use Firefox.
by Baradanikto
Sat May 20, 2017 1:12 pm
Forum: Roku Direct Publisher
Topic: Video Problems since update to OS 7.6
Replies: 3
Views: 903

Re: Video Problems since update to OS 7.6

UPDATE : I'd like to get to the bottom of this with help from Roku if they troll this forum.  I've found that on the videos that do not always start from the beginning, I can use the remote to rewind to the start.  What I don't understand is why the videos sometimes start a few seconds into the str...
by Baradanikto
Sat May 20, 2017 1:03 pm
Forum: Roku Direct Publisher
Topic: MRSS to JSON Conversion Utility
Replies: 0
Views: 796

MRSS to JSON Conversion Utility

Hi everyone, After writing the MRSS Feed Update Utility , I've been busy putting together a conversion program to complement it.  I've just released the MRSS to JSON Converter to convert an MRSS feed to a JSON (' shortFormVideo ') feed.  I'm also in the process of writing a JSON Feed Manager, but, t...
by Baradanikto
Sun May 07, 2017 7:46 am
Forum: Roku Direct Publisher
Topic: Video Problems since update to OS 7.6
Replies: 3
Views: 903

Re: Video Problems since update to OS 7.6

UPDATE :  To validate my claim, I downloaded a video in question from my Amazon S3 bucket.  The video plays from the beginning on my laptop.  However, if I view it on several Roku devices, it does not start at the beginning.  This video, and others like it, used to play correctly before the recent ...
by Baradanikto
Sat May 06, 2017 1:32 pm
Forum: Roku Direct Publisher
Topic: Video Problems since update to OS 7.6
Replies: 3
Views: 903

Video Problems since update to OS 7.6

My Roku was updated to OS 7.6 yesterday (May 5).  Today, I noticed that some of my videos on my channel do not stream correctly.  In fact, I have one video that no longer plays.  It plays sound, but, no video (green background).  It used to play correctly before this update. Additionally, I've notic...
by Baradanikto
Thu Apr 06, 2017 2:05 pm
Forum: Roku Direct Publisher
Topic: Missing videos - category error?
Replies: 3
Views: 674

Re: Missing videos - category error?

The utility program I wrote to update the feed now works to prevent any problems in the feed.  I can output MRSS and convert it to JSON with a Powershell script with no problem.  So, adding the categories and the tags in the feed is not a problem for me.