Your Digital Media Has Never Looked So Good

 
Kevin McMurtrie
Posts: 13
Joined: Sat Dec 29, 2007 1:36 am
Contact:

Apple Lossless still broken

Tue Aug 12, 2008 8:17 pm

Apple Lossless still doesn't work. It fails instantly twice then hangs. The Roku's log shows all zeros except DaapConnect: 1. The DAAP looks fine - GET for metadata, status 200 returned with metadata, GET for the m4a file, status 200 returned with song. The file has ftyp 'M4A ', then the 'moov', a little 'free', then the 'mdat'. Roku sends reset packets during the mdat stream. The process to fetch the file repeats two more times.

My biggest feature request remains the same: A useful log!
 
bobinchicago
Posts: 136
Joined: Fri Feb 17, 2006 5:15 pm

Thu Aug 14, 2008 6:39 pm

Hi Kevin -- Right this very minute I'm listening to an Apple Lossless file encoded using OS X iTunes 7.7 and served by OS X iTunes 7.7.1 on my Soundbridge M1001 running 2.7.78. I've read here that some versions of iTunes incorrectly encode some files, and there have been other bugs involving extended-ASCII and Unicode characters in file names and meta tags. But from what you say, it sounds like a server-client issue. I don't know if any of your versions are different from what I'm running, but my setup has worked fine; the Soundbridge is wired, but the server is wireless. Because of the aforementioned compatibility issues I've kept my music server running an old version of iTunes -- 7.3.x if I recall -- but if remaining tests on a backup server go as well as they already have, I'll be happy to update the primary server to 7.7.1.
 
Kevin McMurtrie
Posts: 13
Joined: Sat Dec 29, 2007 1:36 am
Contact:

Sun Aug 17, 2008 12:25 am

I tried something different - a different iTunes serving music. That worked.

Even though my server's iTunes works great with everything else, it doesn't work with my Rokus. Now the trick is figuring out what's different. Again, logs would be helpful.
 
markmaus
Posts: 3
Joined: Thu Oct 16, 2008 1:03 am

What about a Firmware with realy new features?!

Thu Oct 16, 2008 1:12 am

Many people, like me, would like to have an audioscrobbler funktion for the Soundbridge, so that the Soundbridge dierectly transmittes th played songs to a specified LAST.FM Account. This would be very great!
Existing external audiscrobblers for the Soundbrige make it nessesary to have an allways running computer which monitors the Soundbridge :(

Kind Regards

Mark
 
lazyd0g
Posts: 13
Joined: Thu Oct 16, 2008 4:52 am

beta download

Thu Oct 16, 2008 4:58 am

Hi People.

I'm getting "Access denied for user 'apache'@'localhost' (using password: NO)"

Do "you" know if this is because the m1001 is no longer in production?

Is there any other way of getting the beta firmware other than via http://www.roku.com/products/soundbridge/software/beta/ ??

thanks

Steve
 
lazyd0g
Posts: 13
Joined: Thu Oct 16, 2008 4:52 am

It Works Now!!

Thu Oct 16, 2008 5:32 am

ok - it works now v 3.0.52 and I can stream my bbc stations!! :D

just a shame that soundbridges are no longer in production as I'd love to buy another one.
 
alanmc
Posts: 1391
Joined: Mon Jun 11, 2007 10:40 am
Location: Bedfordshire - U.K.

Fri Nov 21, 2008 10:07 pm

UPDATE 22 NOV '08 - from having made a very quick test, the very bloated iTunes v 8.0.2.20 appears to stream A/OK from my Vista laptop to all my SoundBridges with both 3.0.52 and 3.0.44 versions.
 
Schlitz
Posts: 14
Joined: Sun Mar 19, 2006 2:42 pm
Location: Germany, Bavaria

Tue Dec 30, 2008 5:05 am

Hello,
I just installed the new firmware on the soundbridge.

I use the TwonkyMedi software 4.4.9 since a long time now and didn't change it. I often use the option from UPnP called "browse server folders". It's the option not to browse through the albums or artists, but the server folders in which the MP3 files are in. It always worked fine until I did the update of the Soundbridge firmware to 3.0.52

I can not start playing songs using the above described scenario.
The error message I got in german is "Laden fehlgeschlagen. Ungültige Antwort empfangen." - I got this error message when I enter a folder which contains the MP3 files.

Now I want to reinstall an older firmware, butr I don't know how.

Can anyone please help me with that ?
 
S80_UK
Posts: 1035
Joined: Wed Oct 25, 2006 3:11 am
Location: Cambridgeshire, UK

Tue Dec 30, 2008 5:39 am

There is a page to allow a downgrade (back to 2.5.174 I think) and then you can upgrade from there. But I just can't find the page at the moment.

However, I am not certain that this is the problem. I am running firmware 3.0.52 and I just did a quick test using Twonky, although version 4.4.5 which is currently installed on my server. It worked fine using Browse Server Containers allowing me to search and find specific albums / songs etc.
Roku M1000, M1001, M2000, R1000, Roberts WM-201, Stream 83i
 
alanmc
Posts: 1391
Joined: Mon Jun 11, 2007 10:40 am
Location: Bedfordshire - U.K.

Tue Dec 30, 2008 6:00 am

Hi Schlitz,

I use both 3.0.52 and 3.0.44 on my M1001s, and Twonky 4.4.5 on my Home Server without issues -

I've sent you a PM explaining how to undertake a factory Reset - You can then upgrade back to 3.0.44 from there.

Cheers, Alan
 
Schlitz
Posts: 14
Joined: Sun Mar 19, 2006 2:42 pm
Location: Germany, Bavaria

Tue Dec 30, 2008 7:38 am

Hello,
thank you very much for supporting me: it was NOT the Soundbridge firmware update as you already wrote.
But I didn't change the Twonky software on the server.
I will try to find the solution within the Twonky Server software and/or configuration.

Once again: Thanks for helping me.

Have quite god and happy new year 2009

Volker
 
dupondt
Posts: 1653
Joined: Sun Aug 19, 2007 6:46 am
Location: Germany, European Union

Tue Dec 30, 2008 8:45 am

Hi Volker,

this may be a shot to nothing, but is it possible that some of the filenames and/or tags contain characters which "irritate" the SoundBridge, for example accented vowels or umlauts?

Greetings
dupondt
SoundBridge M1001 and M1000 • Clint L1 (retired) • DNT IP-dio (retired)
Google Chromecast • Amazon Fire TV • Amazon Echo and Echo Dot
 
Schlitz
Posts: 14
Joined: Sun Mar 19, 2006 2:42 pm
Location: Germany, Bavaria

Tue Dec 30, 2008 12:44 pm

Ok, I solved it: it was the length of the path on the server.

Solution:
I put in the begin of the path to the MP3 files (/flash/data/public/) into the config of TwonkyMedia on the config page under "sharing" within the variable "content location".

Thanks
Volker
 
athoss
Posts: 5
Joined: Tue Dec 30, 2008 4:06 pm
Location: Aurora, CO, USA

iTunes 8 M1001 Apple Lossless

Tue Dec 30, 2008 4:12 pm

Ever since upgrading to iTunes 8 I am no longer able to play the ALAC files on my G5 with my m1001. I can SEE the files and read the info for the files all form my SB but when I try to play them, it says it cannot play and asks to try the next song or stop.
This seems to be the case with ALAC files encoded with Max and with iTunes 7/8.
AAC and MP3 files play just fine from the same iTunes share.

my M1001 is running 3.0.52

Is this a problem with the current SB firmware or did Apple break iTunes?
The same files play when shared by firefly, but I would rather not have to run two programs when one USED to work.
 
atlantic.mac
Posts: 14
Joined: Sat May 26, 2007 12:56 pm
Location: France

Bug with Bonjour protocol

Fri Jan 02, 2009 11:56 am

the URL linked to Bonjour protocol is wrong

it is http://soundbridge.local./SoundBridge.html instead of http://soundbridge.local

May you correct it ?

Who is online

Users browsing this forum: No registered users and 3 guests