Your Digital Media Has Never Looked So Good

 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Wed Jun 07, 2017 8:08 am

For some reason, Roku isn't liking your video files.  I am just not sure why.  

Roku still has a problem with your json file downloading from your server.  I am getting "Unable to download from feedUrl.".  I am still trying to remember how I fixed it on my end.
 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Wed Jun 07, 2017 8:27 am

Ok I remember how I fixed my issue with "Unable to download from feedUrl"...

If you look at your server logs, when Roku tries to download your .json file you are probably getting 406 errors.  If your hosting service provides you cpanel access go into apache meme types and add the meme type: application/json with the extension: json

Once I added this, my 406 errors went away and Roku could download my feed.

If you don't have cpanel access you can add the following to your .htaccess file:

AddType application/json json

If that still doesn't work then just call your hosting company and tell them you need to fix 406 errors.

I still don't know why your mp4 files aren't being seen by Roku (I can download them fine).
 
mosafer
Posts: 81
Joined: Tue Feb 21, 2017 1:19 pm

Re: Having an issue with XML feed

Wed Jun 07, 2017 10:08 am

Did you try your json file so many times?
I know some servers, if there is so many tries from certain IP, will block IP from accessing the file.
Make sure Roku IPs are not blocked in your server side.
 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Wed Jun 07, 2017 12:37 pm

Ok, I took your JSON file and video file put it on my server and everything works fine.  At this point they problem is with your hosting.  Check your error logs and I am sure you will be seeing a few weird errors especially 406s.  Talk to your provider to have them help clear up the issue.  Both issues with the JSON and video file are probably for the same reason. 
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Wed Jun 07, 2017 8:05 pm

So sorry, didn't see the second page to this post. I see your updates now and am gonna try all of that out.... I will post an update very soon. Thanks!!
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Wed Jun 07, 2017 8:11 pm

Okay, added the MIME type to the server via CPanel. Then, I went to security / IP Blocker and see there are no IP's blocked.

However, I am still getting the same results from Roku, Unable to download from feedUrl.
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Wed Jun 07, 2017 8:12 pm

Also, I am on a Linux Dedicated server, so if there are any changes I need to make... I can do that. I just don't know why they wouldn't deliver from the server to Roku. It shouldn't be blocked anywhere that I know of.
 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Thu Jun 08, 2017 5:43 am

Web servers expect a useragent and other header info to be passed from the web client when a request is made. The Roku servers use http as a transport but don't pass the all header info so the server becomes suspicious and doesn't send.

Your URL can't be HTTPS either.

You may need to disable ModSecurity to get past the errors. The following thread discusses all of these issues a little more clearly.

https://forums.roku.com/viewtopic.php?t=99232
 
mosafer
Posts: 81
Joined: Tue Feb 21, 2017 1:19 pm

Re: Having an issue with XML feed

Thu Jun 08, 2017 8:40 am

PJSWeb wrote:
Okay, added the MIME type to the server via CPanel. Then, I went to security / IP Blocker and see there are no IP's blocked.

However, I am still getting the same results from Roku, Unable to download from feedUrl.

Most of the time, if your host is not dedicated, the server is blocking IP, not your Cpannel. you can contact hosting for that issue.
Also please reduce your image file size to minimum. if your thumbnail should be minimum 800x450, do not make bigger files.
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Thu Jun 08, 2017 10:53 am

mediadisconnect wrote:
Web servers expect a useragent and other header info to be passed from the web client when a request is made.  The Roku servers use http as a transport but don't pass the all header info so the server becomes suspicious and doesn't send.

Your URL can't be HTTPS either.

You may need to disable ModSecurity to get past the errors.  The following thread discusses all of these issues a little more clearly.

https://forums.roku.com/viewtopic.php?t=99232

You were right, it was ModSecurity. I disabled that and now have a new error: The feed format is invalid. We are unable to parse it.

I am not sure why it is unable to parse my json, however now at least I know that it is downloading it. Ah. This is overwhelming. But thanks, again!
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Thu Jun 08, 2017 10:56 am

Ah but I limited it to 10 results and it read fine. So, there is something in one of the entries that is having a problem.

Thank you!!!! I will just need to learn what symbols I need to strip and I think we got it!
 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Thu Jun 08, 2017 11:10 am

Congrats!!  I am glad I was able to help.
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Thu Jun 08, 2017 11:14 am

You have helped me out tremendously, and I'm very thankful!
 
PJSWeb
Topic Author
Posts: 27
Joined: Mon Jun 05, 2017 4:22 pm

Re: Having an issue with XML feed

Thu Jun 08, 2017 1:03 pm

I have been able to get it to ingest my video feed. I have also previewed my channel and everything seems to be working correctly. However, I still have a "!" beside the feed url and feed status. Any ideas?

But- AHHH I'm so thankful I am actually seeing results! You're amazing, Mediadisconnect!
 
mediadisconnect
Posts: 115
Joined: Tue May 31, 2016 10:52 am

Re: Having an issue with XML feed

Thu Jun 08, 2017 1:09 pm

If you click on "Feed Status" what are the errors you are getting from your last refresh?

Who is online

Users browsing this forum: No registered users and 1 guest