Your Digital Media Has Never Looked So Good

 
fcollingwood
Topic Author
Posts: 17
Joined: Thu Nov 11, 2004 5:05 pm

MPlay, TVersity and FFDShow

Wed Mar 14, 2007 5:03 am

Given up on Nero Mediahome - it's just too much like bloatware.

So, this is what I'm trying:
TVersity 0.9.9.2
FFDShow rev 1028
MPlay

I've run into a couple of problems.
1. In order to get the TVersity share to show up in the Roku, I have to restart the Windows service
2. I can't browse the TVersity server in MPlay - the folder for it is empty
3. I can browse the TVersity server via the usual means (Shares bar on the left side of the Roku screen), but transcoding doesn't seem to be working. If I try to play a divx or xvid movie, it goes away and thinks for a while and then comes back saying "unable to play file filename"

I'm about to tear my hair out, esp. as the missus is hounding me, as she wants to watch some movies. Can anyone help me with this?
Receiver - Onkyo TX-NR901
Front - Mordaunt Short 908
Centre - Mordaunt Short 905C
Rear - Mordaunt Short 902 Signature
Surround - Mordaunt Short 903
Sub - Mordaunt Short 912
Media Player - Roku HD1000
Plasma - LG RT50PX10
DVD - Samsung DVD-HD747
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Re: MPlay, TVersity and FFDShow

Wed Mar 14, 2007 6:57 am

fcollingwood wrote:
Given up on Nero Mediahome - it's just too much like bloatware.

So, this is what I'm trying:
TVersity 0.9.9.2
FFDShow rev 1028
MPlay

I've run into a couple of problems.
1. In order to get the TVersity share to show up in the Roku, I have to restart the Windows service
2. I can't browse the TVersity server in MPlay - the folder for it is empty
3. I can browse the TVersity server via the usual means (Shares bar on the left side of the Roku screen), but transcoding doesn't seem to be working. If I try to play a divx or xvid movie, it goes away and thinks for a while and then comes back saying "unable to play file filename"

I'm about to tear my hair out, esp. as the missus is hounding me, as she wants to watch some movies. Can anyone help me with this?

As far as #2 is concerned, you probably need to set the "-UseNativeUPnP" option on MPlay's command line. I'm not sure about #1 or #2, though I do seem to remember, when testing with TVersity, if the video didn't play the first time, it often would if I tried launching it a second time...

TheEndless
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
 
fcollingwood
Topic Author
Posts: 17
Joined: Thu Nov 11, 2004 5:05 pm

Wed Mar 14, 2007 1:55 pm

Thanks TheEndless, I'll give the switch a try tonight when I get home - I'm not sure how to do the command line switches, but I'm sure there's some info out there.

Great app, by the way, also using SlimRoku, and am very impressed.
Receiver - Onkyo TX-NR901

Front - Mordaunt Short 908

Centre - Mordaunt Short 905C

Rear - Mordaunt Short 902 Signature

Surround - Mordaunt Short 903

Sub - Mordaunt Short 912

Media Player - Roku HD1000

Plasma - LG RT50PX10

DVD - Samsung DVD-HD747
 
fcollingwood
Topic Author
Posts: 17
Joined: Thu Nov 11, 2004 5:05 pm

Thu Mar 15, 2007 1:58 am

OK, I tried it.

I added it in the wrapper, and this is the result when running it on the command line:

# MPlay.roku
./MPlay.roku: ./MPlay.app -UseNativeUPnP: No such file or directory
#


When invoking "MPlay.roku -UseNativeUPnP", it is the same as before, not suprising, as the wrapper does not handle switches. However, firing it up on the command line gave some insight, as this is what was output:

Path: /upnp/control/content_directory
!!Invalid Response!!
Skipped Control URL: urn:schemas-upnp-org:service:ConnectionManager:1 - http://192.168.0.21:41952/upnp/control/connection_manager
Match Count: 0
Error: kDataError


Is this of any help? I'm using MPlay v. 3.7b
Receiver - Onkyo TX-NR901

Front - Mordaunt Short 908

Centre - Mordaunt Short 905C

Rear - Mordaunt Short 902 Signature

Surround - Mordaunt Short 903

Sub - Mordaunt Short 912

Media Player - Roku HD1000

Plasma - LG RT50PX10

DVD - Samsung DVD-HD747
 
fcollingwood
Topic Author
Posts: 17
Joined: Thu Nov 11, 2004 5:05 pm

Thu Mar 15, 2007 2:28 am

OK, got it done - I RTFM on your website, used -NativeUPnP, as documented. Also, instead of changing the app invocation to "$SXPATH/MPlay.app -NativeUPnP", I have it as "$SXPATH/MPlay.app" "-NativeUPnP"

Now to sort out that transcoding problem.......
Receiver - Onkyo TX-NR901

Front - Mordaunt Short 908

Centre - Mordaunt Short 905C

Rear - Mordaunt Short 902 Signature

Surround - Mordaunt Short 903

Sub - Mordaunt Short 912

Media Player - Roku HD1000

Plasma - LG RT50PX10

DVD - Samsung DVD-HD747

Who is online

Users browsing this forum: No registered users and 5 guests