Your Digital Media Has Never Looked So Good

 
bslayton
Topic Author
Posts: 19
Joined: Wed Mar 09, 2005 8:56 pm

MPlay and userkeys - I know I'm doing something stupid Help!

Fri Jul 14, 2006 7:19 pm

Please Help!

I can't get userkeys to launch MPlay with the correct parameters. If I launch MPlay through the GUI it works fine and when I launch user_1 in telnet it works just fine.

Here is my MPlay.roku:
#!/bin/sh
#
# MPlay.app [-minfilesize=numbytes][-browsedir=dir][-browseroot=dir][-noicons][-largeicons]
# [-hidesize][-fontsize=numpoints][-exitatend][-maxbuffer][-nobrowserdelete]
# [-browserwithback][-FixTS][NTSCRes=n][PALRes=n][filename][filename]
#
SXPATH=`echo "$0" | sed 's/\/MPlay.roku$//'`
"$SXPATH/MPlay.app" -browsedir="/tmp/Volumes/dell8200-movies" -browseroot="/tmp/Volumes/dell8200-movies" -menuoneof -nomenu

Here is my user_1:
#!/bin/sh
PATH=$PATH:/usr/local/bin
/mnt/smb/dell8200/rokuhd1000/exitapps.sh
/mnt/smb/dell8200/rokuhd1000/MPlay.roku &

The MPlay.roku in user_1 is the same one I listed above. I've tried robooting thinking it was in memory but didn't help. Is there some kind of cache I need to clear? It works if I just telnet into the box and just run user_1 from the prompt! ugh!

Thank you,
b.
 
pxegeek
Posts: 94
Joined: Mon Jan 24, 2005 9:23 pm

Fri Jul 14, 2006 7:51 pm

What exactly is the fail symptom? Reading between the lines, I'm guessing that Mplay launches pointing at the default directory structure rather than the one on your movie server?

Would it help to add in some debug statements so that you can see what's being executed?

The only difference I can think of off the top of my head is that you're running as root when you run user_1 from telnet. I don't know what permissions userkeys itself has when it calls user_1. You might want to check that you have permissions set on the batch files so that they all get executed?

Have you tried moving the Mplay.roku file onto the Roku to see if that helps?

Who is online

Users browsing this forum: No registered users and 3 guests