Your Digital Media Has Never Looked So Good

Topic Author
Posts: 1
Joined: Fri Oct 30, 2009 12:40 am
Location: London, UK

SetAVTransportURI fails to work

Mon Nov 02, 2009 9:49 am

I'm working on getting the SoundBridge working with a UPNP ControlPoint application that currently works successfully with a number of other UPNP MediaRenderers. The SetAVTransportURI call is failing though, and I can't see the reason why. This same call is working for Sonos and BridgeCo interfaces.

Here's a sample XML:

<?xml version="1.0" encoding="utf-8"?>
<s:Envelope xmlns:s="" s:encodingStyle="">
      <u:SetAVTransportURI xmlns:u="urn:schemas-upnp-org:service:AVTransport:1">
         <CurrentURIMetaData>&lt;DIDL-Lite xmlns:dc="" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"&gt;&lt;item id="1$14$744776839$2758061249"&gt;&lt;dc:title&gt;Come Together (The Beatles Cover)&lt;/dc:title&gt;&lt;dc:creator&gt;Unknown&lt;/dc:creator&gt;&lt;upnp:artist&gt;Prince&lt;/upnp:artist&gt;&lt;upnp:album&gt;Coachella&lt;/upnp:album&gt;&lt;upnp:genre&gt;Unknown&lt;/upnp:genre&gt;&lt;upnp:albumArtURI&gt;(null)&lt;/upnp:albumArtURI&gt;&lt;upnp:originalTrackNumber&gt;412506592&lt;/upnp:originalTrackNumber&gt;&lt;upnp:class&gt;object.item.audioItem.musicTrack&lt;/upnp:class&gt;&lt;/item&gt;&lt;/DIDL-Lite&gt;</CurrentURIMetaData>

The mp3 file does exist on the server, and the SoundBridge can play it through it's own interface.

I've tried removing the metadata, and still get the same result. The SoundBridge says that it cannot play the track and asks if I want to skip to the next track.

The server is Twonky 4.something.

Does anybody know of anything that I could try to get this working?

SongBook UPNP ControlPoint for Mac and iPhone
Posts: 1
Joined: Thu Jan 21, 2010 10:17 am
Location: Oakland, CA

Thu Jan 21, 2010 10:21 am

Jason did you ever figure this out?

Who is online

Users browsing this forum: No registered users and 3 guests