Your Digital Media Has Never Looked So Good

 
amphalon
Posts: 20
Joined: Sat Jan 21, 2006 6:58 am

Trouble installing

Thu Feb 16, 2006 1:36 pm

Hi,

I've just installed .Net 2.0 and have Windows XP Running SP2, also just installed Firmware 2.5.

iTunes running, Soundbridge playing. Saved the .exe fine from the .zip to the desktop.

When I double click on the "R" icon I get:

Application has generated an exception that could not be handled.
Process id=0xcf8 (3320), Thread id0xd08 (3336).

Can you give me any ideas how to get it working.

Sounds like a great programme though.

Tom
 
amphalon
Posts: 20
Joined: Sat Jan 21, 2006 6:58 am

Thu Feb 16, 2006 1:49 pm

Right, I was being stupid, now got it running, how do I find the Soundbridge address?

All three files are now in the RokuiTunesCounter folder.

Thanks

Tom
 
amphalon
Posts: 20
Joined: Sat Jan 21, 2006 6:58 am

Perseverence

Thu Feb 16, 2006 2:04 pm

next time I'll try harder. Working fine now, great little programme.

Cheers

Tom
 
Cragar
Posts: 38
Joined: Tue Oct 26, 2004 7:11 am

Thu Feb 23, 2006 4:52 pm

Works GREAT. Thanks for all the work
 
GaryGnu
Posts: 12
Joined: Wed Dec 28, 2005 5:47 pm

Wed Mar 15, 2006 9:59 am

Any update for version 2.3 yet?
 
YourMum
Topic Author
Posts: 215
Joined: Tue May 03, 2005 3:58 am
Location: Watford, UK
Contact:

Wed Mar 15, 2006 3:39 pm

Hi. I am currently working on a significant update, but this requires the RCP stuff that's currently in the beta firmware releases - hopefully Roku will pin down a formal release soon... If I could know that this is not likely to be for a month or so, then I could make a change to the older code to fix v2.3...

I know that I said I'd do a fix for v2.3, but then I realised that it would be better to code with the new firmware in mind... sorry about that. (Plus my 8 month old son has been siphoning off my sleep so that I've not had enough fully-awake time to code in the evenings!!)
YourMum
---
Have you tried the Roku / iTunes Track Counter?
 
YourMum
Topic Author
Posts: 215
Joined: Tue May 03, 2005 3:58 am
Location: Watford, UK
Contact:

Mon Mar 20, 2006 4:45 pm

Hey folks.

I am pleased to announce a new version of the Roku / iTunes Play Count Updater! It's now version 2.0.

Updates from version 1:
  • Option to auto-start the counter
  • Option to start minimized (to system tray)
  • Command-line parameter to choose the settings file to use (enables multi-SoundBridge scanning)
  • Support for SB Radio
  • Support for any language (previously only English)
  • Note that due to the use of RCP, this program requires the latest firmware on your SoundBridge (v2.5.xxx)

The zip file is available at http://www.foghornlimited.net/RokuTrackCounter.html

I know that there are several other programs that also perform play count updating. This program is designed to update the play count, and nothing else - call it SlimWare if you like. It is not supposed to compete with any other product that you can find in this forum!
YourMum

---

Have you tried the Roku / iTunes Track Counter?
 
Cragar
Posts: 38
Joined: Tue Oct 26, 2004 7:11 am

Sat Mar 25, 2006 7:33 am

Is there anyway to get the old version again I can't seem to get the new one to work.
 
YourMum
Topic Author
Posts: 215
Joined: Tue May 03, 2005 3:58 am
Location: Watford, UK
Contact:

Sat Mar 25, 2006 12:55 pm

Version 2.1 now released.

This fixes the problem of not actually updating the iTunes Play Count ;) oops!
YourMum

---

Have you tried the Roku / iTunes Track Counter?
 
Cragar
Posts: 38
Joined: Tue Oct 26, 2004 7:11 am

Mon Mar 27, 2006 8:24 am

Version 2.1 still a little sketchy fro me. Have to stop and start it alot and it will lose song info occasionally. Once I stop it and restart it it will work for a little while then POOf gone again.
 
YourMum
Topic Author
Posts: 215
Joined: Tue May 03, 2005 3:58 am
Location: Watford, UK
Contact:

Tue Apr 18, 2006 2:05 pm

Hey folks

I have just uploaded version 2.2 to my website. This version has the following features over and above previous versions:
1. Log activity to a trace file (see the settings details on the web page)
2. Better error handling around network connection. If the connection is lost (or appears to have been lost), then a new connection is made.

Cragar and HarryDymond: I hope this resolves the issues you have been having... even if it doesn't the trace file should be useful to track down the culprit.

As ever, please let me know if you experience problems and I'll see what I can do to fix/help.
YourMum

---

Have you tried the Roku / iTunes Track Counter?
 
magicmidas
Posts: 2
Joined: Fri Apr 28, 2006 7:11 am
Location: Netherlands
Contact:

Fri Apr 28, 2006 7:19 am

I downloaded the most recent version 2.2 and I am encountering the same problems as with the previous version. Not always the playcount is update. (stopping and restarting does sometimes the trick but not always)

Below you can find a abstract of the tracefile

4:16:17 PM GetElapsedTime: 0:05:23

4:16:17 PM Updating PlayCount...
4:16:17 PM Title: You Look So Fine / Artist: Garbage / Album: Version 2.0
4:16:17 PM Garbage collect and sleep for 1s
4:16:18 PM GetTransportState
4:16:18 PM GetStreamData ==> nothing there! Wait 200ms
4:16:18 PM
4:16:18 PM GetStreamData returned an empty string...
4:16:18 PM Discard existing TCP Connection and create a new one.
4:16:18 PM CreateTcpConnection - disconnecting first
4:16:18 PM CreateTcpConnection - attempting connection
4:16:20 PM GetStreamData ==> nothing there! Wait 200ms
4:16:20 PM Result is only 1 character: wait and read more...
4:16:20 PM Result is only 1 character: wait and read more...
4:16:20 PM Result is only 1 character: wait and read more...
4:16:21 PM roku: ready

4:16:21 PM CreateTcpConnection - created. Return value: True
4:16:21 PM GetTransportState
4:16:21 PM GetStreamData ==> nothing there! Wait 200ms
4:16:21 PM
4:16:21 PM Status: SoundBridge is doing something (but what?)...
4:16:21 PM Garbage collect and sleep for 1s
4:16:22 PM GetTransportState
4:16:22 PM GetStreamData ==> nothing there! Wait 200ms
4:16:22 PM
4:16:22 PM GetStreamData returned an empty string...
4:16:22 PM Discard existing TCP Connection and create a new one.
4:16:22 PM CreateTcpConnection - disconnecting first
4:16:22 PM CreateTcpConnection - attempting connection
4:16:22 PM GetStreamData ==> nothing there! Wait 200ms
4:16:22 PM roku: ready

4:16:22 PM CreateTcpConnection - created. Return value: True
4:16:22 PM GetTransportState
4:16:22 PM GetStreamData ==> nothing there! Wait 200ms
4:16:22 PM GetTransportState: Play

4:16:22 PM Status: SoundBridge is playing
4:16:22 PM GetCurrentSongInfo
4:16:22 PM GetStreamData ==> nothing there! Wait 200ms
4:16:23 PM GetCurrentSongInfo: id: 15143
GetCurrentSongInfo: trackLengthMS: 284525
GetCurrentSongInfo: year: 2005
GetCurrentSongInfo: trackNumber: 6
GetCurrentSongInfo: format: MP3
GetCurrentSongInfo: status: unsupported
GetCurrentSongInfo: title: And Then Patterns
GetCurrentSongInfo: artist: Four Tet
GetCurrentSongInfo: album: Everything Ecstatic
GetCurrentSongInfo: genre: Electronic
GetCurrentSongInfo: songFormat: mp3
GetCurrentSongInfo: formatDescription: MPEG audio file
GetCurrentSongInfo: resource[0] url: http://192.168.1.50:3689/databases/37/i ... =406230509
GetCurrentSongInfo: resource[0] format: MP3
GetCurrentSongInfo: resource[0] bitrate: 320
GetCurrentSongInfo: resource[0] sampleRate: 44100
GetCurrentSongInfo: resource[0] sizeBytes: 11771879
GetCurrentSongInfo: OK

Any clue?
 
HarryDymond
Posts: 247
Joined: Sat Oct 29, 2005 2:39 pm
Location: UK

Tue May 02, 2006 9:53 am

YourMum wrote:
I have just uploaded version 2.2 to my website.


Hi,

I've upgraded to version 2.2 and Roku Firmware 2.5 b10, and so far, the Roku counter is working much better :D However, I haven't been using it long enough to know if all the problems with staying connected to/synchronised with the SoundBridge are gone.

However, I did see again a problem which happened once before but didn't mention:

Let's say I'm currently playing track "A" on the SoundBridge, and in iTunes, "A" has a zero play count. Next on the playlist is track "B", which also has a play count of zero.

The RokuCounter says SoundBridge is playing "A", and the count in zero. When "A" is nearly finished playing, the RokuCounter counter shows "A" is playing, and increments the play count to 1. When the Roku moves on to track "B", the play count indicator in RokuCounter should return to 0, but it does not. Therefore, when "B" finishes, it is erroneously updated to a play count of 2.

This is a difficult one to reproduce. It seems to be random, but I've seen it happen a couple of times in the last 10 tracks.
 
YourMum
Topic Author
Posts: 215
Joined: Tue May 03, 2005 3:58 am
Location: Watford, UK
Contact:

Wed May 03, 2006 3:25 pm

magicmidas: It looks like RIC (as amphalon nicely christened the program) is having problems with the network... it's finding problems and re-creating the TCP connection, but keeps finding problems. Are you running wirelessly and have any other network issues (e.g. SoundBridge re-buffers lots)?

HarryDymond: I will have to investigate this issue - I can't say that I have noticed this, but I will see if I can reproduce it - or at least examine the code to figure out how/why this might be happening.
YourMum

---

Have you tried the Roku / iTunes Track Counter?
 
magicmidas
Posts: 2
Joined: Fri Apr 28, 2006 7:11 am
Location: Netherlands
Contact:

Buffering

Fri May 05, 2006 2:11 am

Hi YourMum,

This soundbridge (m1000) is indeed buffering a lot. The wireless signal is far from optimal at my bedroom (lots of noise) I will run the test with my other soundbridge (m500) in the livingroom and connect that one via ethernet cable (currently also via wireless)
Maybe i get rid of the wireless connection anyhow due to lack of wpa support.

Anyhow i keep you updated.

Who is online

Users browsing this forum: No registered users and 1 guest