Your Digital Media Has Never Looked So Good

Topic Author
Posts: 6
Joined: Sun Mar 23, 2008 3:41 pm

iTunes can't see Firefly using wireless

Fri Jul 04, 2008 10:02 am

I didn't have this problem until recently but need some advice.

I have 2 installations of Firefly:
One on Windows XP Desktop (svn 1359)
( I reverted back to this as the later version won't allow .wav files to be added)
The other is on a Linkstation Pro (NAS connected to the router) which I changed to Debian linux (Freelink firmware) and is mt-daapd svn-1696. I had to configure/install this manually following a HowTo.

I have iTunes on the XP desktop and also on a Mac powerbook G4.
Both iTunes are version 7.6.2 (9)

If I open iTunes on the desktop I can see both installations of Firefly in iTunes.
If I connect my powerbook via ethernet, I can again see these 2 versions of Firefly.
If I use a Homeplug (internet via electricity in home) where one plug is connected to my router via ethernet and the other has a wireless antenna, I can see Firefly in iTunes using wireless.

However if I connect via wireless to the router, I can't see either Firefly in iTunes on the powerbook. I have tried disabling firewire on both router and powerbook. I also enabled Upnp on the ZyZEL router and also enabled Multicast (IGMP v2 and tried v1). Still no sign of Firefly on my powerbook's iTunes.
Is there a bug or compatibility problem - or what could be causing the problem?
Any advice most welcome.

Posts: 623
Joined: Fri Dec 16, 2005 12:29 am
Location: Australia

Fri Jul 04, 2008 4:49 pm

Sounds like your router is still blocking the multicast packets even though you've told it not to.
Is there an AP isolation option?
2 x M2000's
Infrant ReadyNAS NV+ with Firefly svn-1676
NSLU2, 500GB Maxtor One Touch III, uNSLUng 6.8, Firefly svn-1696
music library in FLAC format
Topic Author
Posts: 6
Joined: Sun Mar 23, 2008 3:41 pm

Fri Jul 04, 2008 5:41 pm

Thanks for the quick reply. I had never heard of AP isolation or noticed any setting/option on the router configuration for it. There are settings allowing Wan to Wan, Wan to Lan etc. but disabling the firewire should have bypassed the need for changing such settings.

However, I tried reverting to an earlier version of the firmware. Had to reset the router to factory settings and reinsert details. Still no success with Firefly via wireless access!

So, I went to the local shop and bought a new (Belkin) router - not expensive. Firefly problem solved. I had enabled Upnp but didn't see any settings for multicast.

So now the old Router is indeed isolated even though it works fine for everything else.

Many thanks,

Who is online

Users browsing this forum: No registered users and 1 guest