Your Digital Media Has Never Looked So Good

 
rknopf
Topic Author
Posts: 4
Joined: Tue May 26, 2009 8:34 am
Location: Menlo Park, CA

Firefly server stops when scan finds 3000 songs

Mon Jun 01, 2009 10:03 pm

I am running the firefly version for Win downloaded from Roku's site until I can spend the time to get firefly running on my DNS-321 (includes new firmware which means backing up all the data and reloading it, yech).

It seems to be configured correctly and scans my library but when it gets to 3000 songs it stops scanning and the firefly server stops. When I start it up again there are no songs scanned. Tried this about 3 times and decided to go ask for help. Any idea what is going on?

Its not out of the question that the problem is in my DNS or my itunes library, since the DNS' itunes server is wedged too also in the scan process at 38%. iTunes 8 plays everything fine. Another factor might be that I recently re-ripped more than half of my library to Apple Lossless so I had deleted several thousand songs then added several thousand. Come to think of it, the low water mark for songs may have been around 3000....

Any ideas appreciated.

Roger
Roger
LP spinnin' fool
 
jjaf
Posts: 709
Joined: Thu Sep 18, 2008 5:49 am
Location: Epping Forest (bordering London), UK

Tue Jun 02, 2009 5:56 am

Hi Roger

Look at the log file file for clues as to where the scanning process is failing. Increase the debugging level to 9 for maximum information.

One known problem that causes scanning to fail is the presence of non ASCII characters in file names/tags. Search this topic for more information.

Also check that its not a lack of disk space causing the problem.
 
rknopf
Topic Author
Posts: 4
Joined: Tue May 26, 2009 8:34 am
Location: Menlo Park, CA

Tue Jun 02, 2009 8:08 am

Thanks. I had turned debug up to 2 and ran out of time, will try it again at 9.

Regarding the non-ascii character, I saw that but not having Linux am perplexed about how to find that needle in the haystack of my nearly 8000 songs worth of tags. Any thoughts on how to do that on Windows?

Roger
Roger

LP spinnin' fool
 
rknopf
Topic Author
Posts: 4
Joined: Tue May 26, 2009 8:34 am
Location: Menlo Park, CA

Tue Jun 02, 2009 8:27 am

Progress! After turning up debug to 11 (thanks Nigel!) discovered that it was always quitting when it hit a track entitled [Silence].m4a - one of those embedded silent tracks that delay the last song for a while. It complained that it was missing a bit rate atom. I deleted those tracks and behold it is scanning past that! Now going to turn debug down again so I don't fill my disk with log files!

Thanks!

Roger
Roger

LP spinnin' fool

Who is online

Users browsing this forum: No registered users and 2 guests