Your Digital Media Has Never Looked So Good

 
Ted Harper
Topic Author
Posts: 154
Joined: Fri Mar 24, 2006 1:39 pm
Location: Sydney, Australia
Contact:

BUG: Foreign characters in album titles

Mon May 01, 2006 5:09 pm

NB: I am posting this in here (rather than opening a ticket in the mt-daapd bugtracker) because I am not sure whether the problem is with the Firefly server software or the new RSP protocol.

If an album name (and maybe a track and artist name too) contains a foreign character - eg the e-acute as the final character of Dire Straits' "Communique" album, it is displayed incorrectly on the Soundbridge (M1001, using 2.5B10 firmware) when using Firefly. It was correct previously using Windows Media Connect 2.0.


ted.h.
 
fetto
Posts: 2
Joined: Tue May 02, 2006 2:43 pm

Tue May 02, 2006 2:50 pm

I have the same problem.

Pinnacle Soundbridge with the latest firefly nighlty build (Firefly Media Server (svn-1004)).

For instance all songs with swedish characters (åäö) in the name doesn't show up at all in my soundbridge. They do however show up in mt-daapd's experimental playlist (the web interface).

I also has an album named "100% Barn, Volym 1" which my soundbridge tries to show as "100arn, Volym 1" with no songs at all in it...

/Patrik
 
fetto
Posts: 2
Joined: Tue May 02, 2006 2:43 pm

Tue May 02, 2006 2:57 pm

Found a bug report for my problem, sorry for the spam.

http://www.rokulabs.com/forums/posting. ... te&p=46109

/Patrik
 
rpedde
Posts: 1015
Joined: Fri Sep 10, 2004 6:25 pm

various utf-8 problems

Tue May 02, 2006 7:52 pm

I've got what I need to reproduce this, I'm working on it.

-- Ron
 
rpedde
Posts: 1015
Joined: Fri Sep 10, 2004 6:25 pm

international characters

Tue May 02, 2006 10:15 pm

problems with international characters in wma files has been fixed in version control, and the next release will contain the fix.

-- Ron
 
rpedde
Posts: 1015
Joined: Fri Sep 10, 2004 6:25 pm

Re: international characters

Sat May 06, 2006 1:15 am

rpedde wrote:
problems with international characters in wma files has been fixed in version control, and the next release will contain the fix.



New version posted at http://nightlies.mt-daapd.org/, with this fix in it. You'll have to delete your songs.db to force a rescan of the .wma files, but I'd be interested in hearing any feedback.

-- Ron
 
Ted Harper
Topic Author
Posts: 154
Joined: Fri Mar 24, 2006 1:39 pm
Location: Sydney, Australia
Contact:

Re: international characters

Sat May 06, 2006 2:33 am

rpedde wrote:
rpedde wrote:
problems with international characters in wma files has been fixed in version control, and the next release will contain the fix.



New version posted at http://nightlies.mt-daapd.org/, with this fix in it. You'll have to delete your songs.db to force a rescan of the .wma files, but I'd be interested in hearing any feedback.

-- Ron


The track I struck the problem with and posted above is definitely shown perfectly now with the svn-1018 nightly build. Thanks.

ted.h.

Who is online

Users browsing this forum: No registered users and 2 guests