Your Digital Media Has Never Looked So Good

 
Vortech
Topic Author
Posts: 28
Joined: Sun Oct 23, 2005 6:56 am
Location: Denmark

Firefly have stopped working apparently

Fri Jul 07, 2006 6:11 am

Hey guys,

Hope someone can help me get out of this mess:

I have a NSLU2 that's running the Firefly server.

Yesterday I upgraded to svn-1281. After that, it just doesn't start anymore.

I remember that I by accident typed "ipkg update mt-daapd_svn-1281-1_armeb.ipk" instead of "ipkg install mt-daapd_svn-1281-1_armeb.ipk". Don't know if that has done anything?
Tried to reinstall it by just doing a ipkg install again, and letting it overwrite my config as well.

Anyone know what can be done?

Thanks,
Frank
 
Vortech
Topic Author
Posts: 28
Joined: Sun Oct 23, 2005 6:56 am
Location: Denmark

Sat Jul 08, 2006 12:38 am

What I'm trying to get help with, is to delete my existing installation and then doing a new and clean install.
As I'm no Linux novice/pro/expert I have almost no clue whatsoever. ;)

The last resort is to unslung it again, but that's not a fun process at all!

/Frank
 
Dave.B
Posts: 42
Joined: Fri Dec 30, 2005 6:53 am
Location: ...a dugout that my dad built...
Contact:

Sat Jul 08, 2006 4:09 am

Frank,
I've had LOADS of trouble with 1281 on my slug. It runs for anything up to an hour and then crashes. I've captured a -d9 log and Ron is looking at it.

I downgraded to 1249, and found myself in a similar situation to yourself, Firelfy just wouldn't start. Examining the log showed an incompatible database version. To solve this, you need to delete songs.db:

cd /opt/var/mt-daapd
rm songs.db
/opt/etc/init.d/S60mt-daapd

this will delete the database and restart the server, but it might take some time (up to 2 hours in my case) to recreate the database, so don't give up on it.

FWIW, I've given up on anything after 1236 as none of them seem to run reliably. I've just downgraded to 1236 this morning and I'm keeping my fingers firmly crossed...
 
Dave.B
Posts: 42
Joined: Fri Dec 30, 2005 6:53 am
Location: ...a dugout that my dad built...
Contact:

Sat Jul 08, 2006 4:12 am

I just re-read your 2nd post.
To delete your existing installation and reinstall a different one:

killall -9 mt-daapd
ipkg remove mt-daapd
ipkg install mt-daapd...........

Take heart in the fact that I don't consider myself linux-literate in any way whatsoever, but I've learnt an awful lot just from this little episode, I'm sure you will too.
HTH
 
Vortech
Topic Author
Posts: 28
Joined: Sun Oct 23, 2005 6:56 am
Location: Denmark

Sat Jul 08, 2006 2:06 pm

Dave,

Thanks a lot for the replies and the help you gave. It now works perfectly again!

I actually did everything, you mentioned:
Deleted the songs.db
Uninstalled mt-daapd
Reinstalled it
Installed svn-1274
Edited the conf file and let it build its database for aprox 10 mins.

Then it hit me.. I wasn't aware that it needs to do something after running S60mt-daapd. I usually reboot the NSLU2 a few seconds after.
My guess is that the problem was with the songs.db and it would have been enough just to delete it, and have a go.

Now I'm running with svn-1281 for 5 hours without a glitch.
Hope you get your problem sorted, and thanks again. :)

Frank

Who is online

Users browsing this forum: No registered users and 2 guests