Your Digital Media Has Never Looked So Good

 
petec
Topic Author
Posts: 4
Joined: Tue May 12, 2009 6:49 am

Photobridge Dead?

Fri Feb 12, 2010 1:22 pm

About a year ago or so replaced the PS in my Photobridge with a Morex. All has been well until this morning (I got addicted to this box). Memory card started to flash and no power light came on. Opened it up and noticed about 4 leaking caps on the Morex power supply. Replaced PS with similiar. Booted up and LED on PS shows that PS is working however no LED's on the Roku. Held the power button down a bit but it never came back. Any suggestions?
 
Burkhardi
Posts: 1943
Joined: Tue Jun 07, 2005 11:06 am
Location: Austin, Texas ...Y'all

Re: Photobridge Dead?

Fri Feb 12, 2010 1:33 pm

petec wrote:
About a year ago or so replaced the PS in my Photobridge with a Morex. All has been well until this morning (I got addicted to this box). Memory card started to flash and no power light came on. Opened it up and noticed about 4 leaking caps on the Morex power supply. Replaced PS with similiar. Booted up and LED on PS shows that PS is working however no LED's on the Roku. Held the power button down a bit but it never came back. Any suggestions?


Yes, put your finger in U12 on the main board (it's near (below) the plug that the harness comes in from the power supply on) and see if it almost burns your finger. If it does not, then there is your issue and you can try it yourself (you need a special SMD tweezer iron (so you can get the IC off the PCB with out tearing the land off the PCB or burning the PCB up) or what most people do it send it to Pyramid-Audio or myself. There is a thread in the PhotoBridge forum about it.
http://forums.roku.com/viewtopic.php?t= ... &start=277

Let me know if you have any questions, Matt
Roku3 and Roku HD1000 [Rev B] on a Samsung HLP5674W DLP in the living room; a Roku2 and two Roku XS and a few SoundBridges.Win7; Kubuntu and XP via RT-N66U, E2000 and a switch or two. I own stock in Roku, it's just all in the form of hardware.Viva la Roku
 
petec
Topic Author
Posts: 4
Joined: Tue May 12, 2009 6:49 am

Fri Feb 12, 2010 2:01 pm

Hello Matt,

Yes, just checked the new PS output power and all is fine. U12 is cold though.

Found U12 (LP3965EMP-ADJ SOT223-5) at digikey but I am not really good at smd soldering.

How much would you charge to replace U12?

-Pete
 
Burkhardi
Posts: 1943
Joined: Tue Jun 07, 2005 11:06 am
Location: Austin, Texas ...Y'all

Sat Feb 13, 2010 8:54 pm

petec wrote:
Hello Matt,

Yes, just checked the new PS output power and all is fine. U12 is cold though.

Found U12 (LP3965EMP-ADJ SOT223-5) at digikey but I am not really good at smd soldering.

How much would you charge to replace U12?

-Pete


Check your PM...
Roku3 and Roku HD1000 [Rev B] on a Samsung HLP5674W DLP in the living room; a Roku2 and two Roku XS and a few SoundBridges.Win7; Kubuntu and XP via RT-N66U, E2000 and a switch or two. I own stock in Roku, it's just all in the form of hardware.Viva la Roku

Who is online

Users browsing this forum: No registered users and 2 guests