Your Digital Media Has Never Looked So Good

 
ibra0078
Topic Author
Posts: 4
Joined: Wed Sep 13, 2017 7:27 am

insignia smart tv with roku help disable network ping

Wed Sep 13, 2017 8:06 am

I have a smart tv with a built in Roku box, long story short I have setup and configured a raspberry pi as a plex server and as a Access Point with no internet. I can connect to the pi access point no issue and I am able to open my plex client on my phone or tablet and connect to the plex server. However the issue is when I try connect the roku to the wireless AP, the roku box does 3 checks to validate the connection. The last check it checks for internet connectivity by doing a network ping I assume to a roku server somewhere, however this step fails as my Wireless AP has no internet connection its just local access and I get a 009 ruko error. I went into one of the hidden menus and disabled network ping, rebooted the tv and I try to reconnect to the wireless AP but it still fails at the last step when it checks network connectivity.

I was hoping if anybody had the same issue and what did they do to resolve the problem. I assumed disabling the network pings would work but it didnt.
 
jagreenough
Posts: 39
Joined: Tue Apr 04, 2017 9:03 am

Re: insignia smart tv with roku help disable network ping

Wed Sep 13, 2017 1:19 pm

i'm guessing your pi has a dhcp server active so that the roku tv will get an ip address, for plex to work on the LAN?
 
ibra0078
Topic Author
Posts: 4
Joined: Wed Sep 13, 2017 7:27 am

Re: insignia smart tv with roku help disable network ping

Wed Sep 13, 2017 1:24 pm

Yes I'm running a DHCP server, it connects fine if I use my tablet or phone by for some reason even though I turn off the ping request roku fails at the last step in trying to connect to the wireless.
 
jagreenough
Posts: 39
Joined: Tue Apr 04, 2017 9:03 am

Re: insignia smart tv with roku help disable network ping

Wed Sep 13, 2017 2:13 pm

i'm not sure what the network ping secret menu choice really does.  I think your test might indicate it's still doing something bad if it can't reach the internet.

are you sure you don't have any special characters in your wifi password (only numbers and letters)?
 
ibra0078
Topic Author
Posts: 4
Joined: Wed Sep 13, 2017 7:27 am

Re: insignia smart tv with roku help disable network ping

Wed Sep 13, 2017 2:21 pm

It's not only numbers and letters, I do have a special character. It doesn't support special character?
 
atc98092
Posts: 1645
Joined: Tue Dec 31, 2013 5:09 pm

Re: insignia smart tv with roku help disable network ping

Thu Sep 14, 2017 8:26 am

Yeah, for some reason Roku has issues with special characters. 
Dan
Roku Stick (2016), 4 and Ultra, Insignia Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network. Samsung JU7100 4K TV, Yamaha RX-V679, 40+Mbps DSL from CenturyLink
 
ibra0078
Topic Author
Posts: 4
Joined: Wed Sep 13, 2017 7:27 am

Re: insignia smart tv with roku help disable network ping

Thu Sep 14, 2017 4:32 pm

Well I had no password on my wireless when I was setting up my raspberry Pi and that still didn't work and then added a password but had a special character. I try removing the special character and see if that works. I had a friend try the same thing on his Roku box, he setup a spare router not connected to the wan so no internet and Roku did fail on the last step when trying to connect to the Internet. Even though he turned off network ping, it seems Roku must have a valid internet in order to connect to your wireless which if you ask me is kind of strange they would do that.

Who is online

Users browsing this forum: mikebdoss and 25 guests