Your Digital Media Has Never Looked So Good

 
brottman
Topic Author
Posts: 1
Joined: Tue Jan 16, 2018 7:36 pm

Audio sync issues on Roku TV (TCL 55P607)

Tue Jan 16, 2018 7:51 pm

I was so exited to get my brand new Roku powered 55" 4K TV. Picked up a brand new 5.1 sound system to match. I dreamed of pure Roku+Plex bliss, until I played my first movie. I'm having audio sync issues in every movie, and from what I can gather from research, the audio sync bug dates back more than a year, and Roku has yet to fix it. I know it is a Roku problem, because the same thing happens in Emby as well. It seems to also have been well documented here, and here, here, here, and here.

I have heard that switching Roku itself to Stereo audio fixes the issue. I think more pressure needs to be put on Roku to fix this, because it seems to me like only being able to handle a stereo audio track correctly would be a major issue for flagship Roku products. Is this simply a bug that Roku is unable to fix? Do I need to go and buy a competitor product as a band-aid to my otherwise beautiful Roku TV?

Has anyone found any solutions that do not involve stereo mode, or some weird button combination while watching movies? I'm okay re-encoding the audio tracks in my movie files if that's what it takes. Does anyone know of any Surround Sound 5.1 audio formats that do not have the issue inside Plex/Roku?
 
apodtele
Posts: 63
Joined: Thu Jul 27, 2017 6:30 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Wed Jan 17, 2018 10:12 am

Press Home on your remote control, scroll down to Settings and select Audio > HDMI (or HDMI and S/PDIF on Roku players with an optical connector). Instead of “Auto detect”, select the option that matches the capabilities of your TV, AVR or sound bar.

Try to scale back from "Auto detect" or "Dolby D+, DTS" to something a bit lower but still surround.
 
blade_005
Posts: 153
Joined: Mon Dec 11, 2017 10:47 am
Location: USA

Re: Audio sync issues on Roku TV (TCL 55P607)

Fri Jan 26, 2018 8:28 am

brottman wrote:
I was so exited to get my brand new Roku powered 55" 4K TV. Picked up a brand new 5.1 sound system to match. I dreamed of pure Roku+Plex bliss, until I played my first movie. I'm having audio sync issues in every movie, and from what I can gather from research, the audio sync bug dates back more than a year, and Roku has yet to fix it. I know it is a Roku problem, because the same thing happens in Emby as well. It seems to also have been well documented here, and here, here, here, and here.

I have heard that switching Roku itself to Stereo audio fixes the issue. I think more pressure needs to be put on Roku to fix this, because it seems to me like only being able to handle a stereo audio track correctly would be a major issue for flagship Roku products. Is this simply a bug that Roku is unable to fix? Do I need to go and buy a competitor product as a band-aid to my otherwise beautiful Roku TV?

Has anyone found any solutions that do not involve stereo mode, or some weird button combination while watching movies? I'm okay re-encoding the audio tracks in my movie files if that's what it takes. Does anyone know of any Surround Sound 5.1 audio formats that do not have the issue inside Plex/Roku?

I have a TCL 55P605, Vizio 5.1 Soundbar connected via HDMI-ARC and use Emby to access personal media library and Recorded TV using Emby DVR functionality. 

All was working well while on Roku OS 7.7 with no sync issues across any streaming apps or access to any of my Emby library. The upgrade to Roku OS 8.0 and build 4142 was when I started to see sync issues intermittently with streaming apps and OTA channels and with the Recorded TV (.TS files) if I had Audio set to AUTO DOLBY DIGITAL, DTS. I found any of my Emby media that DIRECT PLAYED did not have any sync issues, but Recorded TV with AC3 audio has to transcode the audio for Emby Roku app and it was badly out of sync, especially if you used FFWD to move through commercial breaks. The only 'fix' while watching Recorded TV with Emby was to set AUDIO to STEREO and the sync issues were not present. Not ideal, but a manageable work around.

Yesterday my TCL Roku set updraded to Roku OS 8.0.0 build 4156-30. An initial test of my Recorded TV files through Emby Roku app exhibit a much better synchronization of audio with DOLBY D, DTS setting. OTA channels can still be a little off, but that varies from channel to channel and I am not much of a Live TV viewer and would just switch audio to STEREO in that case.

If your TCL set has upgraded to 8.0.0 build 4156-30, you might want to give your Plex and Emby libraries a run through again and see if audio sync issues are better with DOLBY D, DTS setting.
TCL Roku 55P605 | VIZIO SmartCast SB3651‑E6 Soundbar
TCL Roku 32S301
 
johnniedoo
Posts: 2
Joined: Thu Jul 19, 2018 4:20 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Thu Jul 19, 2018 4:39 am

I just bought a TCL Roku 49" 5 series tv, which is fine but the audio in the built in speakers is like an echo chamber with my Onkyo SX TR 608 AVR. I use the HDMI cable. I dont know whether this is an issue with ROKU .the TCL or both. I can not leave the built in speakers on, not that they are so great, when i play though the receiver. no auto off options either nor way to connect the remote audio up/down without un muting the tv speakers. it claims to be CEC but only auto off it seems nothing much else no auto on. i saw a thread but it was locked and no real fix for my issue. i suppose it is self defined. just turn off the built in speakers. but i want to play them all at once,maybe.  I have a 7.1 speaker set up and the amp is capable of DTS master and Dolby Digital options up but not including atmos and built in Audyssey eq for audio coloring . i also notice the lip sync in some movies being off regardless of built in speakers or in the onkyo ,though i have that option to scale the audio by ms or 100ms i think which is not exact. no huge deal but can be annoying
thanks
John 
TCL ROKU 49" 4K TV. TCL 49S517 but bought june 2018 as advertised 2018model. first TCL brand tv
 
neelskit
Posts: 1
Joined: Sun Jul 29, 2018 8:55 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Sun Jul 29, 2018 9:04 am

I'm having the same issue with a Sharp LC-55LBU591U 4k Roku TV and an Onkyo TX-NR808 Receiver. It doesn't matter if I use SPIDF or ARC, if the TV is set to Dolby D or higher, the audio is significantly delayed to the receiver. If I set the TV to PCM, the audio is in time. I can even hear the delay when switching thru menus (tick noise) in the TV if I have the TV speakers and Receiver both on.

The TV has Software version 8.1.0 build 4139-38 installed.
 
WayneM
Posts: 1
Joined: Wed Aug 01, 2018 9:52 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Wed Aug 01, 2018 9:58 am

Having the same problem on a brand new 55R617, Roku TV version 8.1.2 - build 4024-30. I've been communicating with TCL support but I don't expect they will be able to fix anything. As it currently stands, I consider the TV defective.
 
danep
Posts: 7
Joined: Sun Sep 01, 2013 7:08 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Thu Aug 02, 2018 8:03 pm

I have a TCL 49S405--technically a different model, but probably running the same firmware. I have the same problem.

If I play any content on the TV in Dolby, DTS, or any other format other than PCM-Stereo, I get a noticable delay in the audio of 100-500ms. This occurs regardless of whether I'm sending audio over optical Toslink / SPDIF or HDMI ARC. It happens with at least three separate receivers (including a Vizio 5.1 soundbar and Pioneer receiver), so the TV definitely seems to be part of the problem.

This problem seems so pervasive, I just don't understand how this ever works for people? It seems like there's an inherent delay in decoding Dolby / DTS bitstreams and if the TV doesn't adjust by also delaying the video, you will always have lip sync issues.
 
blade_005
Posts: 153
Joined: Mon Dec 11, 2017 10:47 am
Location: USA

Re: Audio sync issues on Roku TV (TCL 55P607)

Fri Aug 03, 2018 8:01 am

danep wrote:
I have a TCL 49S405--technically a different model, but probably running the same firmware. I have the same problem.

If I play any content on the TV in Dolby, DTS, or any other format other than PCM-Stereo, I get a noticable delay in the audio of 100-500ms. This occurs regardless of whether I'm sending audio over optical Toslink / SPDIF or HDMI ARC. It happens with at least three separate receivers (including a Vizio 5.1 soundbar and Pioneer receiver), so the TV definitely seems to be part of the problem.

This problem seems so pervasive, I just don't understand how this ever works for people? It seems like there's an inherent delay in decoding Dolby / DTS bitstreams and if the TV doesn't adjust by also delaying the video, you will always have lip sync issues.

I have a 55P607 and Vizio 5.1 soundbar. I occasionally get audio drift from 5.1 audio in streaming apps, but it is normally when I am jumping forward and backward in a stream to find a certain timestamp. Normally, just jumping out of streaming app to another HDMI input and then back to streaming app seams to snap the framerate of video with audio back in synch. I do record OTA video with 5.1 audio and trying to view that in Roku app that supports it is always out of synch with audio set to 5.1 Dolby. I have just learned to drop it to stereo or jump to my HTPC on HDMI source and watch via Windows version of app which is flawless.

I can't say definitely that this works with my soundbar, but I found that turning off any sort of post-processing of audio may help a little with drift. On my Vizio soundbar I eventually turned off TRU VOLUME and set audio to DIRECT instead of the default MOVIE. Might be a placebo effect, but it does seem to occur much less often after adjusting these settings.
TCL Roku 55P605 | VIZIO SmartCast SB3651‑E6 Soundbar
TCL Roku 32S301
 
danep
Posts: 7
Joined: Sun Sep 01, 2013 7:08 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Fri Aug 03, 2018 8:21 am

If you want to rule out placebo effect, an easy way to test for audio delay is to simply enable TV speakers and external speakers at the same time. The delay becomes painfully obvious in the form of an echo.
 
blade_005
Posts: 153
Joined: Mon Dec 11, 2017 10:47 am
Location: USA

Re: Audio sync issues on Roku TV (TCL 55P607)

Fri Aug 03, 2018 8:45 am

danep wrote:
If you want to rule out placebo effect, an easy way to test for audio delay is to simply enable TV speakers and external speakers at the same time. The delay becomes painfully obvious in the form of an echo.

True. But TV speakers are Stereo and soundbar is 5.1. Soundbar is connected via HDMI-ARC. I think when you do that and enable CEC in latest firmware that internal TV speakers are disabled by default.
TCL Roku 55P605 | VIZIO SmartCast SB3651‑E6 Soundbar
TCL Roku 32S301
 
somedatapacket
Posts: 10
Joined: Fri May 11, 2018 7:56 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Sun Aug 05, 2018 3:25 pm

Same exact issue with TCL 55S515.
 
vanylapep
Posts: 4
Joined: Sun Aug 05, 2018 6:48 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Mon Aug 06, 2018 8:04 am

I have Roku Ultra and using the optical out, there is a delay with the audio. Any way to fix this?
 
tikilive
Posts: 2
Joined: Tue Oct 18, 2016 8:29 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Mon Aug 06, 2018 1:40 pm

We are having this as well.

Only Roku devices have the problem and a workaround that can be implemented is setting the Roku Device to "Auto-Detect" on Settings > Video Display.

This is a major problem on Roku for Adaptive streams, we cannot recreate it on single bitrates.

Any help or a solution from Roku would be greatly appreciated, this appears to be a fundamental issue in their playback of Adaptive Streams.
 
john262
Posts: 141
Joined: Fri Feb 14, 2014 10:56 am

Re: Audio sync issues on Roku TV (TCL 55P607)

Mon Aug 06, 2018 9:50 pm

I am having sync problems with my Roku Premier+ as well. This is a very common problem with streaming, and I also have sync issues with my Nvidia Shield. I have the problem whether I use my TV's built in speakers or my Onkyo amp. And the kicker is sometimes I have similar issues with some OTA channels. Back to my Roku, I have audio sync issues with CBSN, one of my favorite streaming channels. But I don't have any issues with Netflix. I also have sync issues with some of the ad-supported movie apps.
 
Fweezal
Posts: 1
Joined: Tue Oct 24, 2017 12:54 pm

Re: Audio sync issues on Roku TV (TCL 55P607)

Wed Aug 08, 2018 8:43 am

Well, it's pretty obvious there's a lot of people having this problem.  "Me too" is going to do nothing to alleviate the issue.  It seems Roku doesn't care or is oblivious to this issue... as is so common with corporations these days.  "We have your money, now go suck wind.", seems the prevailing attitude.  I would LOVE to be proven wrong.

Who is online

Users browsing this forum: No registered users and 20 guests