Your Digital Media Has Never Looked So Good

 
mike1597
Posts: 75
Joined: Fri Oct 28, 2016 9:29 pm

Re: Unauthorized HDCP Content

Mon Apr 16, 2018 6:21 pm

I have had this issue for more than a year.  I have 2 Sony 4k TVs, one has the Roku Ultra, the other has the stick+ and intermittently I get the purple screen on both.  Usually it happens on Hulu or DirecTV Now.  I don't use YouTube.  It seems random and happens about every 2 or 3 days.  A reboot fixes it but it is annoying.  I also use FireTV and it doesn't have this issue.  This does seem to be a Roku firmware issue related to Sony 4k TVs.
 
joemysterio
Posts: 5
Joined: Mon Apr 23, 2018 11:29 pm

Re: Unauthorized HDCP Content

Sat Apr 28, 2018 6:05 pm

donb wrote:
I fixed it by using 4K HDR 60Hz TV.

Streaming Stick+ 3810 kept picking 4K 30Hz TV display mode which kept getting the HDCP error.  I then tried 4K HDR 30Hz TV because it passed all Roku display checks but it kept getting the HDCP error as well.  I then tried 4K HDR 60Hz TV even though it didn't pass the last display check but I told it to Force it. 

Seems like Roku is having a hard time figuring out what display modes are compatible with my Sony KD-50X690E.  

Hello @donb
I have the same TV. Have you tried using the roku on HDMI 1? Mine will not work at all on HDMI1. I get the HDCP error on everything and sound is non-existent at all. I tried so many times all the troubleshooting steps of unplugging, powering off, factory resetting, using different cables, nothing works. Roku support is absolutely ATROCIOUS they they spew the same crap. One even told me to just go buy a new TV. Seriously? Anyway, since I got mine through Amazon, they accepted my return and I got another to try. It worked right away and I had sound the whole way through the set up until it auto updated then it went dead again.
I think the current update for the Roku Stick+ is screwing things up. I think that despite whatever non-4k setting you have it at, the Roku still sends out HDCP 2.2 signals so my HDMI 1, which doesn't support 2.2, just stops working properly. It's SO freaking frustrating.
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Sat Apr 28, 2018 6:25 pm

Yeah HDMI 1 doesn't work because it doesn't support HDCP. I figured that out quick enough. Then read the owners manual which confirmed it.

Well ever since I changed the Streaming Stick+ Display mode from Auto detect to 4K HDR 60hz TV, it's been working fine. Maybe I should knock on wood though.
 
gandalf1369
Posts: 29
Joined: Sun Aug 20, 2017 4:29 am

Re: Unauthorized HDCP Content

Sun Apr 29, 2018 5:04 am

I have also had some luck in avoiding the HDCP purple screen.  As I had mentioned previously I currently have my Stick+ connected to my Sony TV with the free small HDMI extension cable that I got from Roku.  I have also stopped using the YouTube channel on the Stick+ and use the native YouTube app on the television instead (based on the post from donb about the changing resolutions while streaming from YouTube on the Roku).

Its has been almost 1 month since I got the HDCP purple screen, whereas before the above changes I would be getting it approximately 2-3 times per week.  I can't say if what I have done with YouTube and the HDMI cable are the reasons for not getting the purple screen but I plan on just leaving it as is for now.  Maybe in the future I'll experiment with just one and/or the other and see what happens . . .
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Sun Apr 29, 2018 11:15 am

Yeah I was using the YouTube app on the TV just fine but switching between the TV and Roku via multiple remotes wasn't in the cards for me. I switch between apps quite often. Also, the YouTube app on the TV is an old version and Sony informed me that I could not update it. That was a deal breaker for me.
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Wed May 30, 2018 6:22 pm

Well sorry to say but the error has returned out of the blue.  It was working just fine ever since my last post. :(  I haven't tried it on YouTube but its giving me the error with the Roku Media Player.  I have a lot of video content in MP4 format that I watch.  I have had no problems with these same videos until now.  I was watching them without incident and now this HDCP error is back to haunt me. :(
 
gandalf1369
Posts: 29
Joined: Sun Aug 20, 2017 4:29 am

Re: Unauthorized HDCP Content

Thu May 31, 2018 4:44 am

Sorry to hear that your problem is back.  Luckily (at least so far) I have not had the purple screen HDCP error for more than a month and a half now. In my last post I mentioned that I had done two things different : 1. not use the YouTube app on the Stick+ and 2. used the free HDMI extender from Roku to plug the Stick+ into the TV.  As an experiment I eliminated the HDMI extender from the equation about 2 weeks ago and just attached the Stick+ the way it was designed - directly into the TV.  I still avoid using the YouTube app on the Roku.  So far - HDCP purple screen free!!

I still can't say with certainty that the YouTube app was causing my problem but I'm pretty sure that it was at least part of the problem.  Hopefully, I'll continue to not see the flower purple screen!!
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Thu May 31, 2018 10:39 am

YouTube is working but not Roku Media Player.  But the next day, it was fine.  I think there might be some heat related issue going on.  Yeah I got that free extender from Roku.  Its just a very very short HDMI cable.  I was watching TV all day and the problem did not appear until late into the night.  I am really starting to think its heat related somehow.
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Fri Jun 01, 2018 2:24 pm

Other information:

Model 3810X Roku Streaming Stick+
Serial number YH0097428140
Software version 8.0.1 build 4090-50
Uptime 23 hours 36 minutes

TV Model Sony KD50x690e
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Mon Jun 11, 2018 7:48 pm

I mounted heatsinks to my Streaming Stick+.  Let's see if that helps keep the temperature down. :)

Image
 
heligo
Posts: 7
Joined: Sat May 26, 2018 1:52 am

Re: Unauthorized HDCP Content

Mon Jun 18, 2018 12:57 pm

Got the same problem with my Streaming Stick. It's worked beautifully with my LG OLED55B7V since i bought it months ago.

It changed when i turned on "HDMI ULTRA HD Deep Colour" on my TV and switched to "4K HDR 60Hz TV" on my Roku. Now this HDCP message pops up multiple times a day.

I've reverted my settings so we'll see if that resolves it but surely this has to be a Roku issue. If this continues it will simply become unusable and we'll have to go back to Apple TV or something.
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Mon Jun 18, 2018 1:53 pm

Yeah I too had no problem at all with my old TV. It's only when I bought a new 4K TV this all started. I was running 720 and 1080 on my old TV though.

Maybe you can try all of the Roku display modes until you hit the one that works. That's what I had to end up eventually doing.
 
heligo
Posts: 7
Joined: Sat May 26, 2018 1:52 am

Re: Unauthorized HDCP Content

Mon Jun 18, 2018 11:17 pm

donb wrote:
Yeah I too had no problem at all with my old TV. It's only when I bought a new 4K TV this all started. I was running 720 and 1080 on my old TV though.


Thanks. Yeah in the Roku display settings it actually says that the 4K display options require HDCP, where as the 720 & 1080 options do not.

I'm convinced this is a Roku issue.
 
donb
Topic Author
Posts: 103
Joined: Fri Mar 28, 2014 11:28 am

Re: Unauthorized HDCP Content

Tue Jun 19, 2018 12:10 am

Yeah its definitely isolated to the Roku but I fixed mine by manually selecting the display mode.  Others had to use that free HDMI extension cable from Roku.
 
heligo
Posts: 7
Joined: Sat May 26, 2018 1:52 am

Re: Unauthorized HDCP Content

Tue Jun 19, 2018 12:23 am

It's a shame because for the first time I have equipment that is capable of running maxed out (4K HDR 60fps) but i have to downgrade to 30fps. Roku need to acknowledge this.

PS. I'm actually a little ashamed at myself for making that complaint :)

Who is online

Users browsing this forum: No registered users and 39 guests