Your Digital Media Has Never Looked So Good

 
User avatar
atc98092
Posts: 3870
Joined: Tue Dec 31, 2013 5:09 pm
Location: Auburn, WA

Re: Roku Ultra - wireless network issues - no Interference menu option

Thu Feb 28, 2019 2:07 pm

Basketbuild, you have a reasonable suggestion for the dual-band Roku players. Connect the player to the network with the 5GHz radio and use the 2.4 GHz radio for the remote. I don't know if the remotes are dual band, so the opposite might not be possible. And of course the single band Roku players can't use that option. It's too bad they didn't stick with Bluetooth for the remote like they used with the 2 XS, but it was probably a cost decision. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
 
basketbuild
Topic Author
Posts: 17
Joined: Fri Feb 22, 2019 4:59 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Thu Feb 28, 2019 4:15 pm

atc98092 wrote:
Basketbuild, you have a reasonable suggestion for the dual-band Roku players. Connect the player to the network with the 5GHz radio and use the 2.4 GHz radio for the remote. I don't know if the remotes are dual band, so the opposite might not be possible. And of course the single band Roku players can't use that option. It's too bad they didn't stick with Bluetooth for the remote like they used with the 2 XS, but it was probably a cost decision. 

Or, they can continue to use 5GHz. Just don't use the same channel as the highest strength 5GHz (my Wi-Fi router!) in the area!
 
renojim
** Valued Community Member **
Posts: 3490
Joined: Mon Feb 15, 2010 1:35 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Thu Feb 28, 2019 7:10 pm

basketbuild wrote:
Note that the Roku Ultra is different.
Careful, because you just described that they can be on different channels, then stated they need to be on the same channel.
To explicitly describe what I am experiencing, the Roku broadcasts the Wi-Fi for the remote over the same channel as the 5GHz Wi-Fi router. Yes, it's the same channel that it's wirelessly connected to the internet over. That's exactly the issue! The Wi-Fi Direct broadcast signal for the remote shouldn't be on the same channel as the Wi-Fi signal for the internet connection. Which is exactly what's happening. And, it's causing issues.
I'm not sure if you didn't read my first post, didn't care to read it, or you just didn't understand it. But, I explained it in the first post.
Note that I also stated my Roku 3 is just fine because it has the option to not broadcast the remote's Wi-Fi Direct signal on the same channel. The feature called Interference. Poor design to begin with. Then, they removed the option to allow users to resolve the problem on their own.

Be careful when you accuse someone of not being able to read.  I said my Roku 3 is wired, my WiFi AP uses channel 36, and my WiFi direct remote uses channel 165.  Clearly the Roku doesn't just pick the closest/strongest signal.  If you're using a wireless connection to your Roku Ultra, it has no choice but to use the same channel for the remote as for streaming.  There's nothing that can be done about this except to use a wired connection.

I sincerely doubt the Ultra is different than the Roku 3, but I have the previous model of Ultra around here somewhere and I could confirm, or I could just trust my suspicion.  Do you know for a fact that turning on Interference Mitigation puts the remote on a different channel?  I'm pretty sure you're wrong there.  I'm not saying that Interference Mitigation isn't helpful in some way; I'm just saying it doesn't do what you think it does.

-JT
 
basketbuild
Topic Author
Posts: 17
Joined: Fri Feb 22, 2019 4:59 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Thu Feb 28, 2019 8:58 pm

renojim wrote:
basketbuild wrote:
Note that the Roku Ultra is different.
Careful, because you just described that they can be on different channels, then stated they need to be on the same channel.
To explicitly describe what I am experiencing, the Roku broadcasts the Wi-Fi for the remote over the same channel as the 5GHz Wi-Fi router. Yes, it's the same channel that it's wirelessly connected to the internet over. That's exactly the issue! The Wi-Fi Direct broadcast signal for the remote shouldn't be on the same channel as the Wi-Fi signal for the internet connection. Which is exactly what's happening. And, it's causing issues.
I'm not sure if you didn't read my first post, didn't care to read it, or you just didn't understand it. But, I explained it in the first post.
Note that I also stated my Roku 3 is just fine because it has the option to not broadcast the remote's Wi-Fi Direct signal on the same channel. The feature called Interference. Poor design to begin with. Then, they removed the option to allow users to resolve the problem on their own.

Be careful when you accuse someone of not being able to read.  I said my Roku 3 is wired, my WiFi AP uses channel 36, and my WiFi direct remote uses channel 165.  Clearly the Roku doesn't just pick the closest/strongest signal.  If you're using a wireless connection to your Roku Ultra, it has no choice but to use the same channel for the remote as for streaming.  There's nothing that can be done about this except to use a wired connection.

I sincerely doubt the Ultra is different than the Roku 3, but I have the previous model of Ultra around here somewhere and I could confirm, or I could just trust my suspicion.  Do you know for a fact that turning on Interference Mitigation puts the remote on a different channel?  I'm pretty sure you're wrong there.  I'm not saying that Interference Mitigation isn't helpful in some way; I'm just saying it doesn't do what you think it does.

-JT

Did you still not read my initial post? I have a Roku 3 as well! Official Roku tech support has already verified that the hidden feature was removed in the Roku Ultra. The Interference option does exactly what I think it does. Well, it does on Rokus that still have that option available... There is something that can be done about it! It was literally a feature before! In fact, if you took two seconds to find the menu on your Roku 3, you'd see that it used to exist for yourself!

Your experience with your Roku 3 isn't applicable for the same reasons I already stated in my first post. I'm not here to argue with you or anyone else. Please don't post in my thread unless you have something useful to contribute to resolving the problem with the Roku Ultra. Take your guesses and blame game elsewhere.
 
basketbuild
Topic Author
Posts: 17
Joined: Fri Feb 22, 2019 4:59 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Fri Mar 01, 2019 8:48 pm

Nothing from the Roku guys? No hope in getting a solution to this?
 
renojim
** Valued Community Member **
Posts: 3490
Joined: Mon Feb 15, 2010 1:35 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Sun Mar 03, 2019 12:48 pm

You're trying to argue something with me that I'm not arguing. I know it was removed. I know it helped you in the past. You don't know it does what you think it does simply because it helped with your Roku 3. Apparently I'm going to have to prove you're wrong (or maybe you're right; we'll see). You seem to think I'm arguing with you; I'm not. If any Roku can use a different channel for the remote than for its WiFi connection, that's news to me. I sincerely think you're wrong there. My original statement was simply that it doesn't just "use the same channel as the highest strength 5GHz (my Wi-Fi router!) in the area!". That's demonstrably wrong (as I demonstrated).

-JT
 
basketbuild
Topic Author
Posts: 17
Joined: Fri Feb 22, 2019 4:59 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Sun Mar 03, 2019 5:15 pm

renojim wrote:
You're trying to argue something with me that I'm not arguing. I know it was removed. I know it helped you in the past. You don't know it does what you think it does simply because it helped with your Roku 3. Apparently I'm going to have to prove you're wrong (or maybe you're right; we'll see). You seem to think I'm arguing with you; I'm not. If any Roku can use a different channel for the remote than for its WiFi connection, that's news to me. I sincerely think you're wrong there. My original statement was simply that it doesn't just "use the same channel as the highest strength 5GHz (my Wi-Fi router!) in the area!". That's demonstrably wrong (as I demonstrated).

-JT

You sure are doing a lot of thinking about something you haven't tested. Then, telling me I'm wrong after I've gone through all the steps and research, then consulted with support. Now, I'm here for a resolution. It's interesting that you back off your statements now. Your comments are yet to be helpful. You seem to want to state how I'm wrong, even though you have no evidence of the contrary, and even admitted to not testing it prior to making your statements. Which isn't helpful at all.
 
ZethuZ
Posts: 1
Joined: Fri Apr 05, 2019 8:46 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Fri May 24, 2019 8:14 pm

I have had the exact same problem and none of solutions suggested by Roku worked for me. They are clearly aware that there is a fundamental flaw in this product yet not much has been done so far. I am really done with Roku , would be picking up a Fire stick next
 
Mook
Posts: 1
Joined: Mon Jun 03, 2019 7:20 pm

Re: Roku Ultra - wireless network issues - no Interference menu option

Mon Jun 03, 2019 7:36 pm

I think the issue is that the Roku ups its signal strength above what the AP is using and it does degrade the channel being used. I agree this is an issue Roku needs to address!

Symptoms:

Roku will grab the same wifi channel as the nearest wifi access point (e.g. yours)
It will broadcast a Wifi Direct SSID DIRECT-roku-123-A2 on the same channel
It will increase its power to stay above your AP if you up the transit power

I did read on another forum where somebody set the channel on the router to something other than the normal channel, power cycled and let the Roku find that channel, then changed the router back to the normal channel. They stated that this worked unless the Roku power cycled. This might work on the Ultra since it usually stays powered on. It doesn't work on a Roku stick powered by usb.

Who is online

Users browsing this forum: No registered users and 28 guests