Your Digital Media Has Never Looked So Good

 
MatthewJFazio
Topic Author
Posts: 4
Joined: Sat Mar 09, 2019 1:30 pm

YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Mon Mar 11, 2019 1:58 pm

Hello,

A few days ago yesterday the YouTube channel on my TCL Roku TV stopped working. When launching the channel after a few seconds of an hourglass a grey screen appears saying "Connection Error: Please reconnect to the Internet."

After this screen pops up, the "back" button won't respond and I have to use the home button to exit.

Troubleshooting steps taken (in order)
  • Hard restart of TV (unplugged/plugged back in)
  • Made sure TCL was on latest update
  • Checked for good WiFi signal and time (set for auto)
  • Uninstalled YouTube channel / reinstalled channel (latest version of channel)
  • Uninstalled YouTube channel
  • Factory Reset (ugh, last resort that proved fruitless but added an additional 30 minutes of work getting the TV back to its previous configuration.)
  • Reinstalled YouTube channel
Still when channel starts, the grey screen appears with the "reconnect to Internet error."

Very frustrating, and about 30 minutes of web searches pulled up "close but no cigar" issues, mostly with mobile devices but nothing directly related to Roku devices or Roku TVs. Both Roku and TCL support sites were of no help.

Anybody else having this issue? Any assistance would be appreciated!
- Matthew J. Fazio
 
User avatar
RokuTannerD
Posts: 618
Joined: Tue Mar 20, 2018 2:37 pm

Re: YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Tue Mar 12, 2019 10:17 am

@MatthewJFazio

Thanks for the note. I'm sorry to hear about the issue you're seeing with that channel. A few questions here:

- Do you see issues with any other channel (app) on your device?
- If you go into Settings>Network>Check connection, what does your TV report? 
- Have you tried contacting YouTube support to report the issue and request additional assistance from that channel provider? 

It sounds like you've already covered these bases, but I'd recommend trying to remove the channel once more, then restart your TV from Settings>System>Power>System restart. Once it loads up again, go to Settings>Network>Set up connection and reconfirm your network details to connect to your network. Once this is complete, try adding the YouTube channel back once more. 

If you're still running into the issue from there, PM me with your Roku account email address, the serial number of your TV from Settings>system>About, and include the version/build of the YouTube channel that you have installed. (Go to the channel tile on the Roku home screen and press the * key to see this information). I'll take a closer look and see what else we might be able to recommend. 

Thanks,
Tanner
Tanner D.
Roku Community Manager
 
MatthewJFazio
Topic Author
Posts: 4
Joined: Sat Mar 09, 2019 1:30 pm

Re: YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Thu Mar 14, 2019 9:01 am

Hello Tanner,

To answer your questions:

- Do you see issues with any other channel (app) on your device?
No

- If you go into Settings>Network>Check connection, what does your TV report?
Good / Excellent connection (checked this several times, it alternates between the two)

- Have you tried contacting YouTube support to report the issue and request additional assistance from that channel provider?
No.  There's no official "YouTube Channel for Roku Support" that I can find.  Plenty of "sorta-related" forums, and they've all suggested what I've already done.

Finally, I removed/re-added the channel, checked the network connection (excellent this time) and reinstalled-- same problem.

Here's a pic of the error:
- Matthew J. Fazio
 
User avatar
RokuTannerD
Posts: 618
Joined: Tue Mar 20, 2018 2:37 pm

Re: YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Thu Mar 14, 2019 10:09 am

Thanks for the extra details here. Please PM me with your Roku account email address and the serial number of the TV you are seeing this issue on from Settings>System>About. Please also include the version/build of the YouTube channel you have installed on your device by navigating to the YouTube channel tile on the Roku home screen and pressing the * key. 

I'll follow up with your directly to assist you further and see what other suggestions we can make. 

Thanks,
Tanner
Tanner D.
Roku Community Manager
 
MatthewJFazio
Topic Author
Posts: 4
Joined: Sat Mar 09, 2019 1:30 pm

Re: YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Sun Mar 24, 2019 9:54 am

Issue has been resolved.

Tanner,

The issue with YouTube -- noticed ONLY with YouTube so far-- turned out to be the network connection.

Per your previous suggestion to use a different source (like a hot-spot) I purchased a WiFi extender, set it up in the same room, and connected my TCL to it.  Whammo:  channel started up with no issues.

Keep in mind the Roku on this TV has been working just fine for the last couple years with a "good" quality connection;  I'm not sure if a TCL, Roku, or YouTube channel update "broke" viewing YouTube, but now an "excellent" connection is required to make it all work again.

Thanks for looking into this.

- Matt F.
- Matthew J. Fazio
 
steffank
Posts: 1
Joined: Tue Aug 13, 2019 7:35 pm

Re: YouTube Channel Stopped Working on TCL Roku TV: "Connection Error: Please reconnect to the Internet" Grey Screen

Tue Aug 13, 2019 7:40 pm

Same thing here. I have a Roku 2 and a Roku 3. I have a wired connection. The last network connection check shows 77 Mbits/sec. I have uninstalled, rebooted, reinstalled, with the same error "Please reconnect to the internet".
This happens for both Youtube and YoutubeTV, so I'm thinking of ditching both my Rokus and going with ChromeCast.

Who is online

Users browsing this forum: NewsView and 27 guests