Your Digital Media Has Never Looked So Good

 
harrygharper
Topic Author
Posts: 2
Joined: Sun Jul 05, 2009 1:47 pm
Location: Indiana

Problem with Linksys WRT54G

Sun Jul 05, 2009 2:00 pm

Can't get the Roku player to connect wireless (but it will conect via Ethernet cable). When I attempt a wireless connect I get a green light for the "connecting to wireless network" but a red light on "connecting to your local network". I've tried everything but can not get it to work. MAC is not enabled (I even tried that and input the Player's MAC address but then couldn't connect to the internet. Any suggestions ??

Thanks
 
glen4cindy
Posts: 85
Joined: Sun Jul 13, 2008 1:56 pm
Location: St. Louis, MO

Mon Jul 06, 2009 11:42 pm

Do you have wireless security enabled?

If so, are you choosing the proper encryption method and inputting the proper passphrase?

I have the same router and have no problems connecting wireless, though I did run Cat 5 to speed things up.
 
mkiker2089
Posts: 2810
Joined: Fri Jul 03, 2009 9:03 pm

Tue Jul 07, 2009 12:18 am

try turning off security including password (wep,wpa etc..) and the firewall. See if you get on then.
 
User avatar
jeffrok
** Valued Community Member **
Posts: 5523
Joined: Sun Nov 30, 2008 4:51 pm
Location: Milwaukee, WI
Contact:

Tue Jul 07, 2009 8:05 am

Advising someone to disable their wireless security is not that smart, unless you don't mind your neighbors and people with iPhones hopping on your wireless network, and possibly attacking your home PC's.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
 
Satnamji
Posts: 136
Joined: Sat May 16, 2009 12:29 pm

Tue Jul 07, 2009 9:23 am

A few months ago, I was having trouble with my Linksys WRT54G (v. 5) maintaining a wireless (and wired) connection to my PS3 until I read in another forum that I should upgrade my firmware, which I did by going to Linksys's site, finding the upgrade, and following their tutorials on how to apply it. It was a bit of a pain, but the results were worth it. Once I was in my router's internal settings menus, I also changed the channel I was on to one that wasn't being used in my neighborhood. That may have helped too. Good luck!
 
harrygharper
Topic Author
Posts: 2
Joined: Sun Jul 05, 2009 1:47 pm
Location: Indiana

Thanks guys !

Tue Jul 07, 2009 11:08 am

I turned wireless security off for a few minutes and, sure enough, I connected immediately. Turned it back on and fooled around with the security mode finally ending up with wpa2-personal with an AES algorithm and it worked. Before, I was using wpa-personal. It's possible I had wpa-personal on one setting and wpa2-personal on another and didn't see it even though I looked at it fifty times. But we're good now.

Again, thanks much for your input.
 
mkiker2089
Posts: 2810
Joined: Fri Jul 03, 2009 9:03 pm

Tue Jul 07, 2009 11:09 am

jeffrok wrote:
Advising someone to disable their wireless security is not that smart, unless you don't mind your neighbors and people with iPhones hopping on your wireless network, and possibly attacking your home PC's.


I never said to leave it off but it's the best way to a- get the name and settings in the machine and b- determine where the problem is.

Get connected, then enable wpa and re-connect the roku, if that still works fine turn on the firewall and see if that breaks it. You have to think methodically which is just what the OP did and fixed his own problem.
 
DasBroose
Posts: 9
Joined: Thu Feb 12, 2009 3:25 am

Sun Jul 19, 2009 6:22 pm

I'm having exactly the same prboblem with a Linksys WRT310N. I can connect without wireless security enabled, but when I enable the WPA Personal settings (which I was using sucessfully before, mind you), the box errrors on "connecting to your local network".

Is there a known issue with the Roku DVP and WPA security? Or wireless security in general? Is there some way to tell the Roku to use WPA Personal explicitly? I can't find it in the "secret" setup screens.

Please help! This is infinitely frustrating, as I had this thing working just fine a few days ago and it just decided to start effing with me.
 
DasBroose
Posts: 9
Joined: Thu Feb 12, 2009 3:25 am

Sun Jul 19, 2009 6:35 pm

Okay it's out again. What gives? Has anyone had their player act this temperamental?!
This is starting to become infuriating. :x
 
billc124

Sun Jul 19, 2009 6:41 pm

My player has never had a problem with WPA security. I only use Netgear networking equipment though. I have had several Linksys routers over the years and always had trouble with them to the point that I stopped buying and recommending them to other people. I would be willing to wager the problem is with the Linksys router not the Roku player. Just based on my experience with the Linksys products.
 
DasBroose
Posts: 9
Joined: Thu Feb 12, 2009 3:25 am

Sun Jul 19, 2009 7:07 pm

I think I may have found something useful:

In the setup page for the WRT310N, there is a setting under the "Security|Firewall" page for "Internet Filter". I unchecked the box for "Filter anonymous internet requests" and the box connected.
I'm not sure this actually had anything to do with the successful connection given how this thing has been (mis)behaving, but I'm not going to jinx it again by changing back. :wink:
 
mkiker2089
Posts: 2810
Joined: Fri Jul 03, 2009 9:03 pm

Sun Jul 19, 2009 9:14 pm

Word on the net is to flash Linksys routers with Tomato firmware. It's said that they make good hardware, but spotty software.
 
Crow550
** Valued Community Member **
Posts: 2154
Joined: Sat Dec 13, 2008 11:36 am

Mon Jul 20, 2009 12:25 am

Yeah I use Tomato. Got the same Router.

Also heard DD-WRT is good.
 
RWatson
Posts: 152
Joined: Fri Jul 25, 2008 5:13 pm

Mon Jul 20, 2009 7:06 pm

A LAN cable is also very good...........
 
chemosh6969
Posts: 11
Joined: Sun Jun 29, 2008 9:04 am

Sun Jul 26, 2009 6:59 pm

RWatson wrote:
A LAN cable is also very good...........


Ethernet cable.

I have DD-WRT on a couple routers here and while it works fine once everything is setup, setting it up was a pain. My linksys router is using the firmware that it came with and it's been fine for me.

Who is online

Users browsing this forum: No registered users and 41 guests