Your Digital Media Has Never Looked So Good

 
NikolaTesla
Topic Author
Posts: 3
Joined: Fri Dec 07, 2012 6:43 am

Connecting Roku to Ad-Hoc Network

Sun Feb 10, 2013 6:34 am

Hello,

I live in an apartment that supplies free wifi, but I have to enter a username and password every 24 hours (i.e. NOT the SSID, but an actual username and password in the browser. I know, it's annoying; but, my landlord is stubborn, and I have a 12-month lease). My Roku 2 XS (model 3100x) will not do this. Thus, I would like to setup my laptop as an AdHoc or Access Point network for my Roku.

Here are my specs:
Laptop: Dell Inspiron 1525; OS = Windows 7 32-bit; Networking adapters = 2 wireless adapters (inboard Dell 1395 and USB TP-Link WN821N); 1 ethernet connection
Roku 2 XS (model #3100); firmware has been updated
Router: (Unknown, owned by landlord)
Network Configuration: DHCP enabled on all laptop adapters; No WORKGROUP setup. All network connections classified as "Home".
Firewall: Kaspersky Internet Security 2013, but I disable the firewall anytime I am trying to connect.

I have successfully been able to connect my Roku 2 XS to the internet via my laptop using the following:

- Connectify Pro software (note: I was unable to connect trying to setup the Ad-Hoc network manually via Windows 7; thus, I resorted to Connectify).
- ethernet cable between Roku 2 and laptop
- internet connection to landlord's router via USB TP-Link adapter OR Dell 1395 (i.e. both work)

However, because of my apartment layout, I cannot keep the ethernet cable connected between my laptop and Roku all of the time. Therefore, I would like to connect my Roku 2 to my laptop via wifi and still connect to my landlord's router via wifi.

I have tried many ways to make this happen:

1) Setup an Ad-Hoc network manually using Windows 7 Network and Sharing Center. But, Roku will not show green on even the first stage of three ("Connecting to wireless network")
2) Setup Connectify as an Ad-Hoc network. But, I have the same issue above (cannot get past the first stage as mentioned above)
3) Setup Connectify as an Access Point and use either TP-Link or Dell Adapter (I get a green light on "Connecting to wireless network", but then it cannot get past "Connecting to local network"). NOTE: my Samsung phone can connect to the Access Point this way, but not with options 1 and 2.

I think option #3 is my best shot, but I don't know why Roku will not "connect to my local network". I have read through the forum and tried so many different things, but nothing seems to work. Can anyone offer advice to option #3 and why my Roku will not connect to my "local network"?

Thank you in advance!

-Nikola
 
User avatar
RokuShawnS
Roku Engineering
Posts: 5915
Joined: Thu Mar 10, 2011 2:21 pm

Re: Connecting Roku to Ad-Hoc Network

Sun Feb 10, 2013 8:13 am

Do a forum search for "Roku+Hotel" Lots of good information in most of those posts.

In short, you'll have to "spoof" things a bit using a MAC address and a laptop/computer.

C. Shawn Smith
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
 
NikolaTesla
Topic Author
Posts: 3
Joined: Fri Dec 07, 2012 6:43 am

Re: Connecting Roku to Ad-Hoc Network

Tue Feb 12, 2013 12:16 am

I finally got it to work!!!!!

I didn't have any success spoofing a MAC address on my laptop, so I continued to pursue how to setup an Access Point or Ad-Hoc network on my laptop. I thought I'd share how I finally got it to work. Please note, I am not expert; there may be better or easier ways to do this. But, perhaps this could help someone else with similar issues to mine....

I had tried using 3rd-party software such as Connectify or Virtual Router Manager. It would create the Access Point, but it couldn't access my network. So, I created the Access Point myself using the following tutorial: http://seevisionc.blogspot.com/2012/06/androidwifi-alternative-to-connectify.html.

But, for some reason, the Access Point (i.e. the Microsoft Virtual WiFi Miniport Adapter) still couldn't access the network. The IPv4 address being generated by the "netsh wlan set hostednetwork..." command was something like: 192.168.174.xxx. My network uses IPv4 addresses similar to 192.168.0.xxx. Once I manually changed the Microsoft Virtual WiFi Miniport IPv4 to a similar address as my network's, it worked!

Now, I don't have any ethernet cables connected to my laptop, and I'm free to work anywhere in my apartment while streaming Pandora, Hulu, Amazon, etc!!!

-Nikola

Who is online

Users browsing this forum: jgarvin1977, jsh1, livestreamaggregator and 21 guests