Your Digital Media Has Never Looked So Good

 
cdodge1
Topic Author
Posts: 3
Joined: Sun May 18, 2014 6:57 pm

Connects to Wifi, but nothing works after that

Sun May 18, 2014 7:01 pm

The Roku 3 has proven tremendously disappointing over the last few months, with severe connectivity issues. Let me be clear, however, that this is not a 014 connectivity problem that seems so prevalent.

What happens is that my Roku will say it is connected to my Wifi (with an 'excellent 'connection, no less), but then nothing will work. Apps will not load or, when they do, the video will not play. I've seen that spinning circle of white dots on HBOGo for more time than I care to mention. Roku support has generally been useless. I put in some DNS numbers per their instructions and that briefly made it play better, but it is back to being mediocre per usual.

Normally I would be inclined to blame something like this on Comcast, the most wretched of all the wretched companies out there. But HBOGo, Netflix, pandora, etc. all play fine through the Wifi on computers, phones, and tablets in my apartment. It is only the Roku that won't work.

Are there any thoughts out there? Every time I try looking for troubleshooting ideas, I end up on a page discussing problems with connecting the Roku, which isn't really my problem.

Thanks for any help.
 
trekkeriii
** Valued Community Member **
Posts: 2561
Joined: Wed Dec 12, 2012 4:10 am

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 7:24 pm

I would change your wi-fi settings to a specific channel, like 11 on your Wi-Fi access point/router. Most likely that's the problem.
http://trekkeriii.com/Roku_PHP_list.php
Router - ASUS RT-AC68U
ISP - TWC - 50 Mbps/5 Mbps
Net+ Cert
 
User avatar
RickRansom
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 7:38 pm

If you have a smartphone with 4G/LTE access that can act as a hotspot, try to have the Roku connect to that and see if the apps on your Roku box work fine. Basically, if the unit works fine through a different connection, it has something to do with the path from your home network [Comcast] to the services that your Roku box is accessing.

BTW, did Comcast have you use one of their XFinity routers or are you using your own?
Retired
- Now works at Riot Games
 
cdodge1
Topic Author
Posts: 3
Joined: Sun May 18, 2014 6:57 pm

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 8:01 pm

To the first poster, I have already tried changing the channel. It was on 11 originally and I've experimented with a few others, but it doesn't change much.

I've given thought to try out the phone as a hotspot and might give that a try tonight. Given that the phone will be on Wifi, that could potentially be a workaround.

And yes, I use a Comcast joint router/modem. Any chance that is the culprit?
 
theuser86
Posts: 1832
Joined: Sun Oct 27, 2013 4:56 pm

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 8:18 pm

Note hotspotting your phone only uses your cellular data connection. You cannot hotspot a wifi connection aka repeating a wireless connection.
 
IBMMuseum
Posts: 77
Joined: Fri Mar 07, 2014 12:31 am

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 9:54 pm

cdodge1 wrote:
To the first poster, I have already tried changing the channel. It was on 11 originally and I've experimented with a few others, but it doesn't change much.

I've given thought to try out the phone as a hotspot and might give that a try tonight. Given that the phone will be on Wifi, that could potentially be a workaround.

And yes, I use a Comcast joint router/modem. Any chance that is the culprit?


Have you tried setting it up on a wired connection, to be able to rule out whether it is a wireless issue or not?...
 
cdodge1
Topic Author
Posts: 3
Joined: Sun May 18, 2014 6:57 pm

Re: Connects to Wifi, but nothing works after that

Sun May 18, 2014 10:17 pm

Unfortunately that is not logistically possible, as the router is on the opposite side of the apartment from my television. Really regret my router placement...
 
User avatar
RickRansom
Posts: 2156
Joined: Sat Nov 12, 2011 3:23 pm
Location: PH

Re: Connects to Wifi, but nothing works after that

Mon May 19, 2014 2:19 pm

If it's an Arris TG862, try disabling the "network ping" on the Roku player and see if that helps. Some users here report having connection problems with that router. This might help.
Retired
- Now works at Riot Games
 
a4adam
Posts: 2
Joined: Wed May 21, 2014 2:41 pm

Re: Connects to Wifi, but nothing works after that

Wed May 21, 2014 2:57 pm

My Roku 3 went belly up with error code 14 in late March after 4 months of working perfectly.

Comcast with an Arris router (TG862G) here. What I had to do was reset the router to factory defaults to clear some issues with the routing table. Then I set wifi to channel 6 and use WPA2 TKIP. Using the recommended settings (default) didn't work for me with the Roku at all.

Nothing I did with the Roku box helped (went through this with support a few times) at all. Disabling pings had no effect.

So try changing your encryption to WPA or WPA2 TKIP, then power cycle your Roku box.

A few times, resetting the gateway cleared problems as well. I'm on day 3 now with no problems, I have my fingers crossed!
 
rmcmillan
Posts: 1
Joined: Sat Jun 13, 2015 5:00 am

Re: Connects to Wifi, but nothing works after that

Sat Jun 13, 2015 5:13 am

a4adam you are a miracle worker! I have Comcast/Infinity router/modem combo and have had trouble with my Roku connection ever since I got it. Roku settings said it was connected to wifi/internet/local and "excellent" but nothing would connect. I tried resetting the channels, resetting the roku and router/modem... nothing worked. I could connect through my iPhone hotspot so I knew it was the Comcast router/modem problem. FINALLY, I saw your post about the encryption -- BINGO. I changed to WPA-TKIP from the automatic (Comcast recommended) encryption setting and everything is great now.
Thank You!
 
DickAlmighty
Posts: 1
Joined: Wed Jan 06, 2016 5:54 am

Re: Connects to Wifi, but nothing works after that

Wed Jan 06, 2016 5:57 am

Xfinity user here. Was having the same problems. Encryption fix worked like a charm. Thank you so much.
 
chostett1
Posts: 1
Joined: Sat Jan 09, 2016 8:55 am

Re: Connects to Wifi, but nothing works after that

Sat Jan 09, 2016 9:05 am

I am so happy to see that others have found the solution to this. I'm afraid I'm not as technologically competent as others seem to be. Would I call Comcast to walk me through the changes suggested by a4adam? Thanks for any help!
 
betbrett
Posts: 5
Joined: Sun Jan 31, 2016 4:28 pm

Re: Connects to Wifi, but nothing works after that

Sun Jan 31, 2016 4:33 pm

Roku Says I am connected. Signal good. This box has been working for a year or more. Nothing has changed. Same router, log in information, everything. Suddenly today it says connected but nothing will play. No matter what app I choose I either get an error or I get a message saying there is no internet connection.

My roku in another room is still working fine. Phone and laptop all fine.

Just this one roku box. Was working fine yesterday. Today it says its connected to the internet but all of the apps I try to use say otherwise.

I have reset the box. I have unplugged it and let it set, then plugged it back in. I have disconnected from the network and reconnected. I have rebooted the comcast router. I have done everything I can think of.

Any ideas? Has the thing just crapped out on me? Nothing makes any sense at this point.
 
User avatar
dgrace
Posts: 873
Joined: Sat Jan 01, 2011 2:31 pm
Location: Montana

Re: Connects to Wifi, but nothing works after that

Sun Jan 31, 2016 9:20 pm

chostett1 wrote:
I am so happy to see that others have found the solution to this. I'm afraid I'm not as technologically competent as others seem to be. Would I call Comcast to walk me through the changes suggested by a4adam? Thanks for any help!

I'd get online with your modem/router model and find a guide or support site for it. You should be able to find the process to do that.
"I might be moving to Montana soon..."
FZ
 
Sapper21
Posts: 1
Joined: Wed Dec 27, 2017 10:06 pm

Re: Connects to Wifi, but nothing works after that

Wed Dec 27, 2017 10:12 pm

If your Roku is connected to WIFI Connection, but not the internet connection, you may need to update your firmware to your Roku. This is done by logging into your router by using most basic IP address 192.168.1.1 and then you will see a login box. Most default logins are: login:admin / Password: password. If you have changed this name in the past and do not remember then you will need to press the reset button on the back of the router for at least 10 seconds (do not disconnect anything). This should make it available to log in with the default login stated above. 

Once you are logged in, a highlighted note will be displayed at the top of the webpage telling you to update if it needs to be updated. Click on that, and let it download. The internet will reset a couple of times (normally about 2-3 times). Once this happens, relog into the router and go from there with all your other settings. Everything should work from there. If you have already tried all the other mentioned comments above about restarting, unplugging, and all that.

Who is online

Users browsing this forum: No registered users and 22 guests