Your Digital Media Has Never Looked So Good

  • 1
  • 2
  • 3
  • 4
  • 5
  • 14
 
mc510
Topic Author
Posts: 110
Joined: Thu Jan 09, 2014 5:30 pm

7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:32 pm

The new firmware hit my Roku 2 XS a couple of days ago; it must have hit it pretty hard too, because I've got all kinds of new issues. Attempting to play a video (from any app) gives a blank screen with a text warning about HDCP not approved. Scrolling around on the main Roku screen, or within an app, causes the Roku video output to flicker off (which I experience as my TV popping up a notification box saying "looking for hdmi source) and then back on a second later. Restarting Roku makes these problems go away temporarily, but they keep coming back.

This is a pain in the a**; can I go back to version 6 firmware?
 
User avatar
RokuShawnS
Roku Engineering
Posts: 6627
Joined: Thu Mar 10, 2011 2:21 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:39 pm

We don't do rollbacks. Can you please PM me your Roku serial number (Settings > System > About) along with the full firmware version and build number? I'll also need the Make and Model number of your television.

Have you contacted CS, and if so, what's your case number?

C. Shawn Smith

PS: the HDCP not approved message is your television's warning message, not Roku. Try a different HDMI cable to see if that changes the behavior.
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
 
AndyCalling
Posts: 171
Joined: Tue Feb 18, 2014 11:02 am

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:43 pm

Try dropping to 720p if you're on 1080p. I believe v7 software has a problem over gunning the HDMI at 1080p. I get this using a Stick (so no cable) though my TV (Samsung UE32F5000) reacts a little differently. Just got to wait for a fix, and drop res till then.

Let us know if this works for you.

@RokuShaun, is this one on the radar of your dev team yet? I suspect many of the glitching threads popping up re. v7 devices are really the same issue. Might be a big problem.
Last edited by AndyCalling on Mon Nov 23, 2015 7:10 pm, edited 2 times in total.
 
mc510
Topic Author
Posts: 110
Joined: Thu Jan 09, 2014 5:30 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:45 pm

Thanks Shawn; I'll PM that info to you tonight when I'm back home.

I haven't contacted CS; was assuming that they only deal with under-warranty issues. Should I contact them?
 
mc510
Topic Author
Posts: 110
Joined: Thu Jan 09, 2014 5:30 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:47 pm

AndyCalling wrote:
Try dropping to 720p if you're on 1080p. I believe v7 software has a problem over gunning the HDMI at 1080p.
My TV doesn't do 1080; it's a 32" 780p model so I've had the Roku set on 780p. I'll check tonight to make sure that's still the case after the firmware upgrade.
 
AndyCalling
Posts: 171
Joined: Tue Feb 18, 2014 11:02 am

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:50 pm

Try to drop res anyway if you can. Perhaps this issue kicks in at max TV res? Who knows, but playing with the res is a good bet to influence the problem.
 
User avatar
RokuShawnS
Roku Engineering
Posts: 6627
Joined: Thu Mar 10, 2011 2:21 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 1:50 pm

You don't need to contact CS ... it just makes it easier (on me) to reference your issue when I speak with CS :). I already have a call-out with CS, just waiting to hear back.

Your serial number will help the engineers by allowing them to look at your logs.

Note: this is a short week due to the holidays, but hopefully we'll get some feedback before Thanksgiving.

C. Shawn Smith
C. Shawn Smith
Community Liaison

------------
The Cosmos is all that is, and all that was, and ever will be. -- Carl Sagan
 
Weezknight
Posts: 18
Joined: Fri Aug 21, 2015 6:18 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 23, 2015 5:07 pm

AndyCalling wrote:
Try dropping to 720p if you're on 1080p. I believe v7 software has a problem over gunning the HDMI at 1080p. I get this using a Stick (so no cable) though my TV reacts a little differently. Just got to wait for a fix, and drop res till then.

Let us know if this works for you.

@RokuShaun, is this one on the radar of your dev team yet? I suspect many of the glitching threads popping up re. v7 devices are really the same issue. Might be a big problem.


Sure does sound like a similar problem. I have had, what I presume, is an HDCP problem with my stick since the v7 rollout, as well. Only affects the stick, and no other devices using the same HDMI port.
 
DallasGG
Posts: 7
Joined: Sun Jan 26, 2014 3:27 am

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 4:32 am

I updated 2 of my Roku 2 XS's to the 7.0 firmware. Both of them have experienced the same problem multiple times. The problem occurs when I haven't used my Roku 2 XS for awhile (several hours up to a day). When I try to use it after not using it for awhile, I hit the remote control one time to move over to one of my channels (which it does successfully) and then the remote control immediately freezes up and is non-responsive. The only solution to get my Roku back working again is to unplug it and plug it back in and let it reboot. This problem only started happening after I updated to the 7.0 firmware. The fact that it's happening on both of my Roku 2 XS's indicates to me that it's a software issue. This problem never happened before the firmware update. Please fix the software!
 
oshia86
Posts: 15
Joined: Tue Oct 13, 2015 4:47 am

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 5:57 am

Having constant lockups on mine. If I watch an episode of anything on Netflix I can guarantee that the unit will be unresponsive to the bt remote or the phone app before the show is over. The only way to get it back is to pull the power. I'm not too worried about it. I got two new Brand X units on the way to the house for Christmas.
 
heyradar
Posts: 13
Joined: Mon Mar 28, 2011 10:28 am

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 6:42 am

I have a Roku 2 XD that is freezing after watching Netflix. It becomes unresponsive to the remote or app, and must be power cycled to work again.

The device had been working flawlessly and just recently started this behavior after it was upgrade to 7.x.
 
renojim
** Valued Community Member **
Posts: 3491
Joined: Mon Feb 15, 2010 1:35 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 2:08 pm

Just got a call from my mother. Her XS is doing the same thing and my Roku 3 crashes on a regular basis. I can't believe Roku is pushing out this steaming pile of firmware! :evil: :evil: :evil:

-JT
 
Pompey
Posts: 267
Joined: Mon Oct 17, 2011 4:24 pm
Location: New York, NY

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 2:11 pm

Don't know if there is a relationship with ver. 7 or not, but today my 2 XS box exhibited some strange behavior. When it woke up, it was completely locked up on the home screen. Button entries from both BT and IR remotes did nothing, even though i could see the box LED blink confirmations. I had to unplug, do a cold boot and after the restart, the home screen displayed a link in the lower left hand corner (where I've never seen anything before) seemingly advertising an ad pushed by the servers concerning Roku deals for Cyber Monday. From the graphics, it appears the link was supposed to be opened with a press of the play/pause button. I tried that button press, but nothing happened. The ad link disappeared. My box seems to be operating normally again. It is the first time I ever saw my 2 XS lock up on the home screen. I wonder what happened?
"One great use of words is to hide our thoughts." Voltaire
"We are masters of the unsaid words, but slaves of those we let slip out." Winston Churchill
 
renojim
** Valued Community Member **
Posts: 3491
Joined: Mon Feb 15, 2010 1:35 pm

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 2:21 pm

V7.0 happened!
 
Pompey
Posts: 267
Joined: Mon Oct 17, 2011 4:24 pm
Location: New York, NY

Re: 7.0 firmware broke my Roku 2 XS

Mon Nov 30, 2015 3:25 pm

I see there is a posting today describing similar symptoms at this thread .... viewtopic.php?f=28&t=90003&p=512226#p512226
"One great use of words is to hide our thoughts." Voltaire
"We are masters of the unsaid words, but slaves of those we let slip out." Winston Churchill
  • 1
  • 2
  • 3
  • 4
  • 5
  • 14

Who is online

Users browsing this forum: raghumobile, Tivoburkee and 25 guests