Your Digital Media Has Never Looked So Good

 
Suchagoodboy
Topic Author
Posts: 1
Joined: Wed Dec 24, 2014 7:47 pm

How I fixed my BLANK SCREEN AFTER BOOT issue (Roku 2xs)...

Mon Dec 14, 2015 3:35 pm

Problem: Blank Screen after boot animation.

I did a Factory Reset (thru the menu) on my Roku 2 XS, and ended up with a device that displayed the dancing ROKU boot animation then went to blank screen.

I spent a couple hours reading forums and trying all sorts of possibilities. Verified cables, swapped power supplies, swapped monitor/TV, taped the reset button, held reset button 30 seconds, held reset button while unplugging power... Nothing worked.

Then as a last ditch effort, I tried a technique I've used to revive semi-bricked routers... and IT FIXED IT.
I didn't see this suggestion on any forums or help pages, so I offer it to you here.

(I started with a Roku 2xs powered up, ethernet cable plugged in, HDMI to a computer monitor)

1. UNPLUG HDMI, ETHERNET, AV OUT LEAVING ONLY POWER PLUGGED IN
2. DEPRESS RESET BUTTON (KEEP IT PRESSED DOWN)|WAIT 30 SECONDS
3. UNPLUG POWER|WAIT 30 SECONDS
4. PLUG POWER BACK IN|WAIT 30 SECONDS
5. RELEASE RESET BUTTON AND UNPLUG POWER
6. Cross your fingers... REATTACH HDMI & POWER

This just about takes 3 hands to keep the reset button pressed for over a minute and a half while unplugging and plugging back the power. Get help.

This would not work with the HDMI plugged in.

I had to re-pair the remote.

I wish you good luck and happy Roku-ing!
 
RogueFun
Posts: 1
Joined: Sun Aug 11, 2019 8:31 am

Re: How I fixed my BLANK SCREEN AFTER BOOT issue (Roku 2xs)...

Sun Aug 11, 2019 8:35 am

Holy Batballs! It worked! I held little hope, because this stuff never works. But this did.

Thanks!

Now back to the Man Cave.


Spoke too soon.

After pairing the the remote and logging on to my network, same bat problem.

Who is online

Users browsing this forum: BooBooKitty, NewsView, RokuTannerD, zkmdh and 27 guests