Your Digital Media Has Never Looked So Good

Posts: 1
Joined: Wed Oct 04, 2017 5:03 pm

Re: Hard-wire a Roku TV with ethernet-dongle-USB port

Wed Oct 04, 2017 5:16 pm

TLC 55fs3750 bought Nov 2015 with software version 7.70 build 4142-08

I bought e100 plugable usb to ethernet adapter and unpowered usb hub. Hub allows usb drive and usb ethernet to be used.
I unplugged tv, plugged in hub to usb (I use a short extension) makes it easier to plug in  different usb drives.
 plugged tv back in and i had ethernet. click on settings/ network and it shows wired ethernet
Posts: 1
Joined: Sat Oct 07, 2017 9:35 pm

Re: Hard-wire a Roku TV with ethernet-dongle-USB port

Sat Oct 07, 2017 10:50 pm

Insignia NS-32DR310NA17

At first power-up, I had a USB-10/100 ethernet adapter connected to the USB port, and I was watching the log on the DHCP server.  The TV did get an address with the shipping firmware.  However, it would not connect to the Roku server, download, or configure channels, nor would it download the current firmware.  I did have to put the TV on a wireless network for it to go that far.  I used a temporary network on a small portable WiFi base station I keep in my laptop bag.

Once the update was installed and the TV rebooted, I shut down the WiFi base I had connected it to.  The TV continued to work just fine (connecting to Netflix, Amazon, and CBS) over the wired ethernet connection.

This ethernet dongle is based on the Asix AX88772 chip.  These are very common, and very cheap.  If you were developing a small embedded Linux system (like the Roku) and needed USB ether support, this is definitely a driver you would include in your kernel.  The AmazonBasics USB 2.0 adapter uses this chip, as does this other one, which I used.  Both are under $10 each.
Posts: 1
Joined: Mon Apr 09, 2018 8:47 am

Re: Hard-wire a Roku TV with ethernet-dongle-USB port

Mon Apr 09, 2018 9:05 am

rkuser2128 wrote:

I just bought the 43" Sharp Roku TV from Best Buy today. The first USB dongle didn't work (a 3.0 USB to ethernet adapter), then I tried the one I had connected to out WII U. Success!!

The brand is "Plugable" and the Model is USB2-E100 (sold at Newegg and Amazon for $12).

Just hook up the adapter, go into Setting -> System settings -> Power -> System Restart

I knew it worked right away because the Home screen previously stated "Not Connected" in the top right of the screen and after the restart, it listed the current time. No need to go into Netflix and check the connection as others have written. ... B00484IEJS ... 2XB12C5920

This worked for me...I also have a 43" Sharp Roku TV.
Based on my research on this topic...certain dongles work on certain TV make sure you research your TV brand of Roku.  
The first dongle I bought did not work...Belkin USB 2.0...
"The brand is "Plugable" and the Model is USB2-E100"...this worked on my Sharp TV...just Google search it to find out where to buy...I paid about $12 from the Walmart website.
It worked as soon as I attached it.  I do not think the system restart was needed...but I did it anyway.
What was different for me is...I still see "not connected" momentarily when I turn the TV on in the upper right hand corner...then it goes to current time.  But you can see it is "wired" connection by checking it settings.  Goto Roku home screen then:  Setting ==> Network ==> About...connection type will say "wired".
Picture quality is way better...I did not realize how bad my wifi connection was...
rksuer...thanks for your post dude!!!!
Good look to all!!!
Posts: 1
Joined: Sat Jan 12, 2019 7:57 am

Re: Hard-wire a Roku TV with ethernet-dongle-USB port

Sat Jan 12, 2019 8:19 am

I own a 55" Sharp Roku, I purchased the following usb adapter ... B00484IEJS
After clearing the wireless setting and restarting the TV the adapter worked fine with one exception. I notice on occasion when i turned the tv on without using it for a while it would not connect to the internet unitl i went into "advanced settings" and reset network connection. I have come to the conclusion that this has something to do with the tv sending power to the usb port. Whether it is the power saving mode or sleep mode or the adapter not activating quickly enough i dont know. However i have solved this problem by using a cheap POWERED usb hub. Since I have installed the hub the tv remains able to connect on startup at all times. 
Powered 4-Port USB 3.0 Hub 5Gbps Portable Compact for PC Mac Laptop Desktop on ebay

Who is online

Users browsing this forum: steveg20 and 22 guests