Your Digital Media Has Never Looked So Good


Tue Mar 20, 2007 3:30 pm

From looking at what you've posted, I think your ISP was not properly assigning a DNS server address to your router. I would guess that they fixed it.
Topic Author
Posts: 11
Joined: Tue Mar 13, 2007 2:43 pm

Tue Mar 20, 2007 3:50 pm

RokuMike wrote:
From looking at what you've posted, I think your ISP was not properly assigning a DNS server address to your router. I would guess that they fixed it.

I think you are right Mike, When I look at the "Wi-Fi Status" pages on the Roku M1001, I see addresses listed under the 2 DNS listings where previously (before I had Roku wireless internet access) I had zero's for the 2 DNS addresses.... Once again, very strange that the DNS addresses would magically appear but I guess the gods had enough fun tormenting me and threw me a bone.... Works for me.... THX
Posts: 2664
Joined: Sun May 08, 2005 10:14 am
Location: Sausalito,Ca

Tue Mar 20, 2007 9:09 pm

thekubiaks wrote:
I finally got the ROKU to work 100%. Thanks for your tips but the unit just decided to start receiving the internet radio stations on its own. I was going thru the Static IP setup procedures again and did several "Restarts" on the Roku M1001. After I re-entered the Wireless WEP password, the unit started to wirelessly access the internet. VERY BIZZARE. I'm happy that everything is working but dumbfounded by the pain involoved in setting up this thing. Almost every procedure I went thru was not documented with the unit and I had to dig thru obscure corners of the internet to find a work-around. :cry: There was practically no documentation on wireless setups and I must have spent 10 hours digging thru Linksys and Roku forums before I coaxed this thing into service. I love the product when it works but good grief!! I bet you have a very large amount of units returned because the customers can't figure out the setup.

95% of the time, the router 'behaves' and properly assigns the IP, subnet, gateway and DNS's, but we occassionally see Netgear, and more frequently Linksys, fail to properly perform DHCP services to the Roku. Roku could certainly shave many hours of frustration and troubleshooting by enhancing and simplifying the static IP assignment procedure, which currently is pretty hairy kludge-fix requiring above-average networking skillz. :|
Then as it was, then again it will be
An' though the course may change sometimes,
rivers always reach the sea

M1000x2,M2000,Twonky 4.3.3 RC1 beta on LinkStation HGLAN400gig,Buffalo whr-g54s on DD-WRTfirmware-luv'in it!
Posts: 1
Joined: Sun Nov 25, 2012 1:49 am

Re: M1001 shows Ethernet port is disabled

Sun Nov 25, 2012 2:15 am

WOW, removing the wireless card from the unit did the trick. I upgraded the firmware (old was 2.0.something) last night and couldn't connect through cable/ethernet any more. As my roku m500 doesn't support WPA I didn't even plan on using the wireless connection. Before the upgrade I could listen to iternet radio on via cable and the wireless card was inserted too. After upgrade - dead end. Because I'm using WPA on the router I couldn't connect to wireless (but Roku obviously decided this is the ONLY way to connect to the network), and when checking the Etehrnet status, the message I got was: "The ethernet port is disabled". Tried rebooting the router, unplugging the cable, resetting the unit and such, but the magic line was: "If your m500 has a removable wireless card, you must remove the wireless card to use ethernet."

After removing, Roku connected (and immediately found yet an update 3.0.... that I intentionally skipped : )
Then it found the Plex Media Server running on Synology as well - everything seems to be working now. If somebody is SURE the latest firmware update 3.0.something is OK and working on the m500, please let me know (I'm using 2.7.78 now). Cheers! N.

Who is online

Users browsing this forum: No registered users and 8 guests