Your Digital Media Has Never Looked So Good

 
ismarketing
Topic Author
Posts: 59
Joined: Fri Jun 23, 2006 8:22 am

Warning - New iTunes 7.7 Can't Playback

Thu Jul 10, 2008 7:32 am

Just upgraded to the newest version of iTunes this morning and none of my Sound bridges will play any files. I can browse just fine, but selecting anything for playback (mp3 or apple lossless) causes the SB to reboot.

Have we lost iTunes compatability, or is there a fix for this?
 
grommet
Posts: 1718
Joined: Thu Dec 16, 2004 9:31 pm
Location: S.F. Bay Area, CA

Thu Jul 10, 2008 10:31 am

I can't confirm the incompatibility until later, but be aware if Apple did "break" something... it might be a long wait for a solution. :?

Either don't upgrade (which isn't an option for iPhone 2.0 users), or use another server... likely Firefly for iTunes centric users.
 
dupondt
Posts: 1653
Joined: Sun Aug 19, 2007 6:46 am
Location: Germany, European Union

Thu Jul 10, 2008 10:31 am

Hi ismarketing,

for testing reasons I just upgraded iTunes on my Mac to version 7.7 and can confirm the issue you describe. Browsing and searching works, trying to play results in the Soundbridge showing "Preparing to play" for some seconds and then rebooting (Soundbridge is an M1001 with firmware version 3.0.44).

The tracks play A/OK via Firefly (on the same Mac as iTunes) and Twonky (on the NAS).

Greetings
dupondt
SoundBridge M1001 and M1000 • Clint L1 (retired) • DNT IP-dio (retired)
Google Chromecast • Amazon Fire TV • Amazon Echo and Echo Dot
 
RokuLyndon

Thu Jul 10, 2008 12:17 pm

It appears some ipod users are having problems with 7.7 as well...

http://www.macfixit.com/article.php?sto ... 0104108497
 
ismarketing
Topic Author
Posts: 59
Joined: Fri Jun 23, 2006 8:22 am

Thu Jul 10, 2008 12:21 pm

Thanks others and RokuLyndon. Can the Roku support staff confirm the issue at your end?

For what it's worth, a downgrade to iTunes 7.6 (both the application and the library file) fixed the problem instantly. Thank goodness for time machine.
 
S80_UK
Posts: 1035
Joined: Wed Oct 25, 2006 3:11 am
Location: Cambridgeshire, UK

Thu Jul 10, 2008 4:51 pm

Not the first time Apple have done this of course. Many of us remember the painful delay when Apple did this to Roku last time. And of course they have a good history of breaking compatibility between iPod and third-party products as well. Moral - if you don't need to upgrade, then don't.
Roku M1000, M1001, M2000, R1000, Roberts WM-201, Stream 83i
 
JustMike
Posts: 96
Joined: Wed Sep 19, 2007 10:55 pm

Thu Jul 10, 2008 5:50 pm

Howdy,

I did a little investigation (what little I can as a non-Roku guy), and here's what I've determined.

It looks as though, for whatever reason, when SoundBridge tries to fetch the data for any track in the library, it gets data for one specific song (i.e. no matter what song you try to get data for, you get this one song).

This has two side effects:

1) If the song whose data you get is of the same format as the one you're trying to play, then the track will play, but the displayed information will be incorrect.

2) If the song whose data you get is in a different format (different codec), then the track will fail to play, because the SoundBridge is trying to use the wrong codec.

I've passed this info along to some friends at Apple, and I'm sure Roku will be reporting the issue directly as well.

This could be an iTunes bug, or it could be that a change in iTunes has revealed a latent SoundBridge bug. As Roku and Apple investigate, I'm sure we'll find out which it is...

Hope this sheds a little light.
Formerly "RokuMike", but these opinions are mine alone.
 
jhanlon
Posts: 23
Joined: Thu Nov 16, 2006 1:46 pm

Thu Jul 10, 2008 6:49 pm

Thanks "Formerly" RokuMike ... we'll watch for feedback from Roku (if they're doing anything other than Netflix.)
Jim Hanlon
 
MacAl
Posts: 189
Joined: Fri Dec 03, 2004 6:38 pm

Thu Jul 10, 2008 7:12 pm

For what it's worth, a downgrade to iTunes 7.6 (both the application and the library file) fixed the problem instantly. Thank goodness for time machine.


Which library files did you restore with Time Machine? I must have missed some because I get the error message "The file 'iTunes Library' cannot be read because it was created by a newer version of iTunes."

--------
Later:
Another attempt and I found the file: Music/iTunes/iTunes Library. All is well again thanks to Time Machine and the good advice on this forum.
 
RokuDaveC

Fri Jul 11, 2008 4:48 am

Hi all,

We've found the problem and will post a fix as soon as it's been thoroughly tested. The new iTunes release seems to have got picky over some ordering of statements within the URL used to get the song information back. Looks like an iTunes bug, but it may be that they've tightened up the spec...

DaveC.
 
ismarketing
Topic Author
Posts: 59
Joined: Fri Jun 23, 2006 8:22 am

Excellent News

Fri Jul 11, 2008 7:37 am

Thanks Dave. Great to see such a quick response from team Roku.
 
JustMike
Posts: 96
Joined: Wed Sep 19, 2007 10:55 pm

Fri Jul 11, 2008 9:58 am

Nice! :)
Formerly "RokuMike", but these opinions are mine alone.
 
igby
Posts: 11
Joined: Thu Nov 04, 2004 4:25 pm
Location: Chicago

Gah!

Fri Jul 11, 2008 9:16 pm

Yeah, well, I thought that my iFone 3G purchase (and subsequent upgrade to 7.7) was totally awesome. Until I ran into this behavior. Actually, my M2k and M1k will both browse fine, play 2-3 minutes of the first song in a playlist, only to reboot unceremoniously.

I eagerly anticipate erudite replies and a fix!
 
dupondt
Posts: 1653
Joined: Sun Aug 19, 2007 6:46 am
Location: Germany, European Union

Sat Jul 12, 2008 1:42 am

igby,

as a (temporary) workaround you can install Firefly.

Greetings
dupondt
SoundBridge M1001 and M1000 • Clint L1 (retired) • DNT IP-dio (retired)
Google Chromecast • Amazon Fire TV • Amazon Echo and Echo Dot
 
dbdemigod
Posts: 2
Joined: Sat Jul 12, 2008 9:20 am

How to get/install Firefly

Sat Jul 12, 2008 9:26 am

dupondt,

I found a link to SourceForge and DL'ed some DAAPD daemon, but it is so Unix-centric I can't figure out what I'm supposed to do with the files!

I'm no techno-geek - just want my Soundbridge to work again. Any assistance you can provide to get Firefly running on my iMac is greatly appreciated!

Thanks,
dbdemigod

Who is online

Users browsing this forum: No registered users and 4 guests