Your Digital Media Has Never Looked So Good

 
PinkiPie

SoundBridge and Plextor/Zyxel Problems

Mon Aug 22, 2011 6:56 am

Hello,

i have an SoundBridge M1001 and an Plextor NAS:PX-NAS4 (Zyxel NSA-2400/2401).
I want to stream my Music via LAN-Cable from NAS to the SB.

The MediaServer share on the NAS is opend to public and could accessed by any other
client ( MusicMatch, Windows MP are all OK ).

The MediaServer running has the following capabilities:
- DLNA 1.5
- UPnP AV
- iTunes

The SoundBridge "recognizes & shows" the NAS-Server but could not connect.

I TelNeted to the RCP-Shell and fiddled out that the server did not respond on the SoundBridge
requests. ( ServerConnect = ConnectionFailedNoContact ).

I found out that my Plextor NAS is the same piece of Hardware like the Zyxel NSA-2400/2401 wich
make all big problems with Roku-Hardware. ( Search over in the Forum: Zyxel Problems... )

What could be done ? Any ideas ? Should I use a crossover-cable ( 1GBit NAS to SB )?
Did anybody have the 3.0.52 PublicBeta Image for the SB to try ?
 
jjaf
Posts: 709
Joined: Thu Sep 18, 2008 5:49 am
Location: Epping Forest (bordering London), UK

Re: SoundBridge and Plextor/Zyxel Problems

Wed Aug 31, 2011 9:23 am

You may be confusing the NAS "folder share" used by those other media players to see the tracks on the NAS file system, with the NAS Mediaserver "library sharing" permissions. Look for possible permissions in the NAS Mediaserver library configuration that need to be set to allow it to respond to the Soundbridge. You will find similar permission options on WMP and iTunes.
R1000, M400, M1001
 
PinkiPie

Re: SoundBridge and Plextor/Zyxel Problems

Sat Sep 03, 2011 12:22 pm

Oh, i don´t want to confuse:

I know a share is only a set of access permissions mapped to a folder.
That´s exactly what i get whan i make a share and open it to public for the internal PX-NAS4 MediaServer.

But I´ve also tryed your hint to look for granting more permissions:

1. makeing a "share" and published this to the MediaServer
2. used the Advanced Share Access configuration
3. added (1)EVERYONE, (2)ANONYMOUS, (3)GUESTUSER & (4)ADMIN rights to this share...
- i think in most cases (1) should be enough at all.
4. copied some music stuff.
5. nothing changed; the SB couldn´t go through.

Do one know what USER & RIGHTS the SoundBridge expected ?
 
dupondt
Posts: 1653
Joined: Sun Aug 19, 2007 6:46 am
Location: Germany, European Union

Re: SoundBridge and Plextor/Zyxel Problems

Sat Sep 03, 2011 1:00 pm

Hi PinkiPie,

a belated welcome to the forums.

Do one know what USER & RIGHTS the SoundBridge expected ?

As the SoundBridge isn't capable of accessing network shares, file or folder permissions on the NAS are completely irrelevant. Setting special permissions for the media server software shouldn't be necessary, either.

It looks as though your SoundBridge might be puzzled by the fact that the UPnP-AV server and the iTunes server on the NAS are active at the same time. Furthermore the iTunes server on the NAS might be incompatible with the SoundBridge.

MusicMatch and WMP only see the UPnP-AV server, they can't connect to the iTunes server. The SoundBridge will see both servers and therefore should display two entries if you choose "Change Library or Configuration".

To resolve the issue you could try the following:

1) Enable the UPnP-AV server and disable the iTunes server on the NAS and check if the SoundBridge can connect to the UPnP-AV server (you might have to reboot both the NAS and the SoundBridge).

2) Disable the UPnP-AV server and enable the iTunes server on the NAS and check if the SoundBridge can connect to the iTunes server (again you might have to reboot both the NAS and the SoundBridge).

3) Enable streaming in WMP on your computer and check if the SoundBridge can connect to WMP.

If these steps don't resolve the problem please post the following information here:

a) the make and model of your router;
b) the connection between the router and the NAS (wired/wireless);
c) the brand of your SoundBridge (Roku/Pinnacle);
d) your SoundBridge's software version.

Greetings
dupondt
SoundBridge M1001 and M1000 • Clint L1 (retired) • DNT IP-dio (retired)
Google Chromecast • Amazon Fire TV • Amazon Echo and Echo Dot
 
PinkiPie

Re: SoundBridge and Plextor/Zyxel Problems

Sat Sep 03, 2011 4:27 pm

Good day to you dupont,

your hints make sense, but i couldn´t enable UVPnP-AV or iTunes features on my NAS.
( ...i searched for them the first time i installed the NAS...)

The NAS has a minimal "very userfriendly" Interface. No chance, only ON/OFF checking music,
videos or photos to be shared by the MediaServer & MediaServer ON/OFF.

I connected a BELKIN N1 router first via cable then by WiFi between NAS and SB and
disabled UPnP at the router-Level. Same as before...
But please keep in mind that i want to connect the SB and the NAS without a router in the middle.

It seems it´s a pinnacle SoundBridge M1001 powered by Roku. The software Version is 3.044.

Greetings PinkiPie

(PS: In early days the SB was wireless connected to the same router but with a cheap & sluggish
Phillips NAS, this worked fine. UPnP was allways disabled at the router )
 
dupondt
Posts: 1653
Joined: Sun Aug 19, 2007 6:46 am
Location: Germany, European Union

Re: SoundBridge and Plextor/Zyxel Problems

Sun Sep 04, 2011 11:55 am

PinkiPie wrote:
The NAS has a minimal "very userfriendly" Interface. No chance, only ON/OFF checking music,
videos or photos to be shared by the MediaServer & MediaServer ON/OFF.

That doesn't look good. As there's no manual available for download I can't help you any further, I'm afraid.

But please keep in mind that i want to connect the SB and the NAS without a router in the middle.

You mean by directly connecting the SoundBridge and the NAS with an ethernet cable?

It seems it´s a pinnacle SoundBridge M1001 powered by Roku. The software Version is 3.044.

That's fine, your SoundBridge runs the latest official software (3.0.52 is a beta and doesn't offer any additional features).

Pinnacle branded SoundBridges, however, won't work with iTunes and might not be compatible with the "iTunes server" on your NAS which presumably is a piece of software called mt-daapd.

(PS: In early days the SB was wireless connected to the same router but with a cheap & sluggish Phillips NAS, this worked fine. UPnP was allways disabled at the router )

UPnP on the router and UPnP-AV are different things, enabling or disabling the router's UPnP option should not interfere with media streaming at all.

Greetings
dupondt
SoundBridge M1001 and M1000 • Clint L1 (retired) • DNT IP-dio (retired)
Google Chromecast • Amazon Fire TV • Amazon Echo and Echo Dot

Who is online

Users browsing this forum: No registered users and 2 guests