Your Digital Media Has Never Looked So Good

 
duttonst
Topic Author
Posts: 4
Joined: Wed Oct 26, 2005 5:40 am

M1000 freezing/rebooting on certain files

Wed Oct 26, 2005 5:50 am

I just bought a Roku SoundBridge M1000 and I'm having problems getting it to play certain, specific AAC files. They generally end up causing my SB to freeze or reboot.

These are NOT protected AAC files - they were all ripped straight from CD using iTunes (versions 4.9 & 6.0) at normal 128K. It's not CD specific, it's track specific. So I have certain albums that always lock up on track 3, for example. Other AAC tracks (and all my MP3's) play just fine.

I'm using TwonkVision 2.9 as a server (on a LinkStation) and at the point that the SB freezes I start seeing the following errors on the server:

recv (10.0.0.51): Connection reset by peer 
recv (10.0.0.51): Connection reset by peer
recv (10.0.0.51): Connection reset by peer
recv (10.0.0.51): Connection reset by peer


(10.0.0.51 is the address of the M1000)

I just get "Buffering...[0%]" on the SoundBridge. Sometimes it stays there forever; sometimes it reboots after a few seconds.

If it's stuck I can usually telnet to the SB and run commands at the prompt without a problem (e.g. I can issue a reboot command).

I'm not using WiFi - the SB is connected directly to a switch.

Any ideas?

Thanks & regards,
 
davwebb
Posts: 352
Joined: Wed Aug 10, 2005 7:47 am

AAC files

Wed Oct 26, 2005 6:00 pm

I also had some tracks that wouldn't play. I deleted them and re-ripped them, and the problem went away....
 
duttonst
Topic Author
Posts: 4
Joined: Wed Oct 26, 2005 5:40 am

Thu Oct 27, 2005 12:33 am

Sadly I tried that already. I tried ripping from iTunes 4.9 & 6.0 from both a PC and a Mac, at various different bit-rates. It still always failed on the same tracks. :cry:

I tried re-ripping as mp3 and it worked fine, but that's not really an option I'd want to go down for my whole library.
 
Widescreen
Posts: 23
Joined: Fri Jun 03, 2005 4:29 am
Location: Southern Germany

Thu Nov 03, 2005 8:00 am

I didn't want to change my AACs to MP3 either. Since I only had a few, I finally did it though. I never had any problems again since I bashed all AACs out of my library... :evil:
Widescreen

1x M2000 over LAN, Optical Wire on Marantz SR7008+Canton Reference 7+Canton Sub 1200
1x M1000 over LAN, on Marantz PM7004+Canton Chrono SL 526
1x M1001 over LAN, on Marantz PM6003+Canton LE 120
iTunes (+FireFly for the M1001)
 
duttonst
Topic Author
Posts: 4
Joined: Wed Oct 26, 2005 5:40 am

Thu Nov 03, 2005 8:57 am

Actually I ended up switching to mt-daapd instead of TwonkyVision.

All my AAC's and MP3's now play perfectly. :D

Who is online

Users browsing this forum: No registered users and 1 guest