Your Digital Media Has Never Looked So Good

 
venkatareddy
Topic Author
Posts: 19
Joined: Thu Jun 29, 2017 4:56 am

Star button not working when video is playing...

Wed Jun 13, 2018 2:53 am

No popup is visible when click on star button  while video is playing in fullscreen mode please help me I am struggling from last few days I wrote the code in play button in details screen. details screen is extends from group 

[color=#009193]<component name = "DetailsScreen" extends = "Group" initialFocus="playButton" >[/color]
 
User avatar
enter0
Posts: 19
Joined: Thu May 17, 2018 8:39 am

Re: Star button not working when video is playing...

Wed Jun 13, 2018 8:56 am

Are you talking about the default behavior of the Roku Options overlay? It should override the app-specific behavior of the options/star button when and only when the Video node is in focus.

Edit: you can see some description of this behavior here. OnKeyEvent() is not fired when the Video node is in focus and the options key is pressed on the remote, because Roku is taking control of the options key to control their overlay.

Your question is a little unclear though—is the problem that this default behavior is not happening as it should (i.e. the overlay is not appearing) or that the default behavior is happening (i.e. that roku is taking control of the options button from your app when the Video node is in focus, so that you can't control what happens when the options key is pressed when a video is playing)? The former could be caused by a failure to properly put the Video node in focus or something. The latter is just something that Roku requires you to deal with I think.
 
venkatareddy
Topic Author
Posts: 19
Joined: Thu Jun 29, 2017 4:56 am

Re: Star button not working when video is playing...

Thu Jun 14, 2018 12:34 am

Yes i am talking about default behavior of the Roku Options overlay. It is not displaying when click on options / star button when the focus is on video node only even though pop up is not displayed but the remaining all other buttons(Rewind ,play/stop,ok,fastforward) working fine .I have tried so many types for getting subtitles but I am unable display the subtitles 

I have followed the below three types of code  getting subtitles and popup overlay.
one :
          videocontent = createObject("RoSGNode", "ContentNode")
           videocontent.HttpHeaders = headers
           videocontent.title = m.ContentNode_child_object.title
           videocontent.streamformat = "dash"
           subtitle_config = {
                   TrackName: “sample.srt"
                              }
           videocontent.subtitleconfig = subtitle_config
           videocontent.url = “URL”  
           m.video.content = videocontent
           m.video.control = "play"
           m.video.visible = true
           m.video.setFocus(true)
Two : 
          videocontent = createObject("RoSGNode","ContentNode")
          videocontent.HttpHeaders = headers
            videocontent.title = m.ContentNode_child_object.title
           videocontent.streamformat = "dash"
           m.video.globalCaptionMode = "On"
           m.video.subtitleTrack = "http://path.to/my/file.srt"
           videocontent.url = “URL”  
           m.video.content = videocontent
           m.video.control = "play"
           m.video.visible = true
           m.video.setFocus(true)
Third :
           videocontent = createObject("RoSGNode", "ContentNode")
           videocontent.HttpHeaders = headers
           videocontent.title = m.ContentNode_child_object.title
           videocontent.streamformat = "dash"
           videocontent.SubtitleURL= "http://path.to/my/file.srt"  
           videocontent.url = “URL”  
           m.video.content = videocontent
           m.video.control = "play". 
           m.video.visible = true
           m.video.setFocus(true)

Who is online

Users browsing this forum: No registered users and 5 guests