Your Digital Media Has Never Looked So Good

 
hmatar
Topic Author
Posts: 3
Joined: Sat Sep 02, 2017 8:09 pm

Unable to play .ts (live streaming) on my roku premiere plus

Sat Sep 02, 2017 8:13 pm

Hello, 
Unable to play .ts (live streaming) on my roku premiere plus.
the application is working fine on Roku 3.
is there any workaround for this?
Thanks. 
 
User avatar
Tyler Smith
Posts: 108
Joined: Thu Apr 14, 2016 10:51 am
Location: Nova Scotia, Canada
Contact:

Re: Unable to play .ts (live streaming) on my roku premiere plus

Tue Sep 05, 2017 5:34 am

Very interesting, do you have any DRM on the stream?
Last edited by Tyler Smith on Wed Sep 06, 2017 5:18 pm, edited 1 time in total.
Tyler Smith
Senior Developer, REDspace
redspace.com
 
coldrain
Posts: 13
Joined: Mon May 08, 2017 7:52 pm

Re: Unable to play .ts (live streaming) on my roku premiere plus

Tue Sep 05, 2017 9:20 pm

My channel have the same problem with HLS streaming (.m3u8), 2 users reported the issue with Roku Premier+ but I don't have any Roku Premier+ to troubleshoot (I tried with Roku 4, Roku stick and Express+ and they work fine). Let me know if you find out the reason.
 
hmatar
Topic Author
Posts: 3
Joined: Sat Sep 02, 2017 8:09 pm

Re: Unable to play .ts (live streaming) on my roku premiere plus

Sun Sep 10, 2017 9:46 pm

coldrain wrote:
My channel have the same problem with HLS streaming (.m3u8), 2 users reported the issue with Roku Premier+ but I don't have any Roku Premier+ to troubleshoot (I tried with Roku 4, Roku stick and Express+ and they work fine). Let me know if you find out the reason.

issue fixed by setting the streamFormat 
selectedItem.streamformat =  "ts"
this was not needed on other roku devices. 
 
coldrain
Posts: 13
Joined: Mon May 08, 2017 7:52 pm

Re: Unable to play .ts (live streaming) on my roku premiere plus

Tue Sep 12, 2017 11:47 pm

hmatar wrote:
coldrain wrote:
My channel have the same problem with HLS streaming (.m3u8), 2 users reported the issue with Roku Premier+ but I don't have any Roku Premier+ to troubleshoot (I tried with Roku 4, Roku stick and Express+ and they work fine). Let me know if you find out the reason.

issue fixed by setting the streamFormat 
selectedItem.streamformat =  "ts"
this was not needed on other roku devices. 

I didn't think that I missed to set streamformat. My streamformat is "hls" not "ts" but from your suggestion, I debug and see that I didn't set it up properly (I put the streamformat in xml feed but for some reason, the content reader doesn't get the streamformat). Thanks for sharing

Who is online

Users browsing this forum: No registered users and 3 guests