Your Digital Media Has Never Looked So Good

 
usman_itsrelevant
Topic Author
Posts: 15
Joined: Thu Feb 16, 2017 2:54 am
Location: Pakistan

logos changing from blue to orange or orange to blue

Tue Oct 10, 2017 2:07 am

On my channel on ROKU, I am facing an issue that images color change from blue to orange or orange to blue and it appears to be happening just to the images. And it’s only on certain boxes.


What can be issue?
 
rymawby
Posts: 15
Joined: Fri Jan 16, 2015 9:03 am
Contact:

Re: logos changing from blue to orange or orange to blue

Wed Oct 11, 2017 10:04 pm

Hi Usman,

Do you have a code sample I can take a look at?
---
Blogging Roku stuff at http://rymawby.com
---
 
usman_itsrelevant
Topic Author
Posts: 15
Joined: Thu Feb 16, 2017 2:54 am
Location: Pakistan

Re: logos changing from blue to orange or orange to blue

Thu Oct 12, 2017 12:00 am

rymawby wrote:
Hi Usman,

Do you have a code sample I can take a look at?

screen = CreateObject("roBitmap", {width: 1280, height: 720, AlphaEnable: True})
If screen <> Invalid
 screen.Clear(&h00000000)
        If thislogoImageURL <> Invalid And this.bitmaps[this.logoImageURL].bitmap <> Invalid
 screen.DrawScaledObject(1000, 27, 1.0, 1.0, this.bitmaps[this.logoImageURL].bitmap, &hFFFFFFC0)
 End If


This happens to only some boxes that original color of image is blue and on screen it displays orange and vice versa.
 Here is original image:  https://ibb.co/jvGnJw   (Jersey)
Resulted Image: https://ibb.co/mT7YrG (Jersey).
 
joetesta
Posts: 541
Joined: Wed Apr 20, 2011 11:48 am

Re: logos changing from blue to orange or orange to blue

Thu Oct 12, 2017 9:48 am

I used to see this in the past a lot, think it was when I was developing on a Roku 4 back prior to about 6 months ago.
Retrieved Images would load with their inverse colors, usually only the first time they were loaded / displayed, then subsequently they'd display their correct colors.
Chalked it up to a firmware bug and tried to ignore it.  Haven't seen it recently and suspect the factor was the Roku 4 device...?
aspiring
 
usman_itsrelevant
Topic Author
Posts: 15
Joined: Thu Feb 16, 2017 2:54 am
Location: Pakistan

Re: logos changing from blue to orange or orange to blue

Thu Oct 12, 2017 9:01 pm

joetesta wrote:
I used to see this in the past a lot, think it was when I was developing on a Roku 4 back prior to about 6 months ago.
Retrieved Images would load with their inverse colors, usually only the first time they were loaded / displayed, then subsequently they'd display their correct colors.
Chalked it up to a firmware bug and tried to ignore it.  Haven't seen it recently and suspect the factor was the Roku 4 device...?

I am facing this issue on Roke 2 and Roku Express devices.
 
joetesta
Posts: 541
Joined: Wed Apr 20, 2011 11:48 am

Re: logos changing from blue to orange or orange to blue

Fri Oct 13, 2017 7:39 am

Curious - do you have other Roku models that do not show the issue?  I've been developing on Roku 3 and Ultra for the past 6 months and haven't been noticing it
Perhaps it's something about the nature of the images that makes the bug possible or likely?
aspiring
 
User avatar
squirreltown
Posts: 732
Joined: Sun Apr 21, 2013 2:20 pm

Re: logos changing from blue to orange or orange to blue

Fri Oct 13, 2017 8:44 am

I looked at those images when they were posted here. There was no logic to what was happening -graphics wise.  It seems like a firmware issue to me. And given what it's priority might be, I'd start looking for other solutions.
Kinetics Screensaver (kineticsscreensaver), Kinetics³ Screensaver(kinetics3), Kinetics Painter Screensaver (kineticspainter), Kinetics Splash Screensaver (kineticssplash)
 
brybott
Posts: 40
Joined: Wed Feb 04, 2015 5:17 pm

Re: logos changing from blue to orange or orange to blue

Fri Oct 13, 2017 3:02 pm

What firmware version is this occurring on. I suspect this may be an issue with 8.0 firmware?
 
usman_itsrelevant
Topic Author
Posts: 15
Joined: Thu Feb 16, 2017 2:54 am
Location: Pakistan

Re: logos changing from blue to orange or orange to blue

Sun Oct 15, 2017 9:10 pm

brybott wrote:
What firmware version is this occurring on. I suspect this may be an issue with 8.0 firmware?

Software version is 7.7.0
 
joetesta
Posts: 541
Joined: Wed Apr 20, 2011 11:48 am

Re: logos changing from blue to orange or orange to blue

Mon Oct 16, 2017 6:02 pm

I was seeing it a year ago, I guess that was 7.0
aspiring

Who is online

Users browsing this forum: No registered users and 9 guests