Your Digital Media Has Never Looked So Good

 
mwittl
Topic Author
Posts: 3
Joined: Thu Nov 09, 2017 9:43 am

LabelList icons not rendered in correct location

Thu Nov 09, 2017 10:25 am

Using a LabelList with icons and titles with about 180 items on it, I'm having a problem with the initial rendering location of the icons and was hoping someone could point me in the right direction?  When the list is first rendered, the expected behavior is the icon will be rendered to the left of the title.  What I am experiencing is the icons are initially rendering below and to the right of the start position of the title.  If I use the UP key on the remote...they all get placed correctly.  Does anyone have any thoughts on how to get these icons rendered in the correct location when the LabelList is first rendered?
 
adrianc1982
Posts: 89
Joined: Thu Jun 05, 2014 6:02 pm

Re: LabelList icons not rendered in correct location

Thu Nov 09, 2017 11:51 am

im having the same issue it seems like labellist is broken on roku os 8
 
mwittl
Topic Author
Posts: 3
Joined: Thu Nov 09, 2017 9:43 am

Re: LabelList icons not rendered in correct location

Thu Nov 09, 2017 12:11 pm

adrianc1982 wrote:
im having the same issue it seems like labellist is broken on roku os 8

Do you know if it worked correctly before v8?  This is my 1st use of a LabelList with icons so I don't know how it worked prior to the current firmware version.  It's definitely screwy!
 
mwittl
Topic Author
Posts: 3
Joined: Thu Nov 09, 2017 9:43 am

Re: LabelList icons not rendered in correct location

Fri Nov 10, 2017 1:28 pm

mwittl wrote:
adrianc1982 wrote:
im having the same issue it seems like labellist is broken on roku os 8

Do you know if it worked correctly before v8?  This is my 1st use of a LabelList with icons so I don't know how it worked prior to the current firmware version.  It's definitely screwy!

Well, it doesn't work correctly on 7.70 either.  I found one of my Roku devices with the 7.70 on it and tried.  When the LabelList is first rendered, the icons are still misplaced.  The behavior when the up key is pressed is even stranger than the v8 firmware.  With 7.70,  the icons get resized back to their original size and then fall into place.  Basically, I believe the icon feature of a LabelList is worthless.

Who is online

Users browsing this forum: No registered users and 21 guests