Your Digital Media Has Never Looked So Good

 
venkatareddy
Topic Author
Posts: 20
Joined: Thu Jun 29, 2017 4:56 am

progress bar is not diplaying in video

Thu Feb 08, 2018 5:11 am

Progress bar is not visible for the first video. When I press back button and play the video again, progress bar is visible.
 
DadOfTwo
Posts: 26
Joined: Thu Feb 02, 2017 8:11 am
Contact:

Re: progress bar is not diplaying in video

Thu Feb 08, 2018 10:13 am

There's not enough information to help with this.

Can you post some example code to give us a clue?
Roku BrightScript Developer - https://www.linkedin.com/in/charlieabbott/
 
venkatareddy
Topic Author
Posts: 20
Joined: Thu Jun 29, 2017 4:56 am

Re: progress bar is not diplaying in video

Thu Feb 08, 2018 10:46 pm

We have the home panel. In home panel we have rowList if we click on rowlist we shows Details Screen in detailsScreen we have the play button if we click on play button video play 

Sub OnContentChange()
    videocontent = createObject("RoSGNode", "ContentNode")
    videocontent.title = "testTitle"
     videocontent.streamformat = "mp4"
    videocontent.url = "http://roku.content.video.llnw.net/smedia/59021fabe3b645968e382ac726cd6c7b/Gb/siCt-V7LOSU08W_Ve1ByJY5N9emKZeXZvnrH2Yb9c/117_segment_2_twitch__nw_060515.mp4"
    m.video.content = videocontent
End Sub

function playButtonClick() as void
            m.video.visible = true
            m.video.setFocus(true)
            m.video.control = "play"
            m.video.observeField("state", "OnVideoPlayerStateChange")
end function
 
DadOfTwo
Posts: 26
Joined: Thu Feb 02, 2017 8:11 am
Contact:

Re: progress bar is not diplaying in video

Fri Feb 09, 2018 9:36 am

Hi

The param on the Video Node to display the video progress bar is called enableUI.

You can define this in the XML in SG:

<Video id="videoId" enableUI="true" />    


Or in your embedded Script or .brs file:

sub init()
  m.video = m.top.findNode("videoId")
  m.video.enableUI = true
end sub
Roku BrightScript Developer - https://www.linkedin.com/in/charlieabbott/
 
venkatareddy
Topic Author
Posts: 20
Joined: Thu Jun 29, 2017 4:56 am

Re: progress bar is not diplaying in video

Tue Mar 13, 2018 12:49 am

Hi 
I have already used EnableUi in xml file but progress bar is not displaying

Who is online

Users browsing this forum: RokuBen and 5 guests