Your Digital Media Has Never Looked So Good

 
lylyahiko
Topic Author
Posts: 1
Joined: Tue Oct 30, 2018 9:57 am

Dash format videos not properly grabbing duration

Fri Dec 28, 2018 6:40 am

Hello,

I've been working with quite a problem. It appears as though the durations for my videos aren't being loaded properly. When the video plays it shows 5hr 45min. The video.duration = 1.844674407371e+16 

The encoding type is PlayReady: LA And Challenge. When downloading the .mpd the duration seems to be properly set but when using the tool [color=#367fee]http://devtools.web.roku.com/stream_tester/html/index.html it seems as though the duration isn't properly set.[/color]

I've submitted a request via partnersuccess but am looking for a work around in the mean time. Has anyone else experienced this before?
 
renojim
** Valued Community Member **
Posts: 3399
Joined: Mon Feb 15, 2010 1:35 pm

Re: Dash format videos not properly grabbing duration

Fri Dec 28, 2018 10:46 am

I know nothing about PlayReady, DASH, or MPDs, but I'd be willing to bet that video.duration should be an integer representing the duration in seconds.  1.844674407371e+16 seconds is many, many, millennia.

-JT
 
lukechinworth
Posts: 2
Joined: Mon Dec 17, 2018 3:39 pm

Re: Dash format videos not properly grabbing duration

Mon Jan 07, 2019 2:20 pm

I am having this same problem. Haven't found a solution yet. My Smooth Streaming assets return the correct duration.

Who is online

Users browsing this forum: No registered users and 12 guests