Your Digital Media Has Never Looked So Good

 
sujithdb
Topic Author
Posts: 9
Joined: Tue Jan 15, 2019 9:20 am

RAF.err handleAdError(); render failure 0: failed to create media player

Wed Apr 17, 2019 5:46 am

Hello,

I am implementing RAF [using this sample: https://github.com/rokudev/SceneGraphDeveloperExtensions/tree/master/samples/Roku_Recommends]. When playing back to back videos automatically, I am randomly getting the following error and then the video does NOT appear.

[RAF] showAds(): rendering preroll pod of 1 ads
[RAF] render.renderTypeChanged("client-inserted")
[RAF.err] handleAdError(); render failure 0: failed to create media player


Any help on fixing this is really appreciated.

Thanks.
 
sujithdb
Topic Author
Posts: 9
Joined: Tue Jan 15, 2019 9:20 am

Re: RAF.err handleAdError(); render failure 0: failed to create media player

Thu Apr 25, 2019 5:15 am

Update:
I noticed that when you are playing a group of videos (example Comedy category where each video play one after the other), the error happens ONLY for the first video. There would be sound, but no visuals. If we just press BACK in remote and play again, it will work perfectly for the entire group of videos along with showing the Ads before each video.
 
gomad
Posts: 56
Joined: Wed Nov 29, 2017 4:07 am

Re: RAF.err handleAdError(); render failure 0: failed to create media player

Wed May 08, 2019 3:24 am

Are you reinitialising the player/RAF everytime for every video?

Who is online

Users browsing this forum: No registered users and 3 guests