Your Digital Media Has Never Looked So Good

 
nowhereman
Topic Author
Posts: 561
Joined: Thu Oct 19, 2006 4:02 pm
Location: AZ
Contact:

Startup Delay with Streaming Audio

Wed Mar 31, 2010 8:47 am

As most of you know, I'm building an Internet Radio channel and I've run into some interesting behavior. It seems as though the longer you use the channel, the longer it takes for a given stream to start playing. When you first launch the channel, streams start almost immediately, but after listening to other streams for a while, those same streams can take several seconds and in some cases minutes to start playing. It's almost as if the player is silently playing out any existing buffered data before it will start playing the new stream.

I've experimented with the streambitrates to no avail

I have tried different combinations of calling the AudioPlayer's Stop() and ClearContent() functions between streams with no luck.

I've seen others mention similar behaviors, but I have not seen anyone come up with a fix. Am I doing something wrong or is this an issue with the box itself? If the latter, is there a fix coming? And is there any sort of workaround?
twitter:nowhereman
http://www.thenowhereman.com/roku
http://www.thenowhereman.com/netflix
 
Narsh
Posts: 30
Joined: Thu Feb 18, 2010 11:13 am

Re: Startup Delay with Streaming Audio

Wed Mar 31, 2010 12:19 pm

I've been wondering about this and searching for a fix too. If there is a way to assure the audio plays promptly I hope someone will post the solution here. Do any of the Roku devs have any advice on this issue?
 
hotw00
Posts: 71
Joined: Mon Jul 13, 2009 11:26 am

Re: Startup Delay with Streaming Audio

Fri Apr 02, 2010 2:54 pm

I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.
 
RokuPatrick

Re: Startup Delay with Streaming Audio

Fri Apr 02, 2010 3:07 pm

Looking into it.
 
nowhereman
Topic Author
Posts: 561
Joined: Thu Oct 19, 2006 4:02 pm
Location: AZ
Contact:

Re: Startup Delay with Streaming Audio

Fri Apr 02, 2010 4:19 pm

hotw00 wrote:
I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.


Roku did PM me shortly after my original post. They have actually done quite a bit to support and encourage my development efforts.
twitter:nowhereman
http://www.thenowhereman.com/roku
http://www.thenowhereman.com/netflix
 
hotw00
Posts: 71
Joined: Mon Jul 13, 2009 11:26 am

Re: Startup Delay with Streaming Audio

Sat Apr 03, 2010 7:43 am

nowhereman wrote:
hotw00 wrote:
I'm stunned there hasn't been a response on this from the Roku team. I'm hoping they've PM'd you about the problem privately.

For all the work you've done on the excellent channels you've been working on I would've expected at least a "We'll PM you" nod from the devs.

Keep up the great work on your channels, by the way. You've turned this device from a wonderful movie machine to an "Oh my God I don't want to live without it" gadget.


Roku did PM me shortly after my original post. They have actually done quite a bit to support and encourage my development efforts.


I was hoping that was the case.

Thanks for your contribution to this device/platform, nowhereman. We're enjoying some streaming Whole Wheat Radio via RadioTime on this Saturday morning.

Thanks dev team and Roku management for deciding to build your product with an open model for independent/private channel development!
 
Narsh
Posts: 30
Joined: Thu Feb 18, 2010 11:13 am

Re: Startup Delay with Streaming Audio

Mon Apr 05, 2010 10:19 am

RokuPatrick wrote:
Looking into it.

Thank you, Patrick. I hope you will share your findings here for other developers to see as well as in the PMs to nowhereman.
 
renojim
** Valued Community Member **
Posts: 3481
Joined: Mon Feb 15, 2010 1:35 pm

Re: Startup Delay with Streaming Audio

Wed Jun 09, 2010 1:28 pm

Has this issue been fixed with the latest firmware? I don't see it occurring anymore, but it was kind of intermittent in the first place.

-JT
 
RokuPatrick

Re: Startup Delay with Streaming Audio

Wed Jun 09, 2010 1:39 pm

renojim wrote:
Has this issue been fixed with the latest firmware? I don't see it occurring anymore, but it was kind of intermittent in the first place.

-JT

It's been improved considerably if not outright fixed.
 
renojim
** Valued Community Member **
Posts: 3481
Joined: Mon Feb 15, 2010 1:35 pm

Re: Startup Delay with Streaming Audio

Wed Jun 09, 2010 5:51 pm

Thanks. It's definitely much better and like I said I haven't seen a case of buffering taking a long time since the new firmware.

Thanks for your efforts!
-JT

Who is online

Users browsing this forum: No registered users and 3 guests