Your Digital Media Has Never Looked So Good

 
cgerrish
Topic Author
Posts: 24
Joined: Mon May 17, 2010 4:59 pm

HLS won't play in VideoPlayer Example

Sun Aug 15, 2010 7:28 am

I have gotten HLS and VOD to work with the simplevideoplayer example. I have VOD working on the VIdeoPlayer example, but when I try to do do HLS streaming with the video player example it doesn't work. Am I missing anything here? I changed the format to hls, and put in my link just like in the simple video player, but it just tries to load the stream, and then backs back out right away. I get this error, and ideas?
showHomeScreen | msg = An unexpected problem (but not server timeout or HTTP error) has been detected. | index = -3
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Re: HLS won't play in VideoPlayer Example

Sun Aug 15, 2010 11:45 am

The stream may not be in the correct format for the Roku. See RokuMarkn's comments here: viewtopic.php?f=34&t=31056#p190110
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
 
cgerrish
Topic Author
Posts: 24
Joined: Mon May 17, 2010 4:59 pm

Re: HLS won't play in VideoPlayer Example

Sun Aug 15, 2010 12:35 pm

Thanks, I know it works on the Roku because it works in the simplevideoplayer example, but my stream and the apple test stream won't work with the videoplayer example.
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Re: HLS won't play in VideoPlayer Example

Sun Aug 15, 2010 1:28 pm

Oops. Sorry. I missed that part.

The videoplayer example defaults the StreamFormat to "mp4" if it's not present in the feed XML. Is it possible that the StreamFormat is either missing, or not set to "hls" in your metadata?
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
 
cgerrish
Topic Author
Posts: 24
Joined: Mon May 17, 2010 4:59 pm

Re: HLS won't play in VideoPlayer Example

Sun Aug 15, 2010 4:44 pm

Ah, thank you! I figured it out. I had my <streamFormat> tag in the <media> section of the xml data so it didn't see it.

Who is online

Users browsing this forum: No registered users and 1 guest