Your Digital Media Has Never Looked So Good

 
User avatar
bbrouse
Topic Author
Posts: 78
Joined: Mon Apr 11, 2011 10:48 am

Poster Nodes not displaying after screensaver

Wed Sep 14, 2016 10:16 am

We're seeings some issues with poster nodes after screensavers are dismissed. The poster will display correctly, but upon re-entering the channel after a screensaver is exited the poster node disappears. Has anyone else run into this issue, and if so is there a fix in place?
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Re: Poster Nodes not displaying after screensaver

Wed Sep 14, 2016 10:52 am

If you observe the poster's "loadStatus", do you get a "failed" result?  If so, you could trigger a reload based on that.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
 
User avatar
RokuJoel
Posts: 1758
Joined: Mon Nov 14, 2011 5:22 pm

Re: Poster Nodes not displaying after screensaver

Wed Sep 14, 2016 2:48 pm

I have filed a bug ticket on this. Ideally if you can get me a sample app that demonstrates the problem it would be helpful.

 - Joel
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Re: Poster Nodes not displaying after screensaver

Wed Sep 14, 2016 10:54 pm

Hey Joel, it's worth noting that I've seen the same behavior after returning from full-screen video playback.  In that case, I get a "failed" loadStatus.  Resetting the uri of the Poster node forces it to reload.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
 
User avatar
bbrouse
Topic Author
Posts: 78
Joined: Mon Apr 11, 2011 10:48 am

Re: Poster Nodes not displaying after screensaver

Fri Sep 16, 2016 11:17 am

It seems to be pretty intermittent, and we've had trouble reproducing the problem consistently. Once we nail down a pattern I can provide some sample code.

To add to TheEndless' comment, we do have a full screen video node present in the first scene we display. That may be related.

Who is online

Users browsing this forum: No registered users and 6 guests